fix debian packages generation (invalid warning silencing)
[vpp.git] / build-root / deb / debian / rules
index 4ecd38f..39be1b5 100755 (executable)
@@ -16,15 +16,23 @@ include /usr/share/dpkg/default.mk
 # package maintainers to append LDFLAGS
 #export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
 
+export PYBUILD_NAME = vpp-api-python
+export PYBUILD_DIR = ../../src/vpp-api/python
+export PYBUILD_DESTDIR_python2=debian/vpp-api-python/
+export PYBUILD_DISABLE_python2=test
+export PYBUILD_SYSTEM=distutils
+
 # main packaging script based on dh7 syntax
 %:
-       dh $@ --with dkms --with systemd,python2
+       dh $@ --with systemd,python2 --buildsystem=pybuild
 
 override_dh_install:
        dh_install --exclude .git
+       ../scripts/remove-rpath .
+
+override_dh_shlibdeps:
+       @dh_shlibdeps 2>&1 \
+         | { grep -v -e "probably a plugin" -e "similar warnings have been skipped" || true; }
 
 override_dh_strip:
        dh_strip --dbg-package=vpp-dbg
-
-override_dh_dkms:
-       dh_dkms -pvpp-dpdk-dkms