deb: fix issues in debian/control, silence some warnings
[vpp.git] / build-root / deb / debian / rules
index bcee012..4c84fc3 100755 (executable)
@@ -18,10 +18,16 @@ include /usr/share/dpkg/default.mk
 
 # main packaging script based on dh7 syntax
 %:
-       dh $@ --with dkms
+       dh $@ --with dkms --with systemd,python2
 
 override_dh_install:
        dh_install --exclude .git
+       ../scripts/remove-rpath .
+
+override_dh_shlibdeps:
+       @dh_shlibdeps 2>&1 \
+         | grep -v "probably a plugin" \
+         | grep -v "similar warnings have been skipped"
 
 override_dh_strip:
        dh_strip --dbg-package=vpp-dbg