Remove RPATH from binaries before creating .deb and .rpm packages
[vpp.git] / build-root / rpm / vpp.spec
index 4a35134..ed38234 100644 (file)
@@ -26,7 +26,7 @@ License: MIT
 Version: %{_version}
 Release: %{_release}
 Requires: vpp-lib = %{_version}-%{_release}, net-tools, pciutils, python
-BuildRequires: systemd
+BuildRequires: systemd, chrpath
 
 Source: %{name}-%{_version}-%{_release}.tar.gz
 
@@ -189,6 +189,11 @@ do
        install -p -m 644 $file %{buildroot}/usr/share/vpp/api
 done
 
+#
+# remove RPATH from ELF binaries
+#
+%{_mu_build_dir}/scripts/remove-rpath %{buildroot}
+
 %post
 sysctl --system
 %systemd_post vpp.service