Add MAC address support to LISP map-cache
[vpp.git] / build-root / rpm / vpp.spec
index ddcdeb9..4a666e6 100644 (file)
@@ -1,4 +1,4 @@
-%define _vpp_install_dir ../install-vpp-native
+%define _vpp_install_dir ../%{_install_dir}
 %define _vpp_build_dir   ../build-tool-native
 %define _unitdir         /lib/systemd/system
 %define _topdir          %(pwd)
@@ -14,10 +14,10 @@ Release: %{_release}
 Requires: vpp-lib = %{_version}-%{_release}, net-tools, pciutils
 
 %description
-This package provides VPP executables: vpe, vpe_api_test, vpe_json_test
-vpe - the vector packet engine
-vpe_api_test - vector packet engine API test tool
-vpe_json_test - vector packet engine JSON test tool
+This package provides VPP executables: vpp, vpp_api_test, vpp_json_test
+vpp - the vector packet engine
+vpp_api_test - vector packet engine API test tool
+vpp_json_test - vector packet engine JSON test tool
 
 %package lib
 Summary: VPP libraries
@@ -49,6 +49,10 @@ allocator (mheap.c), extendable printf-like interface built on top of vectors
 time-based function calls (timer.c).
 TODO: reference and describe only the .h files
 
+%pre
+# Add the vpp group
+groupadd -f -r vpp
+
 %install
 #
 # binaries
@@ -63,7 +67,7 @@ install -p -m 755 %{_vpp_build_dir}/vppapigen/vppapigen %{buildroot}%{_bindir}
 mkdir -p -m755 %{buildroot}/etc/vpp
 mkdir -p -m755 %{buildroot}/etc/sysctl.d
 install -p -m 644 vpp.service %{buildroot}%{_unitdir}
-install -p -m 644 ../../vpp/conf/startup.conf %{buildroot}/etc/vpp
+install -p -m 644 ../../vpp/conf/startup.uiopcigeneric.conf %{buildroot}/etc/vpp/startup.conf
 install -p -m 644 ../../vpp/conf/80-vpp.conf %{buildroot}/etc/sysctl.d
 #
 # libraries
@@ -111,8 +115,9 @@ sysctl --system
 %files
 %defattr(-,bin,bin)
 %{_unitdir}/vpp.service
-/usr/bin/vpe*
+/usr/bin/vpp*
 /usr/bin/svm*
+/usr/bin/elftool
 %config /etc/sysctl.d/80-vpp.conf
 %config /etc/vpp/startup.conf