Implemente terse DEB_BUILD_OPTIONS
[deb_dpdk.git] / debian / rules
index 60fa3e0..3d35e1c 100755 (executable)
@@ -1,8 +1,4 @@
 #!/usr/bin/make -f
-# See debhelper(7) (uncomment to enable)
-# output every command that modifies files on the build system.
-export DH_VERBOSE=1
-export DH_OPTIONS=-v
 
 # see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
 include /usr/share/dpkg/default.mk
@@ -17,6 +13,11 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all,-pie
 DPKG_EXPORT_BUILDFLAGS = 1
 include /usr/share/dpkg/buildflags.mk
 
+ifeq (,$(findstring terse,$(DEB_BUILD_OPTIONS)))
+       export DH_VERBOSE=1
+       export DH_OPTIONS=-v
+endif
+
 # Support backporting to jessie
 dpkg_version_lt = $(shell dpkg --compare-versions $$(dpkg --status dpkg-dev | grep Version | cut -d' ' -f2) lt-nl "1.18.11" && echo yes)
 ifeq (yes, $(dpkg_version_lt))
@@ -56,6 +57,12 @@ RTE_MACHINE ?= "armv8a"
 RTE_TARGET ?= "arm64-armv8a-linuxapp-gcc"
 INCLUDE_ARCH := arm
 else
+ifneq (,$(filter $(DEB_HOST_ARCH), armhf))
+DPDK_CONFIG ?= "arm-armv7a-linuxapp-gcc"
+RTE_MACHINE ?= "armv7a"
+RTE_TARGET ?= "arm-armv7a-linuxapp-gcc"
+INCLUDE_ARCH := arm
+else
 ifneq (,$(filter $(DEB_HOST_ARCH), ppc64el))
 DPDK_CONFIG ?= "ppc_64-power8-linuxapp-gcc"
 RTE_MACHINE ?= "power8"
@@ -68,6 +75,7 @@ RTE_TARGET ?= "$(DEB_HOST_GNU_CPU)-default-linuxapp-gcc"
 INCLUDE_ARCH := x86
 endif
 endif
+endif
 DPDK_STATIC_DIR = "debian/build/static-root"
 DPDK_SHARED_DIR = "debian/build/shared-root"
 
@@ -182,14 +190,23 @@ ifeq (,$(filter dpdk_config=%,$(DEB_BUILD_OPTIONS)))
                -e 's,(CONFIG_RTE_EAL_IGB_UIO=).*,\1$(DPDK_CONFIG_BUILD_KMOD),' \
                -e 's,(CONFIG_RTE_KNI_KMOD=).*,\1$(DPDK_CONFIG_BUILD_KMOD),' \
                -e 's,(LIBRTE_PMD_PCAP=).*,\1y,' \
-               -e 's,(CONFIG_RTE_LIBRTE_MLX4_PMD=).*,\1y,' \
-               -e 's,(CONFIG_RTE_LIBRTE_MLX5_PMD=).*,\1y,' \
                -e 's,(CONFIG_RTE_EAL_PMD_PATH=).*,\1"/usr/lib/$(DEB_HOST_MULTIARCH)/$(DPDK_DRIVER_DIR)/",' \
+               $(DPDK_STATIC_DIR)/.config
+ifeq (,$(filter $(DEB_HOST_ARCH), armhf))
+       sed -ri -e 's,(CONFIG_RTE_LIBRTE_MLX4_PMD=).*,\1y,' \
+               -e 's,(CONFIG_RTE_LIBRTE_MLX5_PMD=).*,\1y,' \
                -e 's,(LIBRTE_PMD_OPENSSL=).*,\1y,' \
                $(DPDK_STATIC_DIR)/.config
+endif
 endif
        echo "CONFIG_RTE_MAJOR_ABI=\"$(DPDK_ABI)\"" >> \
                $(DPDK_STATIC_DIR)/.config
+       # Intel IPSEC library is amd64-only
+ifneq (,$(filter $(DEB_HOST_ARCH), amd64))
+       sed -ri -e 's,(CONFIG_RTE_LIBRTE_PMD_AESNI_MB=).*,\1y,' \
+               -e 's,(CONFIG_RTE_LIBRTE_PMD_AESNI_GCM=).*,\1y,' \
+               $(DPDK_STATIC_DIR)/.config
+endif
        dh_auto_configure
 
 override_dh_auto_build-indep:
@@ -331,6 +348,11 @@ endif
            echo "MEMPOOL: linking $${LIBF} into RTE_EAL_PMD_PATH at $${LIBD}/$(DPDK_DRIVER_DIR)/"; \
            ln -s --relative --target-directory=$${LIBD}/$(DPDK_DRIVER_DIR)/ $${LIBD}/$${LIBF}; \
          fi; \
+         if [ "$${LIBF#librte_ifcvf_}x" != "$${LIBF}x" ]; then \
+           mkdir -p $${LIBD}/$(DPDK_DRIVER_DIR); \
+           echo "IFCVF: linking $${LIBF} into RTE_EAL_PMD_PATH at $${LIBD}/$(DPDK_DRIVER_DIR)/"; \
+           ln -s --relative --target-directory=$${LIBD}/$(DPDK_DRIVER_DIR)/ $${LIBD}/$${LIBF}; \
+         fi; \
          if [ "$${LIBF#librte_eal}x" != "$${LIBF}x" ]; then \
            mkdir -p $${LIBD}/$(DPDK_DRIVER_DIR); \
          fi; \