d/rules: properly enable dpdk systemd service
[deb_dpdk.git] / debian / rules
index 8ec1287..c4487ec 100755 (executable)
@@ -9,9 +9,6 @@ include /usr/share/dpkg/default.mk
 
 DPDK_ABI := $(shell echo $(DEB_VERSION_UPSTREAM) | cut -d '.'  -f1-2)
 
-DEB_HOST_GNU_CPU := $(shell dpkg-architecture -qDEB_HOST_GNU_CPU)
-DEB_HOST_MULTIARCH := $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
-
 # see FEATURE AREAS in dpkg-buildflags(1)
 export DEB_BUILD_MAINT_OPTIONS = hardening=+all,-pie
 
@@ -124,11 +121,11 @@ build:
        fi
        sh debian/prep-modules $(KSRC)
        cat debian/control.modules >> debian/control
-       dh $@ --with python2,dkms
+       dh $@ --with python2,dkms,systemd
 endif
 
 %:
-       dh $@ --with python2,dkms
+       dh $@ --with python2,dkms,systemd
 
 override_dh_gencontrol:
        dh_gencontrol