d/rules support DEB_BUILD_OPTIONS parallel
[deb_dpdk.git] / debian / rules
index e75dd98..f21cf76 100755 (executable)
@@ -22,50 +22,141 @@ export DEB_CFLAGS_MAINT_APPEND  = -fPIC
 
 include /usr/share/dpkg/buildflags.mk
 export EXTRA_CFLAGS=$(CFLAGS)
+export EXTRA_CPPFLAGS=$(CPPFLAGS)
+export HOST_EXTRA_CFLAGS=$(CFLAGS)
+export HOST_EXTRA_CPPFLAGS=$(CPPFLAGS)
 # need to be stripped as DPDK build system adds them and it would be -Wl,-Wl,opt
 export EXTRA_LDFLAGS=$(shell echo $(LDFLAGS) | sed 's/-Wl,//g')
+# HOST_CC build system does not add -Wl ...
+export EXTRA_HOST_LDFLAGS=$(LDFLAGS)
+
+export RTE_DEVEL_BUILD=n
 
 # People rebuilding this package can overwrite DPDK_CONFIG, RTE_MACHINE and
-# RTE_TARGET via environment variables if they like
+# RTE_TARGET via DEB_BUILD_OPTIONS if they like
+ifneq (,$(filter dpdk_config=%,$(DEB_BUILD_OPTIONS)))
+    DPDK_CONFIG ?= $(patsubst dpdk_config=%,%,$(filter dpdk_config=%,$(DEB_BUILD_OPTIONS)))
+endif
+ifneq (,$(filter rte_machine=%,$(DEB_BUILD_OPTIONS)))
+    RTE_MACHINE ?= $(patsubst rte_machine=%,%,$(filter rte_machine=%,$(DEB_BUILD_OPTIONS)))
+endif
+ifneq (,$(filter rte_target=%,$(DEB_BUILD_OPTIONS)))
+    RTE_TARGET ?= $(patsubst rte_target=%,%,$(filter rte_target=%,$(DEB_BUILD_OPTIONS)))
+endif
+
 ifneq (,$(filter $(DEB_HOST_ARCH), arm64))
-DPDK_CONFIG := "arm64-armv8a-linuxapp-gcc"
-RTE_MACHINE := "armv8a"
-RTE_TARGET := "arm64-armv8a-linuxapp-gcc"
+DPDK_CONFIG ?= "arm64-armv8a-linuxapp-gcc"
+RTE_MACHINE ?= "armv8a"
+RTE_TARGET ?= "arm64-armv8a-linuxapp-gcc"
+else
+ifneq (,$(filter $(DEB_HOST_ARCH), ppc64el))
+DPDK_CONFIG ?= "ppc_64-power8-linuxapp-gcc"
+RTE_MACHINE ?= "power8"
+RTE_TARGET ?= "ppc_64-power8-linuxapp-gcc"
 else
-DPDK_CONFIG := "$(DEB_HOST_GNU_CPU)-native-linuxapp-gcc"
-RTE_MACHINE := "default"
-RTE_TARGET := "$(DEB_HOST_GNU_CPU)-default-linuxapp-gcc"
+DPDK_CONFIG ?= "$(DEB_HOST_GNU_CPU)-native-linuxapp-gcc"
+RTE_MACHINE ?= "default"
+RTE_TARGET ?= "$(DEB_HOST_GNU_CPU)-default-linuxapp-gcc"
+endif
 endif
 DPDK_STATIC_DIR = "debian/build/static-root"
 DPDK_SHARED_DIR = "debian/build/shared-root"
 
-clean:
-       dh_testdir
-       rm -rf debian/build debian/tmp
-       dh_clean
+# now stable with parallel comilation, so support -j
+ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+    PAR := $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+else
+    PAR := "1"
+endif
+
+# kernel_modules can be passed via DEB_BUILD_OPTIONS to enable building the
+# optional binary kernel modules package. By default it will be built against
+# the current kernel, or ksrc can be passed with a path to the target kernel
+# sources instead.
+ifeq (,$(findstring kernel_modules,$(DEB_BUILD_OPTIONS)))
+DPDK_CONFIG_BUILD_KMOD=n
+KSRC=""
+else
+ifneq (,$(filter ksrc=%,$(DEB_BUILD_OPTIONS)))
+    KSRC := $(patsubst ksrc=%,%,$(filter ksrc=%,$(DEB_BUILD_OPTIONS)))
+else
+    KSRC := /lib/modules/$(shell uname -r)/build
+endif
+
+KVERS := $(shell perl debian/kernel-version $(KSRC))
+export KVERS
+
+DPDK_CONFIG_BUILD_KMOD=y
+
+# Since the binary module package is generated at build time depending on the
+# local kernel version, we have to append the new package in d/control.
+# We cannot use a separate control file since that wouldn't work with
+# dpkg-genchanges, and also would require a lot of overrides for debhelpers.
+get_built_using        ?= $(filter-out (=),$(shell dpkg-query -f='$${source:Package} (=$${source:Version})' -W $1))
+
+override_dh_gencontrol:
+       dh_gencontrol
+       dh_gencontrol -p dpdk-modules-$(KVERS) -- \
+               -v`cat debian/VERSION` \
+               -V'built:using:kernel=$(call get_built_using,linux-headers-$(KVERS))'
+
+build:
+       @if [ x"$(KVERS)" = x ] ; then \
+           echo 'No version in $(KSRC)/include/linux/version.h' >&2; \
+           exit 1; \
+       fi
+       sh debian/prep-modules $(KSRC)
+       cat debian/control.modules >> debian/control
+       dh $@ --with python2,dkms
+endif
+
+%:
+       dh $@ --with python2,dkms
 
-build-config:
-       dh_testdir
+override_dh_auto_clean:
+       rm -rf debian/build debian/tmp debian/dpdk-modules-* \
+               debian/control.modules debian/VERSION
+       sed -i '/Package: dpdk-modules-/,/`tail -n1 debian/control.modules.in`/d' debian/control
+       test -L config/defconfig_$(DPDK_CONFIG) && rm -f config/defconfig_$(DPDK_CONFIG) || true
+
+override_dh_auto_configure:
+       # Add support for a custom defconfig file in the debian directory.
+ifneq (,$(filter dpdk_config=%,$(DEB_BUILD_OPTIONS)))
+       test -e config/defconfig_$(DPDK_CONFIG) || ln -fs ../debian/defconfig_$(DPDK_CONFIG) config/defconfig_$(DPDK_CONFIG)
+endif
        # report dpkg-buildflags status to build log
        dpkg-buildflags --status
        echo EXTRA_CFLAGS $$EXTRA_CFLAGS
        echo EXTRA_LDFLAGS: $$EXTRA_LDFLAGS
        $(MAKE) V=$(DH_VERBOSE) O=$(DPDK_STATIC_DIR) T=$(DPDK_CONFIG) config
+ifeq (,$(filter dpdk_config=%,$(DEB_BUILD_OPTIONS)))
        sed -ri -e 's,(RTE_MACHINE=).*,\1$(RTE_MACHINE),' \
                -e 's,(RTE_NEXT_ABI=).*,\1n,' \
-               -e 's,(CONFIG_RTE_EAL_IGB_UIO=).*,\1n,' \
-               -e 's,(CONFIG_RTE_KNI_KMOD=).*,\1n,' \
+               -e 's,(CONFIG_RTE_EAL_IGB_UIO=).*,\1$(DPDK_CONFIG_BUILD_KMOD),' \
+               -e 's,(CONFIG_RTE_KNI_KMOD=).*,\1$(DPDK_CONFIG_BUILD_KMOD),' \
                -e 's,(LIBRTE_PMD_PCAP=).*,\1y,' \
                -e 's,(LIBRTE_PMD_XENVIRT=).*,\1y,' \
+               -e 's,(CONFIG_RTE_EAL_PMD_PATH=).*,\1"/usr/lib/$(shell dpkg-architecture -qDEB_HOST_MULTIARCH)/dpdk-pmds/",' \
                $(DPDK_STATIC_DIR)/.config
+       # xen not available on ppc64el
+ifneq (,$(filter $(DEB_HOST_ARCH), ppc64el))
+       sed -ri -e 's,(LIBRTE_PMD_XENVIRT=).*,\1n,' $(DPDK_STATIC_DIR)/.config
+endif
+endif
+       dh_auto_configure
+
+override_dh_auto_build-indep:
+       $(MAKE) -j $(PAR) V=$(DH_VERBOSE) O=$(DPDK_STATIC_DIR) doc-api-html doc-guides-html \
+               doc-guides-man
 
-build-indep: build-config
-       dh_testdir
-       $(MAKE) V=$(DH_VERBOSE) O=$(DPDK_STATIC_DIR) doc-api-html doc-guides-html
+override_dh_auto_install-indep:
+       # Package: dpdk-doc
+       # All files based on the install-doc rule (includes examples)
+       $(MAKE) V=$(DH_VERBOSE) O=$(DPDK_STATIC_DIR) prefix=/usr \
+               DESTDIR=debian/dpdk-doc install-doc
 
-build-arch: build-config
-       dh_testdir
-       $(MAKE) V=$(DH_VERBOSE) O=$(DPDK_STATIC_DIR) build
+override_dh_auto_build-arch:
+       $(MAKE) -j $(PAR) V=$(DH_VERBOSE) O=$(DPDK_STATIC_DIR) RTE_KERNELDIR=$(KSRC) build
        # Unfortunately the decision about having static or shared libraries is
        # made for the whole build, which then produces only .a or .so files
        # (but not both).
@@ -78,53 +169,16 @@ build-arch: build-config
        cp -a $(DPDK_STATIC_DIR) $(DPDK_SHARED_DIR)
        sed -ri 's,(RTE_BUILD_SHARED_LIB=).*,\1y,' \
                $(DPDK_SHARED_DIR)/.config
-       $(MAKE) V=$(DH_VERBOSE) O=$(DPDK_SHARED_DIR) build
-
-build: build-arch build-indep
-
-binary-indep: PACKAGE_NAME=dpdk-doc
-binary-indep: DOCDIR=usr/share/doc/dpdk
-binary-indep: export DH_OPTIONS=--indep
-binary-indep:
-       dh_testroot
-       dh_prep
-       dh_testdir
-       dh_installdirs
-       dh_install
-       dh_installdocs
-       dh_installchangelogs
-       dh_lintian
-       # Package: dpdk-doc
-       # All files based on the install-doc rule (includes examples)
-       $(MAKE) V=$(DH_VERBOSE) O=$(DPDK_SHARED_DIR) prefix=/usr \
-               DESTDIR=debian/dpdk-doc install-doc
-       dh_link
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary-arch: LIBDIR=usr/lib/$(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
-binary-arch: export DH_OPTIONS=--arch
-binary-arch:
-       dh_testroot
-       dh_prep
-       dh_testdir
-       dh_installdirs
-       dh_install
-       dh_installdocs
-       dh_installchangelogs
-       dh_lintian
-       dh_systemd_enable
-       dh_installinit --no-start --no-restart-on-upgrade
-       dh_systemd_start --no-start --no-restart-on-upgrade
+       $(MAKE) -j $(PAR) V=$(DH_VERBOSE) O=$(DPDK_SHARED_DIR) RTE_KERNELDIR=$(KSRC) build
+
+override_dh_auto_install-arch: LIBDIR=usr/lib/$(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+override_dh_auto_install-arch:
        # Package: dpdk (runtime)
        $(MAKE) V=$(DH_VERBOSE) O=$(DPDK_STATIC_DIR) prefix=/usr \
                DESTDIR=debian/dpdk install-runtime
        $(MAKE) V=$(DH_VERBOSE) O=$(DPDK_SHARED_DIR) prefix=/usr \
                DESTDIR=debian/dpdk install-runtime
+       mkdir -p debian/dpdk/etc/dpdk
        cp debian/dpdk.interfaces debian/dpdk/etc/dpdk/interfaces
        rm debian/dpdk/usr/sbin/dpdk-devbind
        mkdir -p debian/dpdk/sbin
@@ -160,9 +214,19 @@ binary-arch:
          else \
            PKG=$${LN}$${VER}; \
          fi; \
+         LIBF="$$(basename $${lib})"; \
+         LIBD="debian/$${PKG}/$(LIBDIR)"; \
          echo "moving $${lib} for library $${PKG}"; \
-         mkdir -p debian/$${PKG}/$(LIBDIR); \
-         mv $${lib} debian/$${PKG}/$(LIBDIR); \
+         mkdir -p $${LIBD}; \
+         mv $${lib} $${LIBD}; \
+         if [ "$${LIBF#librte_pmd_}x" != "$${LIBF}x" ]; then \
+           mkdir -p $${LIBD}/dpdk-pmds; \
+           echo "PMD: linking $${LIBF} into RTE_EAL_PMD_PATH at $${LIBD}/dpdk-pmds/"; \
+           ln -s --relative --target-directory=$${LIBD}/dpdk-pmds/ $${LIBD}/$${LIBF}; \
+         fi; \
+         if [ "$${LIBF#librte_eal}x" != "$${LIBF}x" ]; then \
+           mkdir -p $${LIBD}/dpdk-pmds; \
+         fi; \
        done
        # pkg-config
        mkdir -p debian/libdpdk-dev/$(LIBDIR)/pkgconfig
@@ -178,18 +242,21 @@ binary-arch:
        mkdir -p debian/dpdk-rte-kni-dkms/usr/src/dpdk-rte-kni-$(VERSION)
        cp -a lib/librte_eal/linuxapp/kni/* \
                debian/dpdk-rte-kni-dkms/usr/src/dpdk-rte-kni-$(VERSION)
+ifneq (,$(KVERS))
+       # Package: dpdk-modules-<kernel version>
+       mkdir -p debian/dpdk-modules-$(KVERS)/lib/modules/$(KVERS)/kernel/drivers/net
+       cp -a debian/build/shared-root/kmod/* \
+               debian/dpdk-modules-$(KVERS)/lib/modules/$(KVERS)/kernel/drivers/net
+endif
+
+override_dh_dkms:
        dh_dkms -V $(VERSION)
-       dh_python2
-       dh_perl
-       dh_link
-       dh_compress
-       dh_fixperms
-       dh_strip
-       dh_makeshlibs
-       dh_shlibdeps
-       dh_installdeb
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
 
-binary: binary-arch binary-indep
+override_dh_installinit:
+       dh_installinit --no-start --no-restart-on-upgrade
+
+override_dh_systemd_start:
+       dh_systemd_start --no-start --no-restart-on-upgrade
+
+override_dh_auto_test:
+