build: do not _FORTIFY_SOURCE in debug mode
[vpp.git] / docs / gettingstarted / developers / buildsystem / buildrootmakefile.rst
index 034339f..84647d0 100644 (file)
@@ -179,11 +179,11 @@ Here are the contents of .../build-data/platforms/vpp.mk:
         vpp_configure_args_vpp += --disable-lb-plugin
         endif
      
-        vpp_debug_TAG_CFLAGS = -g -O0 -DCLIB_DEBUG -D_FORTIFY_SOURCE=2 \
+        vpp_debug_TAG_CFLAGS = -g -O0 -DCLIB_DEBUG \
             -fstack-protector-all -fPIC -Werror
-        vpp_debug_TAG_CXXFLAGS = -g -O0 -DCLIB_DEBUG -D_FORTIFY_SOURCE=2 \
+        vpp_debug_TAG_CXXFLAGS = -g -O0 -DCLIB_DEBUG \
             -fstack-protector-all -fPIC -Werror
-        vpp_debug_TAG_LDFLAGS = -g -O0 -DCLIB_DEBUG -D_FORTIFY_SOURCE=2 \
+        vpp_debug_TAG_LDFLAGS = -g -O0 -DCLIB_DEBUG \
             -fstack-protector-all -fPIC -Werror
 
         vpp_TAG_CFLAGS = -g -O2 -D_FORTIFY_SOURCE=2 -fstack-protector -fPIC -Werror