dpdk: bump rdma-core to 51.0
[vpp.git] / extras / rpm / opensuse / vpp.spec
index 403d25b..11a10d6 100644 (file)
@@ -3,6 +3,8 @@
 #
 # Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
+# Copyright (c) 2022 Nordix Foundation.
+#
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
 # upon. The license for this file, and modifications and additions to the
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
-#
-
-
 %define _vpp_build_dir       %{buildroot}/../../BUILD/vpp-%{version}/build-root
 %define _vpp_install_dir     %{_vpp_build_dir}/install-vpp-native/
 %define _vpp_plugins_lib_dir %{_vpp_install_dir}/vpp/lib64
@@ -34,6 +32,7 @@ BuildRequires:  autoconf
 BuildRequires:  automake
 BuildRequires:  bison
 BuildRequires:  ccache
+BuildRequires:  clang
 BuildRequires:  check-devel
 BuildRequires:  chrpath
 BuildRequires:  distribution-release
@@ -47,12 +46,10 @@ BuildRequires:  libtool
 BuildRequires:  lsb-release
 BuildRequires:  make
 BuildRequires:  openssl-devel
-BuildRequires:  python-devel
-BuildRequires:  python-pip
 BuildRequires:  python-rpm-macros
-BuildRequires:  python2-ply
 BuildRequires:  python3-devel
 BuildRequires:  python3-pip
+BuildRequires:  python3-ply
 BuildRequires:  shadow
 Conflicts:      otherproviders(vpp-any)
 Provides:       %{name}-any = %{version}
@@ -127,7 +124,7 @@ Group:          Development/Libraries/Python
 Requires:       %{lname} = %{version}
 Requires:       %{name} = %{version}
 Requires:       %{name}-devel = %{version}
-Requires:       python-setuptools
+Requires:       python3-setuptools
 Conflicts:      otherproviders(%{name}-any-python-api)
 Provides:       %{name}-any-python-api = %{version}
 
@@ -137,11 +134,13 @@ This package contains the python bindings for the vpp api
 %prep
 %setup -q -n %{name}-%{version}
 
+%debug_package
+
 %build
 export VPP_BUILD_USER=suse
 export VPP_BUILD_HOST=SUSE
 
-make -C build-root V=1 CC=gcc-7 CXX=g++-7 PLATFORM=vpp TAG=vpp install-packages
+make -C build-root V=1 PLATFORM=vpp TAG=vpp install-packages
 
 cd %{_vpp_build_dir}/../src/vpp-api/python && %{py3_build}