VPPAPIGEN: vppapigen replacement in Python PLY.
[vpp.git] / extras / rpm / vpp.spec
index 86c0dbc..532b9a2 100644 (file)
@@ -1,9 +1,10 @@
 %bcond_without aesni
+%{!?_topdir:%define _topdir %(pwd)}
 %define _vpp_build_dir   build-tool-native
 %define _unitdir         /lib/systemd/system
-%define _topdir          %(pwd)
 %define _builddir        %{_topdir}
-%define _mu_build_dir    %{_topdir}/%{name}-%{_version}/build-root
+%define _tmp_build_dir   %{name}-%{_version}.0
+%define _mu_build_dir    %{_topdir}/%{_tmp_build_dir}/build-root
 %define _vpp_tag        %{getenv:TAG}
 %if "%{_vpp_tag}" == ""
 %define _vpp_tag        vpp
@@ -30,23 +31,26 @@ Version: %{_version}
 Release: %{_release}
 Requires: vpp-lib = %{_version}-%{_release}, net-tools, pciutils, python
 BuildRequires: systemd, chrpath
-BuildRequires: libffi-devel, openssl-devel
+BuildRequires: check, check-devel
+BuildRequires: subunit, subunit-devel
 %if 0%{?fedora} >= 26
+BuildRequires: compat-openssl10-devel
 BuildRequires: python2-devel, python2-virtualenv
 %else
 %if 0%{?fedora} == 25
+BuildRequires: openssl-devel
 BuildRequires: python-devel, python2-virtualenv
 %else
+BuildREquires: openssl-devel
 BuildRequires: python-devel, python-virtualenv
 %endif
 %endif
+BuildRequires: libffi-devel
 BuildRequires: glibc-static, java-1.8.0-openjdk, java-1.8.0-openjdk-devel yum-utils, redhat-lsb
 BuildRequires: apr-devel
-%if %{with aesni}
-BuildRequires: nasm
-%endif
 BuildRequires: numactl-devel
 BuildRequires: autoconf automake libtool byacc bison flex
+BuildRequires: boost boost-devel
 
 Source: %{name}-%{_version}-%{_release}.tar.xz
 # Source: vpp-latest.tar.xz
@@ -87,7 +91,7 @@ vppinfra
 %package plugins
 Summary: Vector Packet Processing--runtime plugins
 Group: System Environment/Libraries
-Requires: vpp = %{_version}-%{_release}
+Requires: vpp = %{_version}-%{_release} numactl-libs
 %description plugins
 This package contains VPP plugins
 
@@ -116,13 +120,20 @@ Requires: vpp = %{_version}-%{_release}, vpp-lib = %{_version}-%{_release}, pyth
 This package contains the python bindings for the vpp api
 
 %prep
-%setup -q -n %{name}-%{_version}
+# Unpack into dir with longer name as work around of debugedit bug in in rpm-build 4.13
+rm -rf %{name}-%{_version}
+rm -rf %{_tmp_build_dir}
+/usr/bin/xz -dc '%{_sourcedir}/%{name}-%{_version}-%{_release}.tar.xz' | /usr/bin/tar -xf -
+mv %{name}-%{_version} %{_tmp_build_dir}
+cd '%{_tmp_build_dir}'
+/usr/bin/chmod -Rf a+rX,u+w,g-w,o-w .
 
 %pre
 # Add the vpp group
 groupadd -f -r vpp
 
 %build
+cd '%{_tmp_build_dir}'
 %if %{with aesni}
     make bootstrap
     make -C build-root PLATFORM=vpp TAG=%{_vpp_tag} install-packages
@@ -326,6 +337,7 @@ fi
 %{_includedir}/*
 %{python2_sitelib}/jvppgen/*
 /usr/share/doc/vpp/examples/sample-plugin
+/usr/share/vpp
 
 %files plugins
 %defattr(-,bin,bin)