crypto: add support for testing quad loops in crypto algos
[vpp.git] / src / pkg / debian / rules.in
index 0351ee5..ceef46a 100755 (executable)
@@ -7,15 +7,20 @@ DH_VERBOSE = 1
 DPKG_EXPORT_BUILDFLAGS = 1
 include /usr/share/dpkg/default.mk
 
-export PYBUILD_NAME = vpp-api-python
+export PYBUILD_NAME = vpp-api
 export PYBUILD_DIR = @CMAKE_SOURCE_DIR@/vpp-api/python
 export PYBUILD_DESTDIR_python2=debian/vpp-api-python/
 export PYBUILD_DISABLE_python2=test
+export PYBUILD_DESTDIR_python3=debian/python3-vpp-api/
+export PYBUILD_DISABLE_python3=test
 export PYBUILD_SYSTEM=distutils
 
+buildvers := $(shell pyversions -sv)
+build3vers := $(shell py3versions -sv)
+
 # main packaging script based on dh7 syntax
 %:
-       dh $@ --with systemd,python2 --buildsystem=pybuild
+       dh $@ --with systemd,python2,python3 --buildsystem=pybuild
 
 override_dh_strip:
        dh_strip --dbg-package=vpp-dbg