CSIT-1110: Use jumpavg library from pip
[csit.git] / PyPI / jumpavg / setup.py
similarity index 73%
rename from resources/tools/presentation/new/jumpavg/setup.py
rename to PyPI/jumpavg/setup.py
index 86a3889..aa56efd 100644 (file)
@@ -14,11 +14,12 @@ with open(path.join(here, "README.rst"), encoding="utf-8") as f:
 
 setup(
     name="jumpavg",
-    version="0.1.0",  # This is currently the only place listing the version.
-    description="Library for finding changes in time series by grouping results",
+    version="0.1.2",  # This is currently the only place listing the version.
+    description="Library for finding changes in time series by grouping results.",
     long_description=long_description,
     long_description_content_type="text/x-rst",
-    url="https://github.com/vrpolakatcisco/jumpavg",
+    # TODO: Create a separate webpage for jumpavg library.
+    url="https://gerrit.fd.io/r/gitweb?p=csit.git;a=tree;f=PyPI/jumpavg;hb=refs/heads/master",
     author="Cisco Systems Inc. and/or its affiliates",
     author_email="csit-dev@lists.fd.io",
     classifiers=[
@@ -26,13 +27,14 @@ setup(
         "Intended Audience :: Science/Research",
         # Pick your license as you wish
         "License :: OSI Approved :: Apache Software License",
-        "Natural Language :: English"
+        "Natural Language :: English",
         # TODO: Test which Python versions is the code compatible with.
         "Programming Language :: Python :: 2.7",
         "Topic :: Scientific/Engineering :: Information Analysis"
     ],
     keywords="progression regression anomaly detection",
     packages=find_packages(exclude=[]),
+    # TODO: python_requires="~=2.7"
     install_requires=[],
     # TODO: Include simulator and tests.
     extras_require={
@@ -44,7 +46,7 @@ setup(
         ],
     },
     project_urls={
-        "Bug Reports": "https://github.com/vrpolakatcisco/jumpavg/issues",
-        "Source": "https://github.com/vrpolakatcisco/jumpavg/",
+        "Bug Reports": "https://jira.fd.io/projects/CSIT/issues",
+        "Source": "https://gerrit.fd.io/r/gitweb?p=csit.git;a=tree;f=PyPI/jumpavg;hb=refs/heads/master",
     },
 )