Nested VM refresh
[csit.git] / resources / tools / disk-image-builder / nested / buildroot-patches / dpdk.patch
index 1686e4b..be10b65 100644 (file)
@@ -15,7 +15,7 @@ new file mode 100644
 index 0000000..a42271e
 --- /dev/null
 +++ b/package/dpdk/Config.in
-@@ -0,0 +1,54 @@
+@@ -0,0 +1,55 @@
 +config BR2_PACKAGE_DPDK
 +       bool "dpdk"
 +       depends on (BR2_i386 && !BR2_x86_i386 && !BR2_x86_i486 \
@@ -27,6 +27,7 @@ index 0000000..a42271e
 +       depends on BR2_TOOLCHAIN_HAS_SYNC_2
 +       depends on BR2_TOOLCHAIN_HAS_SYNC_4
 +       depends on BR2_TOOLCHAIN_HAS_SYNC_8
++       depends on BR2_PACKAGE_NUMACTL
 +       help
 +       DPDK is a set of libraries and drivers for fast packet processing. It
 +       was designed to run on any processors, however, Intel x86 has been the
@@ -77,21 +78,21 @@ index 0000000..1c47f19
 +++ b/package/dpdk/dpdk.hash
 @@ -0,0 +1,2 @@
 +# Locally calculated
-+sha256 cf2ef6faf8cd056abbbebba779b7850eb3f79edd0d91767bcdbc216a2cde4fd1  dpdk-16.11.tar.gz
++sha256 3a08addbff45c636538514e9a5838fb91ea557661a4c071e03a9a6987d46e5b6 dpdk-17.08.tar.gz
 diff --git a/package/dpdk/dpdk.mk b/package/dpdk/dpdk.mk
 new file mode 100644
 index 0000000..02860fd
 --- /dev/null
 +++ b/package/dpdk/dpdk.mk
-@@ -0,0 +1,128 @@
+@@ -0,0 +1,133 @@
 +################################################################################
 +#
 +# dpdk
 +#
 +################################################################################
 +
-+DPDK_VERSION = 16.11
-+DPDK_SITE = http://dpdk.org/browse/dpdk/snapshot
++DPDK_VERSION = 17.08
++DPDK_SITE = http://fast.dpdk.org/rel
 +DPDK_SOURCE = dpdk-$(DPDK_VERSION).tar.gz
 +
 +DPDK_LICENSE = BSD (core), GPLv2+ (Linux drivers)
@@ -99,6 +100,9 @@ index 0000000..02860fd
 +DPDK_INSTALL_STAGING = YES
 +
 +DPDK_DEPENDENCIES += linux
++ifeq ($(BR2_PACKAGE_NUMACTL),y)
++DPDK_DEPENDENCIES += numactl
++endif
 +
 +ifeq ($(BR2_PACKAGE_LIBPCAP),y)
 +DPDK_DEPENDENCIES += libpcap
@@ -129,14 +133,16 @@ index 0000000..02860fd
 +# example that may not be met when building in parallel for the first
 +# time. As a (dirty) workaround, we build twice.
 +define DPDK_BUILD_EXAMPLES
-+      $(MAKE) -C $(@D) DESTDIR=$(@D)/examples-sdk \
-+              CROSS=$(TARGET_CROSS) install-sdk install-runtime
-+      $(MAKE) -C $(@D) RTE_KERNELDIR=$(LINUX_DIR) CROSS=$(TARGET_CROSS) \
-+              RTE_SDK=$(@D)/examples-sdk/usr/local/share/dpdk \
-+              T=$(DPDK_CONFIG) examples || echo "Failed, building again"
-+      $(MAKE) -C $(@D) RTE_KERNELDIR=$(LINUX_DIR) CROSS=$(TARGET_CROSS) \
-+              RTE_SDK=$(@D)/examples-sdk/usr/local/share/dpdk \
-+              T=$(DPDK_CONFIG) examples
++       $(INSTALL) -m 0755 -D -d $(TARGET_DIR)/usr/bin
++       $(INSTALL) -m 0755 -D $(@D)/build/app/testpmd $(TARGET_DIR)/usr/bin
++#     $(MAKE) -C $(@D) DESTDIR=$(@D)/examples-sdk \
++#             CROSS=$(TARGET_CROSS) install-sdk install-runtime
++#     $(MAKE) -C $(@D) RTE_KERNELDIR=$(LINUX_DIR) CROSS=$(TARGET_CROSS) \
++#             RTE_SDK=$(@D)/examples-sdk/usr/local/share/dpdk \
++#             T=$(DPDK_CONFIG) examples || echo "Failed, building again"
++#     $(MAKE) -C $(@D) RTE_KERNELDIR=$(LINUX_DIR) CROSS=$(TARGET_CROSS) \
++#             RTE_SDK=$(@D)/examples-sdk/usr/local/share/dpdk \
++#             T=$(DPDK_CONFIG) examples
 +endef
 +
 +DPDK_EXAMPLES_PATH = $(@D)/examples-sdk/usr/local/share/dpdk/examples
@@ -145,18 +151,18 @@ index 0000000..02860fd
 +# here. As the binaries and libraries do not have a single or regular location
 +# where to find them after build, we search for them by find.
 +define DPDK_INSTALL_EXAMPLES
-+      $(INSTALL) -m 0755 -d $(TARGET_DIR)/usr/local/bin
-+      $(INSTALL) -m 0755 -d $(TARGET_DIR)/usr/local/lib
-+      for f in `find $(DPDK_EXAMPLES_PATH) -executable -type f   \
-+                      -name '[a-z]*.so*' | grep '\/lib\/.*'`; do \
-+              $(INSTALL) -m 0755 -D $$f                          \
-+                      $(TARGET_DIR)/usr/local/lib/`basename $$f`;\
-+      done
-+      for f in `find $(DPDK_EXAMPLES_PATH) -executable -type f   \
-+                      ! -name '*.so*' | grep '\/app\/.*'`; do    \
-+              $(INSTALL) -m 0755 -D $$f                          \
-+                      $(TARGET_DIR)/usr/local/bin/`basename $$f`;\
-+      done
++#     $(INSTALL) -m 0755 -d $(TARGET_DIR)/usr/local/bin
++#     $(INSTALL) -m 0755 -d $(TARGET_DIR)/usr/local/lib
++#     for f in `find $(DPDK_EXAMPLES_PATH) -executable -type f   \
++#                     -name '[a-z]*.so*' | grep '\/lib\/.*'`; do \
++#             $(INSTALL) -m 0755 -D $$f                          \
++#                     $(TARGET_DIR)/usr/local/lib/`basename $$f`;\
++#     done
++#     for f in `find $(DPDK_EXAMPLES_PATH) -executable -type f   \
++#                     ! -name '*.so*' | grep '\/app\/.*'`; do    \
++#             $(INSTALL) -m 0755 -D $$f                          \
++#                     $(TARGET_DIR)/usr/local/bin/`basename $$f`;\
++#     done
 +endef
 +
 +define DPDK_INSTALL_KMOD