Remove obsolete image builder 29/31929/1
authorpmikus <pmikus@cisco.com>
Thu, 8 Apr 2021 12:12:30 +0000 (12:12 +0000)
committerpmikus <pmikus@cisco.com>
Thu, 8 Apr 2021 12:12:30 +0000 (12:12 +0000)
Signed-off-by: pmikus <pmikus@cisco.com>
Change-Id: I6cb73a6b9fbbdec2d7127f2457cbe21d12cd3e64

18 files changed:
resources/tools/disk-image-builder/nested/.gitignore [deleted file]
resources/tools/disk-image-builder/nested/CHANGELOG [deleted file]
resources/tools/disk-image-builder/nested/README.md [deleted file]
resources/tools/disk-image-builder/nested/build.sh [deleted file]
resources/tools/disk-image-builder/nested/buildroot-config [deleted file]
resources/tools/disk-image-builder/nested/buildroot-patches/dpdk.patch [deleted file]
resources/tools/disk-image-builder/nested/clean.sh [deleted file]
resources/tools/disk-image-builder/nested/deepclean.sh [deleted file]
resources/tools/disk-image-builder/nested/image-patches/01-serial-console [deleted file]
resources/tools/disk-image-builder/nested/image-patches/02-users [deleted file]
resources/tools/disk-image-builder/nested/image-patches/03-network [deleted file]
resources/tools/disk-image-builder/nested/image-patches/04-qemu-ga [deleted file]
resources/tools/disk-image-builder/nested/image-patches/05-ssh-hostkeys [deleted file]
resources/tools/disk-image-builder/nested/image-patches/06-dpdk-support [deleted file]
resources/tools/disk-image-builder/nested/image-patches/07-isolate-cpu [deleted file]
resources/tools/disk-image-builder/nested/image-patches/08-virtio-disk [deleted file]
resources/tools/disk-image-builder/nested/kernel-defconfig [deleted file]
resources/tools/disk-image-builder/nested/requirements.sh [deleted file]

diff --git a/resources/tools/disk-image-builder/nested/.gitignore b/resources/tools/disk-image-builder/nested/.gitignore
deleted file mode 100644 (file)
index a007fea..0000000
+++ /dev/null
@@ -1 +0,0 @@
-build/*
diff --git a/resources/tools/disk-image-builder/nested/CHANGELOG b/resources/tools/disk-image-builder/nested/CHANGELOG
deleted file mode 100644 (file)
index b334ce2..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
-## [1.7] - 2017-08-14
-
-### Changes
-- update buildroot to 2017.05.2
-- add htop, perf, screen, msr_tools, memstat
-
-
-## [1.6] - 2017-02-20
-
-### Changes
-- replace /dev/sda to /dev/vda, to use with virtio disk driver
-- add noapic to bootloader's kernel line
-- bind igb_uio driver only to network device
-
-
-## [1.5] - 2016-11-14
-
-### Changes
-- DPDK upgrade to 16.11
-
-
-## [1.4] - 2016-10-10
-
-### Changes
-- DPDK upgrade to 16.07
-
-
-## [1.3] - 2016-06-12
-
-### Changes
-- Use Glibc instead of uClibc. Required for DPDK.
-- Include buildroot patch for DPDK. Update build.sh
-  script to include that patch.
-- Update Linux kernel config to include UIO support
-
-### Added
-- Python, DPDK to image
-
-
-## [1.2] - 2016-05-25
-
-### Changes
-- Embed version in hidden file with magic string that can be read
-  without actually booting the image:
-  ~~~
-  cat <vm image> | strings | grep NESTED_VERSION
-  ~~~
-- Include both cisco/cisco credentials (for backwards compatibility)
-  and csit/csit
-
-## [1.1] - 2016-05-17
-
-### Added
-- iproute2 package (for "ip" command)
-
-
-## [1.0] - 2016-05-16
-
-### First release
-- Basic script to build FD.IO VPP CSIT "nested VM" image using buildroot.
-This version is to mimic the previous, manually built image.
-- Packages installed:
-    - Kernel 4.3
-        - support for virtio NIC
-    - bridge-utils (for brctl)
-    - qemu (for qemu-ga)
diff --git a/resources/tools/disk-image-builder/nested/README.md b/resources/tools/disk-image-builder/nested/README.md
deleted file mode 100644 (file)
index 3c49689..0000000
+++ /dev/null
@@ -1,71 +0,0 @@
-# Nested VM builder
-
-## Summary
-
-The files in this directory are used to build CSIT's "nested VM" image.
-The Nested VM image is a mini Linux image that gets spun up inside the
-main CSIT test VM for selected test cases.
-
-Considering that this VM is:
-
-- Very purpose-built; the ONLY thing it needs to do is run a bridge group,
-- spun up and torn down repeatedly by an automated test case,
-- is bundled within another VM image where resources are already limited,
-
-this VM is designed to be minimalistic, small and efficient. For that reason
-it is NOT build around any established Linux distribution (Ubuntu,
-Red Hat, ...), but around "buildroot" (https://buildroot.org/) which is
-aimed at building small Linux images for embedded systems.
-
-Scripts in this directory are aimed at producing functionally identical VM
-images each time they are run. That is, a given version of this package
-will consistenly download the same buildroot version, and install the same
-packages and the same kernel version with the same config.
-
-
-### Prerequisites
-
-This scripts have been tested on Ubuntu Linux. They should run on any platform
-supported by buildroot, and where a standard bourne shell and Linux toolchain
-are available.
-
-## Files
-
-### requirements.sh
-
-(One-time) installs required Ubuntu packages for buildroot
-
-
-### build.sh
-
-Downloads all required packages source code and builds the nested VM image.
-Is NOT intended to be run as root, but requires "sudo" privileges for a
-handful of commands.
-
-### clean.sh
-
-Remove any object files and compiled files. Keep the downloaded source
-packages, both of buildroot itself as well as any packages downloaded by
-buildroot.
-
-### deepclean.sh
-
-Remove any compiled or downloaded files.
-
-### CHANGELOG
-
-A change log. This will also be copied onto the image itself.
-Versions in the changelog MUST be tagged as follows:
-
-~~~
-## [MAJOR.MINOR] YYYY-MM-DD
-~~~
-eg.
-
-~~~
-## [1.0] 2016-05-16
-~~~
-
-This format will be used for auto-extracting the version
-number, which will become part of the target image filename
-and will also be copied onto the image itself.
diff --git a/resources/tools/disk-image-builder/nested/build.sh b/resources/tools/disk-image-builder/nested/build.sh
deleted file mode 100755 (executable)
index 34b96bb..0000000
+++ /dev/null
@@ -1,183 +0,0 @@
-#!/bin/sh -e
-
-# Copyright (c) 2016 Cisco and/or its affiliates.
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at:
-#
-#     http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-# Note: In order to limit the damage this script can do, it is recommended
-# to NOT run as root.
-
-#
-# 1. Download buildroot
-# 2. Build buildroot kernel and root file system as per
-#    config files included in this package
-# 3. Create empty disk image and extract buildroot root
-#    file system onto it, make it bootable
-# 4. Apply any patches/additions included in this package
-#
-BUILD_DIR="$(dirname $0)/build"
-
-BUILDROOT_NAME='buildroot-2017.05.2'
-BUILDROOT_DIR="${BUILD_DIR}/${BUILDROOT_NAME}"
-BUILDROOT_TARBALL="${BUILDROOT_NAME}.tar.gz"
-BUILDROOT_URL="https://buildroot.org/downloads/${BUILDROOT_TARBALL}"
-BUILDROOT_OUTPUT="${BUILDROOT_DIR}/output/images/rootfs.tar"
-
-DISK_FREE_SIZE=8388608              # Min. free space on disk (8 MB)
-DISK_ROUND_TO_NEAREST=16777216      # Round disk size up to nearest (16 MB)
-
-VERSION=$(cat $(dirname $0)/CHANGELOG  | grep '^## ' | head -1 | sed -e 's/.*\[\(.*\)\].*/\1/')
-if [ "${VERSION}" = "" ]
-then
-  echo "Unable to determine build version from CHANGELOG file. Make sure"
-  echo "that there is an entry for the most recent version in CHANGELOG,"
-  echo "and that the entry is formated like"
-  echo
-  echo "## [1.0] - 2016-05-16"
-  exit 1
-fi
-
-mkdir -p ${BUILD_DIR}
-
-echo Building version: ${VERSION}
-echo $VERSION > ${BUILD_DIR}/VERSION
-echo "NESTED_VERSION=${VERSION}" > ${BUILD_DIR}/VERSION_HIDDEN
-img_name="${BUILD_DIR}/csit-nested-${VERSION}.img"
-
-# Normally no need to touch the variables below
-DISK_SECT_SIZE=512
-DISK_HEADS=16
-DISK_SECT_PER_TRACK=63
-DISK_RESERVED_SECTORS=2048
-
-MOUNT_TMPDIR="${BUILD_DIR}/tmp-mount"
-
-set -e
-
-# Download buildroot if not already there
-wget -P ${BUILD_DIR} -N $BUILDROOT_URL
-tar -C ${BUILD_DIR} -xzf ${BUILD_DIR}/$BUILDROOT_TARBALL
-
-# Apply DPDK patch to buildroot. Do not fail if this patch has already been applied.
-patch -N -d ${BUILDROOT_DIR} -p1 < buildroot-patches/dpdk.patch || /bin/true
-
-cp -p buildroot-config $BUILDROOT_DIR/.config
-cp -p kernel-defconfig $BUILDROOT_DIR/kernel-defconfig
-make -C $BUILDROOT_DIR
-
-if [ ! -f ${BUILDROOT_OUTPUT} ]
-then
-  echo "Buildroot compiled OK, but root file system ${BUILDROOT_OUTPUT}"
-  echo "does not exist. Somethig is wrong. Exiting."
-  exit 1
-fi
-
-# If we got here, it means we downloaded (if applicable) and built (if
-# applicable) buildroot OK.
-#
-# Now let's calculate the required disk size, and build an empty disk.
-
-buildroot_size=$(stat -c%s ${BUILDROOT_OUTPUT})
-desired_size=$(( ${buildroot_size} + ${DISK_FREE_SIZE} ))
-rounded_size=$(( ((${desired_size}/${DISK_ROUND_TO_NEAREST})+1) * \
-                  ${DISK_ROUND_TO_NEAREST} ))
-
-echo "Actual root FS size: ${buildroot_size}"
-echo "Root FS size + desired free space (${DISK_FREE_SIZE}): ${desired_size}"
-echo "Root FS size rounded to nearest ${DISK_ROUND_TO_NEAREST}:" \
-  "${rounded_size} ($(( ${rounded_size} / 1024 / 1024 )) MB)"
-
-# In a normal world, we'd be creating a full-size empty image with "dd", an
-# then use fdisk to partition it, and a tool like "kpartx" to map this into
-# individual partitions. We'd then map the partition we're interested in.
-# However, in order to avoid messing with /dev/mapper, we can also create
-# our actual partition first, and then merge it with the MBR+partition table
-# "prefix" to obtain our full disk.
-
-sectors=$(( ${rounded_size} / ${DISK_SECT_SIZE} ))
-
-disk_prefix=${img_name}.prefix
-disk_main=${img_name}.main
-
-dd if=/dev/zero of=${disk_prefix} bs=${DISK_SECT_SIZE} \
-  count=${DISK_RESERVED_SECTORS}
-dd if=/dev/zero of=${disk_main} bs=${DISK_SECT_SIZE} \
-  count=$(( $sectors - ${DISK_RESERVED_SECTORS} ))
-
-# Format and mount the root file system
-mkfs.ext2 -F -L root ${disk_main}
-mkdir -p ${MOUNT_TMPDIR}
-sudo mount -o loop ${disk_main} ${MOUNT_TMPDIR}
-trap "sudo umount ${MOUNT_TMPDIR}" EXIT
-
-# Extract the root filesystem
-echo "Extracting root filesystem..."
-sudo tar -C ${MOUNT_TMPDIR} -xf ${BUILDROOT_OUTPUT}
-
-# Apply any patches
-echo "Applying patches/modifications"
-mydir=$(pwd)
-cd ${MOUNT_TMPDIR}
-sudo run-parts -v  ${mydir}/image-patches
-cd ${mydir}
-
-# Copy version and changelog
-sudo cp ${BUILD_DIR}/VERSION ${MOUNT_TMPDIR}/
-sudo cp ${mydir}/CHANGELOG ${MOUNT_TMPDIR}/
-# Also embed this into a hidden file that we can easily retrieve with
-# "cat <disk image> | strings | grep NESTED_VERSION"
-sudo cp ${BUILD_DIR}/VERSION_HIDDEN ${MOUNT_TMPDIR}/.VERSION.HIDDEN
-
-# Unmount root filesystem
-sudo umount ${MOUNT_TMPDIR}
-trap EXIT
-rmdir ${MOUNT_TMPDIR}
-
-# Now create our larger disk
-cat ${disk_prefix} ${disk_main} > ${img_name}
-rm -f ${disk_prefix} ${disk_main}
-
-# Create partition table on the disk
-sed -e 's/\s*\([\+0-9a-zA-Z]*\).*/\1/' << _EOF | fdisk -H ${DISK_HEADS} -S ${DISK_SECT_PER_TRACK} ${img_name}
-  o # clear the in memory partition table
-  n # new partition
-  p # primary partition
-  1 # partition number 1
-  ${DISK_RESERVED_SECTORS} # Start a few KB into the disk, leave room for GRUB
-    # Default - all the way through the end of the disk
-  a # make a partition bootable
-  1 # bootable partition is partition 1
-  p # print the in-memory partition table
-  w # write the partition table
-  q # and we're done
-_EOF
-
-disk_cylinders=$(fdisk -l -H ${DISK_HEADS} -S ${DISK_SECT_PER_TRACK} ${img_name} | \
-  grep cylinders | \
-  sed -e 's/.* \([0-9][0-9]*\) cylinders.*/\1/')
-
-echo "Disk has ${disk_cylinders} cylinders"
-
-# Install GRUB bootloader on the disk image
-${BUILDROOT_DIR}/output/host/sbin/grub --device-map=/dev/null <<_EOF
-device (hd0) ${img_name}
-geometry (hd0)
-root (hd0,0)
-setup (hd0)
-quit
-_EOF
-
-echo
-echo
-echo
-echo "Your image should be ready in:"
-ls -l ${img_name}
diff --git a/resources/tools/disk-image-builder/nested/buildroot-config b/resources/tools/disk-image-builder/nested/buildroot-config
deleted file mode 100644 (file)
index 5fe2514..0000000
+++ /dev/null
@@ -1,3132 +0,0 @@
-#
-# Automatically generated file; DO NOT EDIT.
-# Buildroot 2017.05.2 Configuration
-#
-BR2_HAVE_DOT_CONFIG=y
-BR2_HOST_GCC_AT_LEAST_4_5=y
-BR2_HOST_GCC_AT_LEAST_4_6=y
-BR2_HOST_GCC_AT_LEAST_4_7=y
-BR2_HOST_GCC_AT_LEAST_4_8=y
-BR2_HOST_GCC_AT_LEAST_4_9=y
-BR2_HOST_GCC_AT_LEAST_5=y
-BR2_HOSTARCH_NEEDS_IA32_COMPILER=y
-
-#
-# Target options
-#
-BR2_ARCH_IS_64=y
-BR2_ARCH_HAS_MMU_MANDATORY=y
-# BR2_arcle is not set
-# BR2_arceb is not set
-# BR2_arm is not set
-# BR2_armeb is not set
-# BR2_aarch64 is not set
-# BR2_aarch64_be is not set
-# BR2_bfin is not set
-# BR2_csky is not set
-# BR2_i386 is not set
-# BR2_m68k is not set
-# BR2_microblazeel is not set
-# BR2_microblazebe is not set
-# BR2_mips is not set
-# BR2_mipsel is not set
-# BR2_mips64 is not set
-# BR2_mips64el is not set
-# BR2_nios2 is not set
-# BR2_or1k is not set
-# BR2_powerpc is not set
-# BR2_powerpc64 is not set
-# BR2_powerpc64le is not set
-# BR2_sh is not set
-# BR2_sparc is not set
-# BR2_sparc64 is not set
-BR2_x86_64=y
-# BR2_xtensa is not set
-BR2_ARCH="x86_64"
-BR2_ENDIAN="LITTLE"
-BR2_GCC_TARGET_ARCH="corei7"
-BR2_BINFMT_SUPPORTS_SHARED=y
-BR2_READELF_ARCH_NAME="Advanced Micro Devices X86-64"
-BR2_BINFMT_ELF=y
-BR2_X86_CPU_HAS_MMX=y
-BR2_X86_CPU_HAS_SSE=y
-BR2_X86_CPU_HAS_SSE2=y
-BR2_X86_CPU_HAS_SSE3=y
-BR2_X86_CPU_HAS_SSSE3=y
-BR2_X86_CPU_HAS_SSE4=y
-BR2_X86_CPU_HAS_SSE42=y
-# BR2_x86_nocona is not set
-# BR2_x86_core2 is not set
-BR2_x86_corei7=y
-# BR2_x86_corei7_avx is not set
-# BR2_x86_core_avx2 is not set
-# BR2_x86_atom is not set
-# BR2_x86_opteron is not set
-# BR2_x86_opteron_sse3 is not set
-# BR2_x86_barcelona is not set
-# BR2_x86_jaguar is not set
-# BR2_x86_steamroller is not set
-
-#
-# Build options
-#
-
-#
-# Commands
-#
-BR2_WGET="wget --passive-ftp -nd -t 3"
-BR2_SVN="svn"
-BR2_BZR="bzr"
-BR2_GIT="git"
-BR2_CVS="cvs"
-BR2_LOCALFILES="cp"
-BR2_SCP="scp"
-BR2_SSH="ssh"
-BR2_HG="hg"
-BR2_ZCAT="gzip -d -c"
-BR2_BZCAT="bzcat"
-BR2_XZCAT="xzcat"
-BR2_LZCAT="lzip -d -c"
-BR2_TAR_OPTIONS=""
-BR2_DEFCONFIG="$(CONFIG_DIR)/defconfig"
-BR2_DL_DIR="$(TOPDIR)/dl"
-BR2_HOST_DIR="$(BASE_DIR)/host"
-
-#
-# Mirrors and Download locations
-#
-BR2_PRIMARY_SITE=""
-BR2_BACKUP_SITE="http://sources.buildroot.net"
-BR2_KERNEL_MIRROR="https://www.kernel.org/pub"
-BR2_GNU_MIRROR="http://ftp.gnu.org/pub/gnu"
-BR2_LUAROCKS_MIRROR="http://rocks.moonscript.org"
-BR2_CPAN_MIRROR="http://cpan.metacpan.org"
-BR2_JLEVEL=0
-# BR2_CCACHE is not set
-# BR2_ENABLE_DEBUG is not set
-BR2_STRIP_strip=y
-# BR2_STRIP_none is not set
-BR2_STRIP_EXCLUDE_FILES=""
-BR2_STRIP_EXCLUDE_DIRS=""
-# BR2_OPTIMIZE_0 is not set
-# BR2_OPTIMIZE_1 is not set
-# BR2_OPTIMIZE_2 is not set
-# BR2_OPTIMIZE_3 is not set
-# BR2_OPTIMIZE_G is not set
-BR2_OPTIMIZE_S=y
-BR2_SSP_NONE=y
-# BR2_SSP_REGULAR is not set
-# BR2_SSP_STRONG is not set
-# BR2_SSP_ALL is not set
-# BR2_STATIC_LIBS is not set
-BR2_SHARED_LIBS=y
-# BR2_SHARED_STATIC_LIBS is not set
-BR2_PACKAGE_OVERRIDE_FILE="$(CONFIG_DIR)/local.mk"
-BR2_GLOBAL_PATCH_DIR=""
-
-#
-# Advanced
-#
-# BR2_COMPILER_PARANOID_UNSAFE_PATH is not set
-# BR2_REPRODUCIBLE is not set
-
-#
-# Toolchain
-#
-BR2_TOOLCHAIN=y
-BR2_TOOLCHAIN_USES_GLIBC=y
-BR2_TOOLCHAIN_BUILDROOT=y
-# BR2_TOOLCHAIN_EXTERNAL is not set
-
-#
-# Toolchain Buildroot Options
-#
-BR2_TOOLCHAIN_BUILDROOT_VENDOR="buildroot"
-# BR2_TOOLCHAIN_BUILDROOT_UCLIBC is not set
-BR2_TOOLCHAIN_BUILDROOT_GLIBC=y
-# BR2_TOOLCHAIN_BUILDROOT_MUSL is not set
-BR2_TOOLCHAIN_BUILDROOT_LIBC="glibc"
-
-#
-# Kernel Header Options
-#
-# BR2_KERNEL_HEADERS_AS_KERNEL is not set
-# BR2_KERNEL_HEADERS_3_2 is not set
-# BR2_KERNEL_HEADERS_3_4 is not set
-# BR2_KERNEL_HEADERS_3_10 is not set
-# BR2_KERNEL_HEADERS_3_12 is not set
-# BR2_KERNEL_HEADERS_4_1 is not set
-BR2_KERNEL_HEADERS_4_4=y
-# BR2_KERNEL_HEADERS_4_9 is not set
-# BR2_KERNEL_HEADERS_4_10 is not set
-# BR2_KERNEL_HEADERS_4_11 is not set
-# BR2_KERNEL_HEADERS_VERSION is not set
-BR2_DEFAULT_KERNEL_HEADERS="4.4.78"
-BR2_PACKAGE_LINUX_HEADERS=y
-BR2_PACKAGE_GLIBC=y
-# BR2_GLIBC_VERSION_2_23 is not set
-# BR2_GLIBC_VERSION_2_24 is not set
-BR2_GLIBC_VERSION_2_25=y
-BR2_GLIBC_VERSION_STRING="2.25"
-
-#
-# Binutils Options
-#
-# BR2_BINUTILS_VERSION_2_26_X is not set
-# BR2_BINUTILS_VERSION_2_27_X is not set
-BR2_BINUTILS_VERSION_2_28_X=y
-BR2_BINUTILS_VERSION="2.28"
-BR2_BINUTILS_EXTRA_CONFIG_OPTIONS=""
-
-#
-# GCC Options
-#
-# BR2_GCC_VERSION_4_8_X is not set
-# BR2_GCC_VERSION_4_9_X is not set
-BR2_GCC_VERSION_5_X=y
-# BR2_GCC_VERSION_6_X is not set
-BR2_GCC_ARCH_HAS_CONFIGURABLE_DEFAULTS=y
-BR2_GCC_SUPPORTS_FINEGRAINEDMTUNE=y
-BR2_GCC_VERSION="5.4.0"
-BR2_EXTRA_GCC_CONFIG_OPTIONS=""
-# BR2_TOOLCHAIN_BUILDROOT_CXX is not set
-# BR2_TOOLCHAIN_BUILDROOT_FORTRAN is not set
-# BR2_GCC_ENABLE_LTO is not set
-# BR2_GCC_ENABLE_OPENMP is not set
-# BR2_GCC_ENABLE_GRAPHITE is not set
-
-#
-# Host GDB Options
-#
-# BR2_PACKAGE_HOST_GDB is not set
-
-#
-# Toolchain Generic Options
-#
-BR2_TOOLCHAIN_HAS_NATIVE_RPC=y
-BR2_USE_WCHAR=y
-BR2_ENABLE_LOCALE=y
-BR2_TOOLCHAIN_HAS_THREADS=y
-BR2_TOOLCHAIN_HAS_THREADS_DEBUG=y
-BR2_TOOLCHAIN_HAS_THREADS_NPTL=y
-BR2_TOOLCHAIN_HAS_SHADOW_PASSWORDS=y
-BR2_TOOLCHAIN_HAS_SSP=y
-BR2_TOOLCHAIN_SUPPORTS_PIE=y
-# BR2_TOOLCHAIN_GLIBC_GCONV_LIBS_COPY is not set
-BR2_USE_MMU=y
-BR2_TARGET_OPTIMIZATION=""
-BR2_TARGET_LDFLAGS=""
-# BR2_ECLIPSE_REGISTER is not set
-BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0=y
-BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_1=y
-BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_2=y
-BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_3=y
-BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_4=y
-BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_5=y
-BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_6=y
-BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_7=y
-BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_8=y
-BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_9=y
-BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_10=y
-BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_11=y
-BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_12=y
-BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_13=y
-BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_14=y
-BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_15=y
-BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_16=y
-BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_17=y
-BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_18=y
-BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_19=y
-BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_0=y
-BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_1=y
-BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_2=y
-BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_3=y
-BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_4=y
-BR2_TOOLCHAIN_HEADERS_AT_LEAST="4.4"
-BR2_TOOLCHAIN_GCC_AT_LEAST_4_3=y
-BR2_TOOLCHAIN_GCC_AT_LEAST_4_4=y
-BR2_TOOLCHAIN_GCC_AT_LEAST_4_5=y
-BR2_TOOLCHAIN_GCC_AT_LEAST_4_6=y
-BR2_TOOLCHAIN_GCC_AT_LEAST_4_7=y
-BR2_TOOLCHAIN_GCC_AT_LEAST_4_8=y
-BR2_TOOLCHAIN_GCC_AT_LEAST_4_9=y
-BR2_TOOLCHAIN_GCC_AT_LEAST_5=y
-BR2_TOOLCHAIN_GCC_AT_LEAST="5"
-BR2_TOOLCHAIN_HAS_SYNC_1=y
-BR2_TOOLCHAIN_HAS_SYNC_2=y
-BR2_TOOLCHAIN_HAS_SYNC_4=y
-BR2_TOOLCHAIN_HAS_SYNC_8=y
-BR2_TOOLCHAIN_HAS_LIBATOMIC=y
-BR2_TOOLCHAIN_HAS_ATOMIC=y
-BR2_TOOLCHAIN_HAS_LIBQUADMATH=y
-
-#
-# System configuration
-#
-BR2_ROOTFS_SKELETON_DEFAULT=y
-# BR2_ROOTFS_SKELETON_CUSTOM is not set
-# BR2_ROOTFS_MERGED_USR is not set
-BR2_TARGET_GENERIC_HOSTNAME="buildroot"
-BR2_TARGET_GENERIC_ISSUE="Welcome to Buildroot"
-BR2_TARGET_GENERIC_PASSWD_MD5=y
-# BR2_TARGET_GENERIC_PASSWD_SHA256 is not set
-# BR2_TARGET_GENERIC_PASSWD_SHA512 is not set
-BR2_TARGET_GENERIC_PASSWD_METHOD="md5"
-BR2_INIT_BUSYBOX=y
-# BR2_INIT_SYSV is not set
-# BR2_INIT_SYSTEMD is not set
-# BR2_INIT_NONE is not set
-# BR2_ROOTFS_DEVICE_CREATION_STATIC is not set
-BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_DEVTMPFS=y
-# BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_MDEV is not set
-# BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_EUDEV is not set
-BR2_ROOTFS_DEVICE_TABLE="system/device_table.txt"
-# BR2_ROOTFS_DEVICE_TABLE_SUPPORTS_EXTENDED_ATTRIBUTES is not set
-BR2_TARGET_ENABLE_ROOT_LOGIN=y
-BR2_TARGET_GENERIC_ROOT_PASSWD=""
-BR2_SYSTEM_BIN_SH_BUSYBOX=y
-
-#
-# bash, dash, mksh, zsh need BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
-#
-# BR2_SYSTEM_BIN_SH_NONE is not set
-BR2_TARGET_GENERIC_GETTY=y
-BR2_TARGET_GENERIC_GETTY_PORT="console"
-BR2_TARGET_GENERIC_GETTY_BAUDRATE_KEEP=y
-# BR2_TARGET_GENERIC_GETTY_BAUDRATE_9600 is not set
-# BR2_TARGET_GENERIC_GETTY_BAUDRATE_19200 is not set
-# BR2_TARGET_GENERIC_GETTY_BAUDRATE_38400 is not set
-# BR2_TARGET_GENERIC_GETTY_BAUDRATE_57600 is not set
-# BR2_TARGET_GENERIC_GETTY_BAUDRATE_115200 is not set
-BR2_TARGET_GENERIC_GETTY_BAUDRATE="0"
-BR2_TARGET_GENERIC_GETTY_TERM="vt100"
-BR2_TARGET_GENERIC_GETTY_OPTIONS=""
-BR2_TARGET_GENERIC_REMOUNT_ROOTFS_RW=y
-BR2_SYSTEM_DHCP=""
-# BR2_ENABLE_LOCALE_PURGE is not set
-BR2_GENERATE_LOCALE=""
-# BR2_TARGET_TZ_INFO is not set
-BR2_ROOTFS_USERS_TABLES=""
-BR2_ROOTFS_OVERLAY=""
-BR2_ROOTFS_POST_BUILD_SCRIPT=""
-BR2_ROOTFS_POST_FAKEROOT_SCRIPT=""
-BR2_ROOTFS_POST_IMAGE_SCRIPT=""
-
-#
-# Kernel
-#
-BR2_LINUX_KERNEL=y
-BR2_LINUX_KERNEL_LATEST_VERSION=y
-# BR2_LINUX_KERNEL_LATEST_CIP_VERSION is not set
-# BR2_LINUX_KERNEL_CUSTOM_VERSION is not set
-# BR2_LINUX_KERNEL_CUSTOM_TARBALL is not set
-# BR2_LINUX_KERNEL_CUSTOM_GIT is not set
-# BR2_LINUX_KERNEL_CUSTOM_HG is not set
-# BR2_LINUX_KERNEL_CUSTOM_SVN is not set
-BR2_LINUX_KERNEL_VERSION="4.4.78"
-BR2_LINUX_KERNEL_PATCH=""
-# BR2_LINUX_KERNEL_USE_DEFCONFIG is not set
-# BR2_LINUX_KERNEL_USE_ARCH_DEFAULT_CONFIG is not set
-BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
-BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="kernel-defconfig"
-BR2_LINUX_KERNEL_CONFIG_FRAGMENT_FILES=""
-BR2_LINUX_KERNEL_BZIMAGE=y
-# BR2_LINUX_KERNEL_VMLINUX is not set
-# BR2_LINUX_KERNEL_IMAGE_TARGET_CUSTOM is not set
-BR2_LINUX_KERNEL_GZIP=y
-# BR2_LINUX_KERNEL_LZ4 is not set
-# BR2_LINUX_KERNEL_LZMA is not set
-# BR2_LINUX_KERNEL_LZO is not set
-# BR2_LINUX_KERNEL_XZ is not set
-# BR2_LINUX_KERNEL_DTS_SUPPORT is not set
-BR2_LINUX_KERNEL_INSTALL_TARGET=y
-
-#
-# Linux Kernel Extensions
-#
-# BR2_LINUX_KERNEL_EXT_XENOMAI is not set
-# BR2_LINUX_KERNEL_EXT_RTAI is not set
-# BR2_LINUX_KERNEL_EXT_EV3DEV_LINUX_DRIVERS is not set
-# BR2_LINUX_KERNEL_EXT_FBTFT is not set
-# BR2_LINUX_KERNEL_EXT_AUFS is not set
-
-#
-# Linux Kernel Tools
-#
-BR2_PACKAGE_LINUX_TOOLS_CPUPOWER=y
-# BR2_PACKAGE_LINUX_TOOLS_GPIO is not set
-# BR2_PACKAGE_LINUX_TOOLS_IIO is not set
-BR2_PACKAGE_LINUX_TOOLS_PERF=y
-
-#
-# selftests needs BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
-#
-
-#
-# Target packages
-#
-BR2_PACKAGE_BUSYBOX=y
-BR2_PACKAGE_BUSYBOX_CONFIG="package/busybox/busybox.config"
-BR2_PACKAGE_BUSYBOX_CONFIG_FRAGMENT_FILES=""
-# BR2_PACKAGE_BUSYBOX_SHOW_OTHERS is not set
-# BR2_PACKAGE_BUSYBOX_SELINUX is not set
-# BR2_PACKAGE_BUSYBOX_WATCHDOG is not set
-BR2_PACKAGE_SKELETON=y
-
-#
-# Audio and video applications
-#
-# BR2_PACKAGE_ALSA_UTILS is not set
-# BR2_PACKAGE_ATEST is not set
-# BR2_PACKAGE_AUMIX is not set
-
-#
-# bellagio needs a toolchain w/ C++, threads, dynamic library
-#
-# BR2_PACKAGE_DVBLAST is not set
-# BR2_PACKAGE_DVDAUTHOR is not set
-
-#
-# dvdrw-tools needs a toolchain w/ threads, C++, wchar
-#
-
-#
-# espeak needs a toolchain w/ C++, wchar, threads, dynamic library
-#
-# BR2_PACKAGE_FAAD2 is not set
-BR2_PACKAGE_FFMPEG_ARCH_SUPPORTS=y
-# BR2_PACKAGE_FFMPEG is not set
-# BR2_PACKAGE_FLAC is not set
-# BR2_PACKAGE_FLITE is not set
-# BR2_PACKAGE_GMRENDER_RESURRECT is not set
-# BR2_PACKAGE_GSTREAMER is not set
-# BR2_PACKAGE_GSTREAMER1 is not set
-
-#
-# jack2 needs a toolchain w/ threads, C++, dynamic library
-#
-BR2_PACKAGE_KODI_ARCH_SUPPORTS=y
-
-#
-# kodi needs python w/ .py modules, a uClibc or glibc toolchain w/ C++, locale, threads, wchar, dynamic library, gcc >= 4.8, host gcc >= 4.6
-#
-
-#
-# kodi needs an OpenGL EGL with either an openGL or an OpenGL ES backend
-#
-# BR2_PACKAGE_LAME is not set
-# BR2_PACKAGE_MADPLAY is not set
-# BR2_PACKAGE_MIMIC is not set
-
-#
-# miraclecast needs systemd and a glibc toolchain w/ threads and wchar
-#
-
-#
-# mjpegtools needs a toolchain w/ C++, threads
-#
-
-#
-# modplugtools needs a toolchain w/ C++
-#
-# BR2_PACKAGE_MOTION is not set
-
-#
-# mpd needs a toolchain w/ C++, threads, wchar, gcc >= 4.9
-#
-# BR2_PACKAGE_MPD_MPC is not set
-# BR2_PACKAGE_MPG123 is not set
-BR2_PACKAGE_MPLAYER_ARCH_SUPPORTS=y
-# BR2_PACKAGE_MPLAYER is not set
-# BR2_PACKAGE_MPV is not set
-# BR2_PACKAGE_MULTICAT is not set
-# BR2_PACKAGE_MUSEPACK is not set
-# BR2_PACKAGE_NCMPC is not set
-# BR2_PACKAGE_OPUS_TOOLS is not set
-# BR2_PACKAGE_PULSEAUDIO is not set
-# BR2_PACKAGE_SOX is not set
-# BR2_PACKAGE_SQUEEZELITE is not set
-
-#
-# tovid needs a toolchain w/ threads, C++, wchar
-#
-
-#
-# tovid depends on python or python3
-#
-# BR2_PACKAGE_TSTOOLS is not set
-# BR2_PACKAGE_TWOLAME is not set
-# BR2_PACKAGE_UDPXY is not set
-
-#
-# upmpdcli needs a toolchain w/ C++, threads, gcc >= 4.7
-#
-
-#
-# v4l2grab needs a toolchain w/ threads, dynamic library, C++ and headers >= 3.0
-#
-
-#
-# vlc needs a toolchain w/ C++, dynamic library, wchar, threads, headers >= 3.7
-#
-# BR2_PACKAGE_VORBIS_TOOLS is not set
-# BR2_PACKAGE_WAVPACK is not set
-# BR2_PACKAGE_YAVTA is not set
-# BR2_PACKAGE_YMPD is not set
-
-#
-# Compressors and decompressors
-#
-# BR2_PACKAGE_BZIP2 is not set
-# BR2_PACKAGE_LZ4 is not set
-
-#
-# lzip needs a toolchain w/ C++
-#
-# BR2_PACKAGE_LZOP is not set
-
-#
-# p7zip needs a toolchain w/ threads, wchar, C++
-#
-
-#
-# unrar needs a toolchain w/ C++, wchar, threads
-#
-# BR2_PACKAGE_XZ is not set
-# BR2_PACKAGE_ZIP is not set
-
-#
-# Debugging, profiling and benchmark
-#
-# BR2_PACKAGE_BLKTRACE is not set
-
-#
-# bonnie++ needs a toolchain w/ C++
-#
-# BR2_PACKAGE_CACHE_CALIBRATOR is not set
-# BR2_PACKAGE_DHRYSTONE is not set
-# BR2_PACKAGE_DIEHARDER is not set
-# BR2_PACKAGE_DMALLOC is not set
-# BR2_PACKAGE_DROPWATCH is not set
-# BR2_PACKAGE_DSTAT is not set
-# BR2_PACKAGE_DT is not set
-
-#
-# duma needs a toolchain w/ C++, threads, dynamic library
-#
-# BR2_PACKAGE_FIO is not set
-# BR2_PACKAGE_FWTS is not set
-# BR2_PACKAGE_GDB is not set
-BR2_PACKAGE_GOOGLE_BREAKPAD_ARCH_SUPPORTS=y
-
-#
-# google-breakpad requires a glibc or uClibc toolchain w/ wchar, thread, C++, gcc >= 4.8
-#
-# BR2_PACKAGE_IOZONE is not set
-# BR2_PACKAGE_KEXEC is not set
-# BR2_PACKAGE_KTAP is not set
-# BR2_PACKAGE_KVM_UNIT_TESTS is not set
-# BR2_PACKAGE_LATENCYTOP is not set
-# BR2_PACKAGE_LMBENCH is not set
-BR2_PACKAGE_LTP_TESTSUITE_ARCH_SUPPORTS=y
-# BR2_PACKAGE_LTP_TESTSUITE is not set
-# BR2_PACKAGE_LTRACE is not set
-# BR2_PACKAGE_LTTNG_BABELTRACE is not set
-# BR2_PACKAGE_LTTNG_MODULES is not set
-# BR2_PACKAGE_LTTNG_TOOLS is not set
-# BR2_PACKAGE_MCELOG is not set
-# BR2_PACKAGE_MEMSTAT is not set
-# BR2_PACKAGE_NETPERF is not set
-# BR2_PACKAGE_NETSNIFF_NG is not set
-# BR2_PACKAGE_NMON is not set
-BR2_PACKAGE_OPROFILE_ARCH_SUPPORTS=y
-
-#
-# oprofile needs a toolchain w/ C++, wchar
-#
-# BR2_PACKAGE_PAX_UTILS is not set
-# BR2_PACKAGE_PV is not set
-
-#
-# racehound needs a uClibc or glibc toolchain w/ C++, wchar, dynamic library
-#
-# BR2_PACKAGE_RAMSMP is not set
-# BR2_PACKAGE_RAMSPEED is not set
-# BR2_PACKAGE_RT_TESTS is not set
-# BR2_PACKAGE_SPIDEV_TEST is not set
-# BR2_PACKAGE_STRACE is not set
-# BR2_PACKAGE_STRESS is not set
-# BR2_PACKAGE_STRESS_NG is not set
-
-#
-# sysdig needs a toolchain w/ C++, gcc >= 4.7, dynamic library and a Linux kernel to be built
-#
-# BR2_PACKAGE_SYSPROF is not set
-# BR2_PACKAGE_TINYMEMBENCH is not set
-# BR2_PACKAGE_TRACE_CMD is not set
-BR2_PACKAGE_TRINITY_ARCH_SUPPORTS=y
-# BR2_PACKAGE_TRINITY is not set
-# BR2_PACKAGE_UCLIBC_NG_TEST is not set
-# BR2_PACKAGE_VALGRIND is not set
-# BR2_PACKAGE_WHETSTONE is not set
-
-#
-# Development tools
-#
-# BR2_PACKAGE_BINUTILS is not set
-# BR2_PACKAGE_BSDIFF is not set
-# BR2_PACKAGE_CHECK is not set
-BR2_PACKAGE_CMAKE_ARCH_SUPPORTS=y
-
-#
-# ctest needs a toolchain w/ C++, wchar, dynamic library, gcc >= 4.7, NPTL
-#
-
-#
-# cppunit needs a toolchain w/ C++, dynamic library
-#
-# BR2_PACKAGE_CVS is not set
-
-#
-# cxxtest needs a toolchain w/ C++ support
-#
-# BR2_PACKAGE_FLEX is not set
-BR2_PACKAGE_GETTEXT=y
-# BR2_PACKAGE_GIT is not set
-
-#
-# git-crypt needs a toolchain w/ C++
-#
-
-#
-# gperf needs a toolchain w/ C++
-#
-# BR2_PACKAGE_JO is not set
-# BR2_PACKAGE_JQ is not set
-# BR2_PACKAGE_LIBTOOL is not set
-# BR2_PACKAGE_MAKE is not set
-# BR2_PACKAGE_PKGCONF is not set
-# BR2_PACKAGE_SUBVERSION is not set
-# BR2_PACKAGE_TREE is not set
-# BR2_PACKAGE_YASM is not set
-
-#
-# Filesystem and flash utilities
-#
-# BR2_PACKAGE_AUFS_UTIL is not set
-# BR2_PACKAGE_AUTOFS is not set
-# BR2_PACKAGE_BTRFS_PROGS is not set
-# BR2_PACKAGE_CIFS_UTILS is not set
-# BR2_PACKAGE_CPIO is not set
-# BR2_PACKAGE_CRAMFS is not set
-# BR2_PACKAGE_CURLFTPFS is not set
-# BR2_PACKAGE_DOSFSTOOLS is not set
-# BR2_PACKAGE_E2FSPROGS is not set
-# BR2_PACKAGE_E2TOOLS is not set
-# BR2_PACKAGE_ECRYPTFS_UTILS is not set
-# BR2_PACKAGE_EXFAT is not set
-# BR2_PACKAGE_EXFAT_UTILS is not set
-# BR2_PACKAGE_F2FS_TOOLS is not set
-# BR2_PACKAGE_FLASHBENCH is not set
-# BR2_PACKAGE_FWUP is not set
-# BR2_PACKAGE_GENEXT2FS is not set
-# BR2_PACKAGE_GENPART is not set
-# BR2_PACKAGE_GENROMFS is not set
-# BR2_PACKAGE_MMC_UTILS is not set
-# BR2_PACKAGE_MTD is not set
-# BR2_PACKAGE_MTOOLS is not set
-# BR2_PACKAGE_NFS_UTILS is not set
-# BR2_PACKAGE_NTFS_3G is not set
-# BR2_PACKAGE_SIMICSFS is not set
-# BR2_PACKAGE_SP_OOPS_EXTRACT is not set
-# BR2_PACKAGE_SQUASHFS is not set
-# BR2_PACKAGE_SSHFS is not set
-# BR2_PACKAGE_UNIONFS is not set
-# BR2_PACKAGE_XFSPROGS is not set
-
-#
-# Fonts, cursors, icons, sounds and themes
-#
-
-#
-# Cursors
-#
-# BR2_PACKAGE_COMIX_CURSORS is not set
-# BR2_PACKAGE_OBSIDIAN_CURSORS is not set
-
-#
-# Fonts
-#
-# BR2_PACKAGE_BITSTREAM_VERA is not set
-# BR2_PACKAGE_CANTARELL is not set
-# BR2_PACKAGE_DEJAVU is not set
-# BR2_PACKAGE_FONT_AWESOME is not set
-# BR2_PACKAGE_GHOSTSCRIPT_FONTS is not set
-# BR2_PACKAGE_INCONSOLATA is not set
-# BR2_PACKAGE_LIBERATION is not set
-
-#
-# Icons
-#
-# BR2_PACKAGE_GOOGLE_MATERIAL_DESIGN_ICONS is not set
-# BR2_PACKAGE_HICOLOR_ICON_THEME is not set
-
-#
-# Sounds
-#
-# BR2_PACKAGE_SOUND_THEME_BOREALIS is not set
-# BR2_PACKAGE_SOUND_THEME_FREEDESKTOP is not set
-
-#
-# Themes
-#
-
-#
-# Games
-#
-# BR2_PACKAGE_CHOCOLATE_DOOM is not set
-
-#
-# gnuchess needs a toolchain w/ C++, threads
-#
-# BR2_PACKAGE_LBREAKOUT2 is not set
-# BR2_PACKAGE_LTRIS is not set
-# BR2_PACKAGE_OPENTYRIAN is not set
-# BR2_PACKAGE_PRBOOM is not set
-# BR2_PACKAGE_SL is not set
-
-#
-# stella needs a toolchain w/ dynamic library, C++, gcc >= 4.8
-#
-
-#
-# Graphic libraries and applications (graphic/text)
-#
-
-#
-# Graphic applications
-#
-
-#
-# expedite needs a toolchain w/ C++
-#
-# BR2_PACKAGE_FSWEBCAM is not set
-# BR2_PACKAGE_GHOSTSCRIPT is not set
-
-#
-# glmark2 needs a toolchain w/ C++, gcc >= 4.9
-#
-# BR2_PACKAGE_GNUPLOT is not set
-# BR2_PACKAGE_JHEAD is not set
-# BR2_PACKAGE_PNGQUANT is not set
-# BR2_PACKAGE_RRDTOOL is not set
-
-#
-# tesseract-ocr needs a toolchain w/ threads, C++, gcc >= 4.8, dynamic library, wchar
-#
-
-#
-# Graphic libraries
-#
-
-#
-# cegui06 needs a toolchain w/ C++, threads, dynamic library
-#
-
-#
-# directfb needs a glibc or uClibc toolchain w/ C++, NPTL, gcc >= 4.5, dynamic library
-#
-
-#
-# efl needs a toolchain w/ C++, dynamic library, gcc >= 4.7, threads, wchar
-#
-# BR2_PACKAGE_FBDUMP is not set
-# BR2_PACKAGE_FBGRAB is not set
-# BR2_PACKAGE_FB_TEST_APP is not set
-
-#
-# fbterm needs a toolchain w/ C++, wchar, locale
-#
-# BR2_PACKAGE_FBV is not set
-
-#
-# freerdp needs a toolchain w/ wchar, dynamic library, threads, C++
-#
-# BR2_PACKAGE_IMAGEMAGICK is not set
-# BR2_PACKAGE_LINUX_FUSION is not set
-
-#
-# mesa3d needs a toolchain w/ C++, NPTL, dynamic library
-#
-
-#
-# ocrad needs a toolchain w/ C++
-#
-# BR2_PACKAGE_PSPLASH is not set
-# BR2_PACKAGE_SDL is not set
-# BR2_PACKAGE_SDL2 is not set
-
-#
-# Other GUIs
-#
-
-#
-# qt needs a toolchain w/ C++, threads
-#
-BR2_PACKAGE_QT5_JSCORE_AVAILABLE=y
-
-#
-# Qt5 needs a toolchain w/ wchar, NPTL, C++, dynamic library
-#
-
-#
-# tekui needs a Lua interpreter and a toolchain w/ threads, dynamic library
-#
-
-#
-# weston needs udev and a toolchain w/ locale, threads, dynamic library, headers >= 3.0
-#
-# BR2_PACKAGE_XORG7 is not set
-
-#
-# midori needs libgtk3 and a glibc toolchain w/ C++, gcc >= 4.9
-#
-# BR2_PACKAGE_XKEYBOARD_CONFIG is not set
-
-#
-# Hardware handling
-#
-
-#
-# Firmware
-#
-# BR2_PACKAGE_B43_FIRMWARE is not set
-# BR2_PACKAGE_LINUX_FIRMWARE is not set
-# BR2_PACKAGE_UX500_FIRMWARE is not set
-# BR2_PACKAGE_WILC1000_FIRMWARE is not set
-# BR2_PACKAGE_WILINK_BT_FIRMWARE is not set
-# BR2_PACKAGE_ZD1211_FIRMWARE is not set
-# BR2_PACKAGE_ACPICA is not set
-# BR2_PACKAGE_ACPID is not set
-
-#
-# acpitool needs a toolchain w/ threads, C++, dynamic library
-#
-# BR2_PACKAGE_AER_INJECT is not set
-# BR2_PACKAGE_AMD_CATALYST is not set
-# BR2_PACKAGE_AVRDUDE is not set
-
-#
-# bcache-tools needs udev /dev management
-#
-
-#
-# cc-tool needs a toolchain w/ C++, threads, wchar
-#
-# BR2_PACKAGE_CDRKIT is not set
-# BR2_PACKAGE_CRYPTSETUP is not set
-# BR2_PACKAGE_CWIID is not set
-# BR2_PACKAGE_DBUS is not set
-# BR2_PACKAGE_DMIDECODE is not set
-# BR2_PACKAGE_DMRAID is not set
-# BR2_PACKAGE_DTV_SCAN_TABLES is not set
-# BR2_PACKAGE_DVB_APPS is not set
-# BR2_PACKAGE_DVBSNOOP is not set
-# BR2_PACKAGE_EDID_DECODE is not set
-# BR2_PACKAGE_EEPROG is not set
-
-#
-# eudev needs eudev /dev management
-#
-# BR2_PACKAGE_EVEMU is not set
-# BR2_PACKAGE_EVTEST is not set
-# BR2_PACKAGE_FAN_CTRL is not set
-# BR2_PACKAGE_FCONFIG is not set
-# BR2_PACKAGE_FIS is not set
-# BR2_PACKAGE_FLASHROM is not set
-# BR2_PACKAGE_FMTOOLS is not set
-# BR2_PACKAGE_FXLOAD is not set
-# BR2_PACKAGE_GADGETFS_TEST is not set
-# BR2_PACKAGE_GPM is not set
-# BR2_PACKAGE_GPSD is not set
-
-#
-# gptfdisk needs a toolchain w/ C++
-#
-# BR2_PACKAGE_GVFS is not set
-# BR2_PACKAGE_HWDATA is not set
-# BR2_PACKAGE_HWLOC is not set
-# BR2_PACKAGE_I7Z is not set
-# BR2_PACKAGE_INPUT_EVENT_DAEMON is not set
-# BR2_PACKAGE_INPUT_TOOLS is not set
-# BR2_PACKAGE_INTEL_MICROCODE is not set
-# BR2_PACKAGE_IOSTAT is not set
-# BR2_PACKAGE_IPMITOOL is not set
-# BR2_PACKAGE_IPMIUTIL is not set
-# BR2_PACKAGE_IQVLINUX is not set
-# BR2_PACKAGE_IRDA_UTILS is not set
-# BR2_PACKAGE_IUCODE_TOOL is not set
-# BR2_PACKAGE_KBD is not set
-# BR2_PACKAGE_LCDPROC is not set
-# BR2_PACKAGE_LIBUIO is not set
-# BR2_PACKAGE_LINUX_BACKPORTS is not set
-
-#
-# lirc-tools needs a toolchain w/ threads, dynamic library, C++
-#
-# BR2_PACKAGE_LM_SENSORS is not set
-
-#
-# lshw needs a toolchain w/ C++, wchar
-#
-# BR2_PACKAGE_LSUIO is not set
-# BR2_PACKAGE_LVM2 is not set
-# BR2_PACKAGE_MDADM is not set
-# BR2_PACKAGE_MEMTEST86 is not set
-# BR2_PACKAGE_MEMTESTER is not set
-# BR2_PACKAGE_MEMTOOL is not set
-# BR2_PACKAGE_MINICOM is not set
-BR2_PACKAGE_MSR_TOOLS=y
-# BR2_PACKAGE_NANOCOM is not set
-# BR2_PACKAGE_NEARD is not set
-# BR2_PACKAGE_NVIDIA_DRIVER is not set
-# BR2_PACKAGE_NVME is not set
-# BR2_PACKAGE_OFONO is not set
-# BR2_PACKAGE_OPEN2300 is not set
-# BR2_PACKAGE_OPENIPMI is not set
-# BR2_PACKAGE_OPENOCD is not set
-
-#
-# openpowerlink needs a toolchain w/ C++, threads
-#
-# BR2_PACKAGE_PARTED is not set
-# BR2_PACKAGE_PCIUTILS is not set
-# BR2_PACKAGE_PDBG is not set
-# BR2_PACKAGE_PICOCOM is not set
-
-#
-# powertop needs a toolchain w/ C++, threads, wchar
-#
-# BR2_PACKAGE_PPS_TOOLS is not set
-# BR2_PACKAGE_READ_EDID is not set
-# BR2_PACKAGE_RFKILL is not set
-# BR2_PACKAGE_RNG_TOOLS is not set
-# BR2_PACKAGE_RS485CONF is not set
-# BR2_PACKAGE_RTL8188EU is not set
-# BR2_PACKAGE_RTL8723BS is not set
-# BR2_PACKAGE_RTL8821AU is not set
-# BR2_PACKAGE_SANE_BACKENDS is not set
-# BR2_PACKAGE_SDPARM is not set
-# BR2_PACKAGE_SETSERIAL is not set
-# BR2_PACKAGE_SG3_UTILS is not set
-# BR2_PACKAGE_SIGROK_CLI is not set
-# BR2_PACKAGE_SISPMCTL is not set
-
-#
-# smartmontools needs a toolchain w/ C++
-#
-# BR2_PACKAGE_SMSTOOLS3 is not set
-# BR2_PACKAGE_SPI_TOOLS is not set
-# BR2_PACKAGE_SREDIRD is not set
-# BR2_PACKAGE_STATSERIAL is not set
-# BR2_PACKAGE_STM32FLASH is not set
-# BR2_PACKAGE_SYSSTAT is not set
-
-#
-# targetcli-fb depends on Python
-#
-
-#
-# ti-sgx-um needs the ti-sgx-km driver
-#
-# BR2_PACKAGE_TI_UIM is not set
-# BR2_PACKAGE_TI_UTILS is not set
-# BR2_PACKAGE_TRIGGERHAPPY is not set
-# BR2_PACKAGE_UBOOT_TOOLS is not set
-# BR2_PACKAGE_UBUS is not set
-# BR2_PACKAGE_UCCP420WLAN is not set
-
-#
-# udisks needs udev /dev management
-#
-
-#
-# upower needs udev /dev management
-#
-# BR2_PACKAGE_USB_MODESWITCH is not set
-# BR2_PACKAGE_USB_MODESWITCH_DATA is not set
-
-#
-# usbmount requires udev to be enabled
-#
-
-#
-# usbutils needs udev /dev management and toolchain w/ threads
-#
-# BR2_PACKAGE_W_SCAN is not set
-# BR2_PACKAGE_WIPE is not set
-# BR2_PACKAGE_XORRISO is not set
-
-#
-# Interpreter languages and scripting
-#
-# BR2_PACKAGE_4TH is not set
-# BR2_PACKAGE_ENSCRIPT is not set
-BR2_PACKAGE_ERLANG_ARCH_SUPPORTS=y
-# BR2_PACKAGE_ERLANG is not set
-# BR2_PACKAGE_EXECLINE is not set
-# BR2_PACKAGE_FICL is not set
-BR2_PACKAGE_GAUCHE_ARCH_SUPPORTS=y
-# BR2_PACKAGE_GAUCHE is not set
-# BR2_PACKAGE_GUILE is not set
-# BR2_PACKAGE_HASERL is not set
-# BR2_PACKAGE_JAMVM is not set
-# BR2_PACKAGE_JIMTCL is not set
-# BR2_PACKAGE_LUA is not set
-BR2_PACKAGE_LUAJIT_ARCH_SUPPORTS=y
-# BR2_PACKAGE_LUAJIT is not set
-# BR2_PACKAGE_MICROPYTHON is not set
-# BR2_PACKAGE_MOARVM is not set
-BR2_PACKAGE_MONO_ARCH_SUPPORTS=y
-# BR2_PACKAGE_MONO is not set
-BR2_PACKAGE_NODEJS_ARCH_SUPPORTS=y
-
-#
-# nodejs needs a toolchain w/ C++, dynamic library, threads, gcc >= 4.8, wchar
-#
-# BR2_PACKAGE_PERL is not set
-# BR2_PACKAGE_PHP is not set
-# BR2_PACKAGE_PYTHON is not set
-# BR2_PACKAGE_PYTHON3 is not set
-# BR2_PACKAGE_RUBY is not set
-# BR2_PACKAGE_TCL is not set
-
-#
-# Libraries
-#
-
-#
-# Audio/Sound
-#
-# BR2_PACKAGE_ALSA_LIB is not set
-# BR2_PACKAGE_AUBIO is not set
-
-#
-# audiofile needs a toolchain w/ C++
-#
-# BR2_PACKAGE_CELT051 is not set
-BR2_PACKAGE_FDK_AAC_ARCH_SUPPORTS=y
-
-#
-# fdk-aac needs a toolchain w/ C++
-#
-# BR2_PACKAGE_LIBAO is not set
-
-#
-# asplib needs a toolchain w/ C++
-#
-# BR2_PACKAGE_LIBBROADVOICE is not set
-# BR2_PACKAGE_LIBCDAUDIO is not set
-# BR2_PACKAGE_LIBCDDB is not set
-# BR2_PACKAGE_LIBCDIO is not set
-# BR2_PACKAGE_LIBCODEC2 is not set
-# BR2_PACKAGE_LIBCUE is not set
-# BR2_PACKAGE_LIBCUEFILE is not set
-# BR2_PACKAGE_LIBEBUR128 is not set
-# BR2_PACKAGE_LIBG7221 is not set
-# BR2_PACKAGE_LIBGSM is not set
-# BR2_PACKAGE_LIBID3TAG is not set
-# BR2_PACKAGE_LIBILBC is not set
-# BR2_PACKAGE_LIBLO is not set
-# BR2_PACKAGE_LIBMAD is not set
-
-#
-# libmodplug needs a toolchain w/ C++
-#
-# BR2_PACKAGE_LIBMPD is not set
-# BR2_PACKAGE_LIBMPDCLIENT is not set
-# BR2_PACKAGE_LIBREPLAYGAIN is not set
-# BR2_PACKAGE_LIBSAMPLERATE is not set
-
-#
-# libsidplay2 needs a toolchain w/ C++
-#
-# BR2_PACKAGE_LIBSILK is not set
-# BR2_PACKAGE_LIBSNDFILE is not set
-
-#
-# libsoundtouch needs a toolchain w/ C++
-#
-# BR2_PACKAGE_LIBSOXR is not set
-# BR2_PACKAGE_LIBVORBIS is not set
-
-#
-# mp4v2 needs a toolchain w/ C++
-#
-BR2_PACKAGE_OPENAL_ARCH_SUPPORTS=y
-
-#
-# openal needs a toolchain w/ NPTL, C++
-#
-
-#
-# opencore-amr needs a toolchain w/ C++
-#
-# BR2_PACKAGE_OPUS is not set
-# BR2_PACKAGE_OPUSFILE is not set
-# BR2_PACKAGE_PORTAUDIO is not set
-# BR2_PACKAGE_SBC is not set
-# BR2_PACKAGE_SPEEX is not set
-
-#
-# taglib needs a toolchain w/ C++, wchar
-#
-# BR2_PACKAGE_TINYALSA is not set
-# BR2_PACKAGE_TREMOR is not set
-# BR2_PACKAGE_VO_AACENC is not set
-BR2_PACKAGE_WEBRTC_AUDIO_PROCESSING_ARCH_SUPPORTS=y
-
-#
-# webrtc-audio-processing needs a toolchain w/ C++, NPTL, gcc >= 4.8
-#
-
-#
-# Compression and decompression
-#
-# BR2_PACKAGE_LIBARCHIVE is not set
-
-#
-# libsquish needs a toolchain w/ C++, dynamic library
-#
-# BR2_PACKAGE_LIBZIP is not set
-# BR2_PACKAGE_LZO is not set
-# BR2_PACKAGE_MINIZIP is not set
-
-#
-# snappy needs a toolchain w/ C++
-#
-# BR2_PACKAGE_SZIP is not set
-BR2_PACKAGE_ZLIB=y
-
-#
-# Crypto
-#
-# BR2_PACKAGE_BEECRYPT is not set
-BR2_PACKAGE_BOTAN_ARCH_SUPPORTS=y
-
-#
-# botan needs a toolchain w/ C++, threads
-#
-# BR2_PACKAGE_CA_CERTIFICATES is not set
-# BR2_PACKAGE_CRYPTODEV is not set
-# BR2_PACKAGE_GCR is not set
-# BR2_PACKAGE_GNUTLS is not set
-# BR2_PACKAGE_LIBASSUAN is not set
-# BR2_PACKAGE_LIBGCRYPT is not set
-BR2_PACKAGE_LIBGPG_ERROR_ARCH_SUPPORTS=y
-# BR2_PACKAGE_LIBGPG_ERROR is not set
-BR2_PACKAGE_LIBGPG_ERROR_SYSCFG="x86_64-pc-linux-gnu"
-# BR2_PACKAGE_LIBGPGME is not set
-# BR2_PACKAGE_LIBKCAPI is not set
-# BR2_PACKAGE_LIBKSBA is not set
-# BR2_PACKAGE_LIBMCRYPT is not set
-# BR2_PACKAGE_LIBMHASH is not set
-# BR2_PACKAGE_LIBNSS is not set
-# BR2_PACKAGE_LIBSCRYPT is not set
-# BR2_PACKAGE_LIBSECRET is not set
-# BR2_PACKAGE_LIBSHA1 is not set
-# BR2_PACKAGE_LIBSODIUM is not set
-# BR2_PACKAGE_LIBSSH is not set
-# BR2_PACKAGE_LIBSSH2 is not set
-# BR2_PACKAGE_LIBTOMCRYPT is not set
-# BR2_PACKAGE_LIBUECC is not set
-# BR2_PACKAGE_MBEDTLS is not set
-# BR2_PACKAGE_NETTLE is not set
-BR2_PACKAGE_OPENSSL=y
-# BR2_PACKAGE_OPENSSL_BIN is not set
-# BR2_PACKAGE_OPENSSL_ENGINES is not set
-# BR2_PACKAGE_TINYDTLS is not set
-# BR2_PACKAGE_TROUSERS is not set
-# BR2_PACKAGE_USTREAM_SSL is not set
-
-#
-# Database
-#
-# BR2_PACKAGE_BERKELEYDB is not set
-# BR2_PACKAGE_GDBM is not set
-# BR2_PACKAGE_HIREDIS is not set
-
-#
-# kompexsqlite needs a toolchain w/ C++, wchar, threads, dynamic library
-#
-
-#
-# leveldb needs a toolchain w/ C++, threads
-#
-BR2_PACKAGE_MONGODB_ARCH_SUPPORTS=y
-
-#
-# mongodb needs a glibc toolchain w/ wchar, threads, C++, gcc >= 4.8
-#
-
-#
-# mysql needs a toolchain w/ C++, threads
-#
-# BR2_PACKAGE_POSTGRESQL is not set
-# BR2_PACKAGE_REDIS is not set
-# BR2_PACKAGE_SQLCIPHER is not set
-# BR2_PACKAGE_SQLITE is not set
-# BR2_PACKAGE_UNIXODBC is not set
-
-#
-# Filesystem
-#
-# BR2_PACKAGE_GAMIN is not set
-# BR2_PACKAGE_LIBCONFIG is not set
-# BR2_PACKAGE_LIBCONFUSE is not set
-# BR2_PACKAGE_LIBFUSE is not set
-# BR2_PACKAGE_LIBLOCKFILE is not set
-# BR2_PACKAGE_LIBNFS is not set
-# BR2_PACKAGE_LIBSYSFS is not set
-# BR2_PACKAGE_LOCKDEV is not set
-
-#
-# physfs needs a toolchain w/ C++
-#
-
-#
-# Graphics
-#
-
-#
-# assimp needs a toolchain w/ C++
-#
-# BR2_PACKAGE_ATK is not set
-
-#
-# atkmm needs a toolchain w/ C++, wchar, threads, gcc >= 4.8
-#
-
-#
-# bullet needs a toolchain w/ C++
-#
-# BR2_PACKAGE_CAIRO is not set
-
-#
-# cairomm needs a toolchain w/ C++, wchar, threads, gcc >= 4.8
-#
-
-#
-# exiv2 needs a toolchain w/ C++, wchar, dynamic library
-#
-# BR2_PACKAGE_FONTCONFIG is not set
-# BR2_PACKAGE_FREETYPE is not set
-# BR2_PACKAGE_GD is not set
-# BR2_PACKAGE_GDK_PIXBUF is not set
-# BR2_PACKAGE_GIFLIB is not set
-
-#
-# granite needs libgtk3 and a toolchain w/ wchar, threads
-#
-
-#
-# graphite2 needs a toolchain w/ C++, dynamic library
-#
-
-#
-# gtkmm3 needs libgtk3 and a toolchain w/ C++, wchar, threads, gcc >= 4.8
-#
-
-#
-# harfbuzz needs a toolchain w/ C++
-#
-# BR2_PACKAGE_IJS is not set
-# BR2_PACKAGE_IMLIB2 is not set
-# BR2_PACKAGE_JASPER is not set
-# BR2_PACKAGE_JPEG is not set
-BR2_PACKAGE_JPEG_SIMD_SUPPORT=y
-
-#
-# kms++ needs a toolchain w/ threads, C++, gcc >= 4.8, headers >= 3.8
-#
-# BR2_PACKAGE_LCMS2 is not set
-
-#
-# lensfun needs a toolchain w/ C++, threads, wchar
-#
-# BR2_PACKAGE_LEPTONICA is not set
-# BR2_PACKAGE_LIBART is not set
-# BR2_PACKAGE_LIBDMTX is not set
-# BR2_PACKAGE_LIBDRM is not set
-
-#
-# libepoxy needs an OpenGL and/or OpenGL EGL backend
-#
-# BR2_PACKAGE_LIBEXIF is not set
-
-#
-# libfm needs X.org and a toolchain w/ wchar, threads, C++
-#
-# BR2_PACKAGE_LIBFM_EXTRA is not set
-
-#
-# libfreeglut depends on X.org and needs an OpenGL backend
-#
-
-#
-# libfreeimage needs a toolchain w/ C++, dynamic library, wchar
-#
-# BR2_PACKAGE_LIBGEOTIFF is not set
-
-#
-# libglew depends on X.org and needs an OpenGL backend
-#
-
-#
-# libglfw depends on X.org and needs an OpenGL backend
-#
-
-#
-# libglu needs an OpenGL backend
-#
-
-#
-# libgtk3 needs a toolchain w/ wchar, threads, C++
-#
-
-#
-# libgtk3 needs an OpenGL or an OpenGL-EGL/wayland backend
-#
-# BR2_PACKAGE_LIBMEDIAART is not set
-# BR2_PACKAGE_LIBMNG is not set
-# BR2_PACKAGE_LIBPNG is not set
-# BR2_PACKAGE_LIBQRENCODE is not set
-
-#
-# libraw needs a toolchain w/ C++
-#
-
-#
-# librsvg needs a toolchain w/ wchar, threads, C++
-#
-
-#
-# libsoil needs an OpenGL backend and a toolchain w/ dynamic library
-#
-# BR2_PACKAGE_LIBSVG is not set
-# BR2_PACKAGE_LIBSVG_CAIRO is not set
-# BR2_PACKAGE_LIBSVGTINY is not set
-# BR2_PACKAGE_LIBVA is not set
-# BR2_PACKAGE_LIBVA_INTEL_DRIVER is not set
-
-#
-# libvips needs a toolchain w/ wchar, threads, C++
-#
-# BR2_PACKAGE_MENU_CACHE is not set
-
-#
-# opencv needs a toolchain w/ C++, NPTL, wchar
-#
-
-#
-# opencv3 needs a toolchain w/ C++, NPTL, wchar, dynamic library
-#
-# BR2_PACKAGE_OPENJPEG is not set
-
-#
-# pango needs a toolchain w/ wchar, threads, C++
-#
-
-#
-# pangomm needs a toolchain w/ C++, wchar, threads, gcc >= 4.8
-#
-BR2_PACKAGE_PIXMAN=y
-
-#
-# poppler needs a toolchain w/ C++, threads
-#
-# BR2_PACKAGE_TIFF is not set
-# BR2_PACKAGE_WAYLAND is not set
-BR2_PACKAGE_WEBKITGTK_ARCH_SUPPORTS=y
-
-#
-# webkitgtk needs libgtk3 and a glibc toolchain w/ C++, gcc >= 4.9
-#
-# BR2_PACKAGE_WEBP is not set
-
-#
-# zbar needs a toolchain w/ threads, dynamic library, C++ and headers >= 3.0
-#
-
-#
-# zxing-cpp needs a toolchain w/ C++, dynamic library
-#
-
-#
-# Hardware handling
-#
-# BR2_PACKAGE_ACSCCID is not set
-# BR2_PACKAGE_C_PERIPHERY is not set
-# BR2_PACKAGE_CCID is not set
-# BR2_PACKAGE_DTC is not set
-# BR2_PACKAGE_GNU_EFI is not set
-
-#
-# hidapi needs udev /dev management and a toolchain w/ NPTL threads
-#
-
-#
-# lcdapi needs a toolchain w/ C++, threads
-#
-BR2_PACKAGE_LIBAIO_ARCH_SUPPORTS=y
-# BR2_PACKAGE_LIBAIO is not set
-
-#
-# libatasmart requires udev to be enabled
-#
-
-#
-# libcec needs a toolchain w/ C++, wchar, threads, dynamic library, gcc >= 4.7
-#
-# BR2_PACKAGE_LIBFREEFARE is not set
-# BR2_PACKAGE_LIBFTDI is not set
-# BR2_PACKAGE_LIBFTDI1 is not set
-# BR2_PACKAGE_LIBGPHOTO2 is not set
-
-#
-# libgpiod needs kernel headers >= 4.8
-#
-
-#
-# libgudev needs udev /dev handling and a toolchain w/ wchar, threads
-#
-# BR2_PACKAGE_LIBHID is not set
-# BR2_PACKAGE_LIBIIO is not set
-
-#
-# libinput needs udev /dev management and a toolchain w/ locale
-#
-# BR2_PACKAGE_LIBIQRF is not set
-# BR2_PACKAGE_LIBLLCP is not set
-
-#
-# libmbim needs udev /dev management and a toolchain w/ wchar, threads
-#
-# BR2_PACKAGE_LIBNFC is not set
-# BR2_PACKAGE_LIBPCIACCESS is not set
-# BR2_PACKAGE_LIBPHIDGET is not set
-# BR2_PACKAGE_LIBQMI is not set
-# BR2_PACKAGE_LIBRAW1394 is not set
-# BR2_PACKAGE_LIBRTLSDR is not set
-
-#
-# libserial needs a toolchain w/ C++, threads, wchar
-#
-# BR2_PACKAGE_LIBSERIALPORT is not set
-# BR2_PACKAGE_LIBSIGROK is not set
-# BR2_PACKAGE_LIBSIGROKDECODE is not set
-# BR2_PACKAGE_LIBSOC is not set
-# BR2_PACKAGE_LIBUSB is not set
-# BR2_PACKAGE_LIBUSBGX is not set
-
-#
-# libv4l needs a toolchain w/ threads, dynamic library, C++ and headers >= 3.0
-#
-# BR2_PACKAGE_LIBXKBCOMMON is not set
-# BR2_PACKAGE_MRAA is not set
-# BR2_PACKAGE_MTDEV is not set
-# BR2_PACKAGE_NEARDAL is not set
-# BR2_PACKAGE_OWFS is not set
-# BR2_PACKAGE_PCSC_LITE is not set
-# BR2_PACKAGE_TSLIB is not set
-
-#
-# urg needs a toolchain w/ C++
-#
-# BR2_PACKAGE_WIRINGPI is not set
-
-#
-# Javascript
-#
-# BR2_PACKAGE_ANGULARJS is not set
-# BR2_PACKAGE_BOOTSTRAP is not set
-# BR2_PACKAGE_EXPLORERCANVAS is not set
-# BR2_PACKAGE_FLOT is not set
-# BR2_PACKAGE_JQUERY is not set
-# BR2_PACKAGE_JSMIN is not set
-# BR2_PACKAGE_JSON_JAVASCRIPT is not set
-
-#
-# JSON/XML
-#
-
-#
-# benejson needs a toolchain w/ C++
-#
-# BR2_PACKAGE_CJSON is not set
-# BR2_PACKAGE_EXPAT is not set
-# BR2_PACKAGE_EZXML is not set
-# BR2_PACKAGE_JANSSON is not set
-# BR2_PACKAGE_JSMN is not set
-# BR2_PACKAGE_JSON_C is not set
-# BR2_PACKAGE_JSON_GLIB is not set
-
-#
-# jsoncpp needs a toolchain w/ C++, gcc >= 4.7
-#
-# BR2_PACKAGE_LIBBSON is not set
-# BR2_PACKAGE_LIBFASTJSON is not set
-
-#
-# libjson needs a toolchain w/ C++
-#
-# BR2_PACKAGE_LIBROXML is not set
-# BR2_PACKAGE_LIBUCL is not set
-# BR2_PACKAGE_LIBXML2 is not set
-
-#
-# libxml++ needs a toolchain w/ C++, wchar, threads, gcc >= 4.8
-#
-# BR2_PACKAGE_LIBXMLRPC is not set
-# BR2_PACKAGE_LIBXSLT is not set
-# BR2_PACKAGE_LIBYAML is not set
-# BR2_PACKAGE_MXML is not set
-
-#
-# pugixml needs a toolchain w/ C++
-#
-
-#
-# rapidjson needs a toolchain w/ C++
-#
-# BR2_PACKAGE_RAPIDXML is not set
-# BR2_PACKAGE_RAPTOR is not set
-
-#
-# tinyxml needs a toolchain w/ C++
-#
-
-#
-# tinyxml2 needs a toolchain w/ C++
-#
-
-#
-# valijson needs a toolchain w/ C++, threads, wchar  support
-#
-
-#
-# xerces-c++ needs a toolchain w/ C++, wchar
-#
-# BR2_PACKAGE_YAJL is not set
-
-#
-# yaml-cpp needs a toolchain w/ C++, threads, wchar
-#
-
-#
-# Logging
-#
-# BR2_PACKAGE_EVENTLOG is not set
-
-#
-# glog needs a toolchain w/ C++, threads, dynamic library
-#
-# BR2_PACKAGE_LIBLOG4C_LOCALTIME is not set
-# BR2_PACKAGE_LIBLOGGING is not set
-
-#
-# log4cplus needs a toolchain w/ C++, wchar, threads
-#
-
-#
-# log4cpp needs a toolchain w/ C++, threads
-#
-
-#
-# log4cxx needs a toolchain w/ C++, threads, dynamic library
-#
-# BR2_PACKAGE_ZLOG is not set
-
-#
-# Multimedia
-#
-# BR2_PACKAGE_BITSTREAM is not set
-# BR2_PACKAGE_LIBAACS is not set
-# BR2_PACKAGE_LIBASS is not set
-# BR2_PACKAGE_LIBBDPLUS is not set
-# BR2_PACKAGE_LIBBLURAY is not set
-# BR2_PACKAGE_LIBDCADEC is not set
-# BR2_PACKAGE_LIBDVBCSA is not set
-# BR2_PACKAGE_LIBDVBPSI is not set
-
-#
-# libdvbsi++ needs a toolchain w/ C++, wchar, threads
-#
-# BR2_PACKAGE_LIBDVDCSS is not set
-# BR2_PACKAGE_LIBDVDNAV is not set
-# BR2_PACKAGE_LIBDVDREAD is not set
-
-#
-# libebml needs a toolchain w/ C++, wchar
-#
-# BR2_PACKAGE_LIBHDHOMERUN is not set
-
-#
-# libmatroska needs a toolchain w/ C++, wchar
-#
-# BR2_PACKAGE_LIBMMS is not set
-# BR2_PACKAGE_LIBMPEG2 is not set
-# BR2_PACKAGE_LIBOGG is not set
-BR2_PACKAGE_LIBOPENH264_ARCH_SUPPORTS=y
-
-#
-# libopenh264 needs a toolchain w/ C++, dynamic library, threads
-#
-# BR2_PACKAGE_LIBPLAYER is not set
-# BR2_PACKAGE_LIBTHEORA is not set
-# BR2_PACKAGE_LIBVPX is not set
-
-#
-# libyuv needs a toolchain w/ C++, dynamic library
-#
-
-#
-# live555 needs a toolchain w/ C++
-#
-
-#
-# mediastreamer needs a toolchain w/ threads, C++
-#
-# BR2_PACKAGE_X264 is not set
-
-#
-# x265 needs a toolchain w/ C++, threads, dynamic library
-#
-
-#
-# Networking
-#
-
-#
-# agent++ needs a toolchain w/ threads, C++, dynamic library
-#
-
-#
-# alljoyn needs a toolchain w/ C++, threads, wchar and dynamic library
-#
-
-#
-# alljoyn-base needs a toolchain w/ C++, threads, wchar, dynamic library
-#
-# BR2_PACKAGE_ALLJOYN_TCL is not set
-# BR2_PACKAGE_ALLJOYN_TCL_BASE is not set
-# BR2_PACKAGE_BATMAN_ADV is not set
-# BR2_PACKAGE_C_ARES is not set
-BR2_PACKAGE_CANFESTIVAL_ARCH_SUPPORTS=y
-# BR2_PACKAGE_CANFESTIVAL is not set
-# BR2_PACKAGE_CGIC is not set
-
-#
-# cppzmq needs a toolchain w/ C++, threads
-#
-
-#
-# czmq needs a toolchain w/ C++, threads
-#
-BR2_PACKAGE_DPDK=y
-BR2_PACKAGE_DPDK_CONFIG="x86_64-native-linuxapp-gcc"
-# BR2_PACKAGE_DPDK_TEST is not set
-BR2_PACKAGE_DPDK_EXAMPLES=y
-
-#
-# filemq needs a toolchain w/ C++, threads
-#
-# BR2_PACKAGE_FLICKCURL is not set
-# BR2_PACKAGE_FREERADIUS_CLIENT is not set
-# BR2_PACKAGE_GEOIP is not set
-# BR2_PACKAGE_GLIB_NETWORKING is not set
-# BR2_PACKAGE_GSSDP is not set
-# BR2_PACKAGE_GUPNP is not set
-# BR2_PACKAGE_GUPNP_AV is not set
-# BR2_PACKAGE_GUPNP_DLNA is not set
-
-#
-# ibrcommon needs a toolchain w/ C++, threads
-#
-
-#
-# ibrdtn needs a toolchain w/ C++, threads
-#
-# BR2_PACKAGE_LIBCGI is not set
-
-#
-# libcgicc needs a toolchain w/ C++
-#
-# BR2_PACKAGE_LIBCOAP is not set
-# BR2_PACKAGE_LIBCURL is not set
-# BR2_PACKAGE_LIBDNET is not set
-# BR2_PACKAGE_LIBEXOSIP2 is not set
-# BR2_PACKAGE_LIBFCGI is not set
-# BR2_PACKAGE_LIBGSASL is not set
-# BR2_PACKAGE_LIBHTTPPARSER is not set
-# BR2_PACKAGE_LIBIDN is not set
-# BR2_PACKAGE_LIBISCSI is not set
-# BR2_PACKAGE_LIBLDNS is not set
-# BR2_PACKAGE_LIBMAXMINDDB is not set
-# BR2_PACKAGE_LIBMBUS is not set
-
-#
-# libmemcached needs a toolchain w/ C++, threads
-#
-# BR2_PACKAGE_LIBMICROHTTPD is not set
-# BR2_PACKAGE_LIBMINIUPNPC is not set
-# BR2_PACKAGE_LIBMNL is not set
-# BR2_PACKAGE_LIBMODBUS is not set
-# BR2_PACKAGE_LIBNATPMP is not set
-# BR2_PACKAGE_LIBNDP is not set
-# BR2_PACKAGE_LIBNET is not set
-# BR2_PACKAGE_LIBNETFILTER_ACCT is not set
-# BR2_PACKAGE_LIBNETFILTER_CONNTRACK is not set
-# BR2_PACKAGE_LIBNETFILTER_CTHELPER is not set
-# BR2_PACKAGE_LIBNETFILTER_CTTIMEOUT is not set
-# BR2_PACKAGE_LIBNETFILTER_LOG is not set
-# BR2_PACKAGE_LIBNETFILTER_QUEUE is not set
-# BR2_PACKAGE_LIBNFNETLINK is not set
-# BR2_PACKAGE_LIBNFTNL is not set
-# BR2_PACKAGE_LIBNICE is not set
-# BR2_PACKAGE_LIBNL is not set
-# BR2_PACKAGE_LIBOAUTH is not set
-# BR2_PACKAGE_LIBOPING is not set
-# BR2_PACKAGE_LIBOSIP2 is not set
-# BR2_PACKAGE_LIBPCAP is not set
-
-#
-# libpjsip needs a toolchain w/ C++, threads
-#
-# BR2_PACKAGE_LIBRSYNC is not set
-# BR2_PACKAGE_LIBSHAIRPLAY is not set
-# BR2_PACKAGE_LIBSHOUT is not set
-# BR2_PACKAGE_LIBSOCKETCAN is not set
-# BR2_PACKAGE_LIBSOUP is not set
-# BR2_PACKAGE_LIBSRTP is not set
-# BR2_PACKAGE_LIBSTROPHE is not set
-# BR2_PACKAGE_LIBTIRPC is not set
-
-#
-# libtorrent needs a toolchain w/ C++, threads
-#
-# BR2_PACKAGE_LIBUPNP is not set
-
-#
-# libupnpp needs a toolchain w/ C++, threads, gcc >= 4.6
-#
-# BR2_PACKAGE_LIBURIPARSER is not set
-# BR2_PACKAGE_LIBVNCSERVER is not set
-# BR2_PACKAGE_LIBWEBSOCK is not set
-# BR2_PACKAGE_LIBWEBSOCKETS is not set
-# BR2_PACKAGE_LKSCTP_TOOLS is not set
-# BR2_PACKAGE_MONGOOSE is not set
-# BR2_PACKAGE_NANOMSG is not set
-# BR2_PACKAGE_NEON is not set
-
-#
-# norm needs a toolchain w/ C++, threads, dynamic library
-#
-# BR2_PACKAGE_NSS_PAM_LDAPD is not set
-
-#
-# omniORB needs a toolchain w/ C++, threads
-#
-# BR2_PACKAGE_OPENLDAP is not set
-
-#
-# openmpi needs a toolchain w/ dynamic library, NPTL, wchar, C++
-#
-# BR2_PACKAGE_OPENPGM is not set
-
-#
-# openzwave needs udev and a toolchain w/ C++, threads, wchar
-#
-
-#
-# ortp needs a toolchain w/ C++, threads
-#
-# BR2_PACKAGE_PAHO_MQTT_C is not set
-# BR2_PACKAGE_QDECODER is not set
-# BR2_PACKAGE_QPID_PROTON is not set
-# BR2_PACKAGE_RABBITMQ_C is not set
-# BR2_PACKAGE_RTMPDUMP is not set
-# BR2_PACKAGE_SLIRP is not set
-
-#
-# snmp++ needs a toolchain w/ threads, C++, dynamic library
-#
-# BR2_PACKAGE_SOFIA_SIP is not set
-
-#
-# thrift needs a toolchain w/ C++, wchar, threads
-#
-# BR2_PACKAGE_USBREDIR is not set
-
-#
-# zeromq needs a toolchain w/ C++, threads
-#
-
-#
-# zmqpp needs a toolchain w/ C++, threads, gcc >= 4.7
-#
-
-#
-# zyre needs a toolchain w/ C++, threads
-#
-
-#
-# Other
-#
-# BR2_PACKAGE_APR is not set
-# BR2_PACKAGE_APR_UTIL is not set
-
-#
-# armadillo needs a toolchain w/ C++
-#
-
-#
-# atf needs a toolchain w/ C++
-#
-
-#
-# bctoolbox needs a toolchain w/ C++, threads
-#
-# BR2_PACKAGE_BDWGC is not set
-
-#
-# boost needs a toolchain w/ C++, threads, wchar
-#
-# BR2_PACKAGE_CLAPACK is not set
-BR2_PACKAGE_CLASSPATH_ARCH_SUPPORTS=y
-# BR2_PACKAGE_CLASSPATH is not set
-
-#
-# cppcms needs a toolchain w/ C++, NPTL, wchar, dynamic library
-#
-
-#
-# dawgdic needs a toolchain w/ C++, gcc >= 4.6
-#
-# BR2_PACKAGE_DING_LIBS is not set
-
-#
-# eigen needs a toolchain w/ C++
-#
-# BR2_PACKAGE_ELFUTILS is not set
-# BR2_PACKAGE_FFTW is not set
-
-#
-# flann needs a toolchain w/ C++, dynamic library
-#
-
-#
-# gflags needs a toolchain w/ C++
-#
-
-#
-# glibmm needs a toolchain w/ C++, wchar, threads, gcc >= 4.8
-#
-
-#
-# glm needs a toolchain w/ C++
-#
-# BR2_PACKAGE_GMP is not set
-# BR2_PACKAGE_GSL is not set
-
-#
-# gtest needs a toolchain w/ C++, wchar, threads
-#
-BR2_PACKAGE_JEMALLOC_ARCH_SUPPORTS=y
-# BR2_PACKAGE_JEMALLOC is not set
-
-#
-# lapack/blas needs a toolchain w/ fortran
-#
-# BR2_PACKAGE_LIBARGTABLE2 is not set
-BR2_PACKAGE_LIBATOMIC_OPS_ARCH_SUPPORTS=y
-# BR2_PACKAGE_LIBATOMIC_OPS is not set
-BR2_PACKAGE_LIBBSD_ARCH_SUPPORTS=y
-# BR2_PACKAGE_LIBBSD is not set
-# BR2_PACKAGE_LIBCAP is not set
-# BR2_PACKAGE_LIBCAP_NG is not set
-
-#
-# libcgroup needs a glibc toolchain w/ C++
-#
-# BR2_PACKAGE_LIBCROCO is not set
-
-#
-# libcrossguid needs a toolchain w/ C++, gcc >= 4.7
-#
-# BR2_PACKAGE_LIBCSV is not set
-# BR2_PACKAGE_LIBDAEMON is not set
-# BR2_PACKAGE_LIBEE is not set
-# BR2_PACKAGE_LIBEV is not set
-# BR2_PACKAGE_LIBEVDEV is not set
-# BR2_PACKAGE_LIBEVENT is not set
-BR2_PACKAGE_LIBFFI=y
-# BR2_PACKAGE_LIBGEE is not set
-BR2_PACKAGE_LIBGLIB2=y
-# BR2_PACKAGE_LIBGLOB is not set
-
-#
-# libical needs a toolchain w/ C++, dynamic library, wchar
-#
-# BR2_PACKAGE_LIBITE is not set
-
-#
-# liblinear needs a toolchain w/ C++
-#
-# BR2_PACKAGE_LIBNPTH is not set
-BR2_PACKAGE_LIBNSPR_ARCH_SUPPORT=y
-# BR2_PACKAGE_LIBNSPR is not set
-# BR2_PACKAGE_LIBPFM4 is not set
-
-#
-# libplist needs a toolchain w/ C++
-#
-# BR2_PACKAGE_LIBPTHREAD_STUBS is not set
-# BR2_PACKAGE_LIBPTHSEM is not set
-BR2_PACKAGE_LIBSECCOMP_ARCH_SUPPORTS=y
-# BR2_PACKAGE_LIBSECCOMP is not set
-
-#
-# libsigc++ needs a toolchain w/ C++, gcc >= 4.8
-#
-BR2_PACKAGE_LIBSIGSEGV_ARCH_SUPPORTS=y
-# BR2_PACKAGE_LIBSIGSEGV is not set
-# BR2_PACKAGE_LIBTASN1 is not set
-# BR2_PACKAGE_LIBTOMMATH is not set
-# BR2_PACKAGE_LIBTPL is not set
-# BR2_PACKAGE_LIBUBOX is not set
-# BR2_PACKAGE_LIBUCI is not set
-BR2_PACKAGE_LIBUNWIND_ARCH_SUPPORTS=y
-# BR2_PACKAGE_LIBUNWIND is not set
-BR2_PACKAGE_LIBURCU_ARCH_SUPPORTS=y
-# BR2_PACKAGE_LIBURCU is not set
-# BR2_PACKAGE_LIBUV is not set
-# BR2_PACKAGE_LIGHTNING is not set
-# BR2_PACKAGE_LINUX_PAM is not set
-# BR2_PACKAGE_LIQUID_DSP is not set
-# BR2_PACKAGE_LTTNG_LIBUST is not set
-# BR2_PACKAGE_MPC is not set
-# BR2_PACKAGE_MPDECIMAL is not set
-# BR2_PACKAGE_MPFR is not set
-# BR2_PACKAGE_MPIR is not set
-
-#
-# msgpack needs a toolchain w/ C++
-#
-# BR2_PACKAGE_MTDEV2TUIO is not set
-BR2_PACKAGE_OPENBLAS_DEFAULT_TARGET="NEHALEM"
-BR2_PACKAGE_OPENBLAS_ARCH_SUPPORTS=y
-# BR2_PACKAGE_OPENBLAS is not set
-# BR2_PACKAGE_ORC is not set
-# BR2_PACKAGE_P11_KIT is not set
-
-#
-# poco needs a toolchain w/ wchar, threads, C++, dynamic library
-#
-BR2_PACKAGE_PROTOBUF_ARCH_SUPPORTS=y
-
-#
-# protobuf needs a toolchain w/ C++, threads, dynamic library, host and target gcc >= 4.5
-#
-
-#
-# protobuf-c needs a toolchain w/ C++, threads, host gcc >= 4.5
-#
-
-#
-# qhull needs a toolchain w/ C++, dynamic library, gcc >= 4.4
-#
-# BR2_PACKAGE_QLIBC is not set
-
-#
-# riemann-c-client needs a toolchain w/ C++, threads, host gcc >= 4.5
-#
-# BR2_PACKAGE_SHAPELIB is not set
-# BR2_PACKAGE_SKALIBS is not set
-# BR2_PACKAGE_SPHINXBASE is not set
-# BR2_PACKAGE_TINYCBOR is not set
-
-#
-# Security
-#
-# BR2_PACKAGE_LIBSELINUX is not set
-# BR2_PACKAGE_LIBSEMANAGE is not set
-# BR2_PACKAGE_LIBSEPOL is not set
-
-#
-# Text and terminal handling
-#
-# BR2_PACKAGE_AUGEAS is not set
-
-#
-# enchant needs a toolchain w/ C++, threads, wchar
-#
-
-#
-# fmt needs a toolchain w/ C++, wchar
-#
-
-#
-# icu needs a toolchain w/ C++, wchar, threads
-#
-# BR2_PACKAGE_LIBCLI is not set
-# BR2_PACKAGE_LIBEDIT is not set
-# BR2_PACKAGE_LIBENCA is not set
-# BR2_PACKAGE_LIBESTR is not set
-# BR2_PACKAGE_LIBFRIBIDI is not set
-# BR2_PACKAGE_LIBUNISTRING is not set
-# BR2_PACKAGE_LINENOISE is not set
-BR2_PACKAGE_NCURSES=y
-BR2_PACKAGE_NCURSES_WCHAR=y
-BR2_PACKAGE_NCURSES_TARGET_PROGS=y
-# BR2_PACKAGE_NEWT is not set
-BR2_PACKAGE_PCRE=y
-# BR2_PACKAGE_PCRE_16 is not set
-# BR2_PACKAGE_PCRE_32 is not set
-BR2_PACKAGE_PCRE_UTF=y
-BR2_PACKAGE_PCRE_UCP=y
-# BR2_PACKAGE_POPT is not set
-# BR2_PACKAGE_READLINE is not set
-# BR2_PACKAGE_SLANG is not set
-
-#
-# tclap needs a toolchain w/ C++
-#
-# BR2_PACKAGE_USTR is not set
-
-#
-# Mail
-#
-# BR2_PACKAGE_DOVECOT is not set
-# BR2_PACKAGE_EXIM is not set
-# BR2_PACKAGE_FETCHMAIL is not set
-# BR2_PACKAGE_HEIRLOOM_MAILX is not set
-# BR2_PACKAGE_LIBESMTP is not set
-# BR2_PACKAGE_MSMTP is not set
-# BR2_PACKAGE_MUTT is not set
-
-#
-# Miscellaneous
-#
-# BR2_PACKAGE_AESPIPE is not set
-# BR2_PACKAGE_BC is not set
-# BR2_PACKAGE_CLAMAV is not set
-# BR2_PACKAGE_COLLECTD is not set
-
-#
-# domoticz needs lua >= 5.2 and a toolchain w/ C++, threads, wchar, dynamic library
-#
-# BR2_PACKAGE_EMPTY is not set
-
-#
-# gnuradio needs a toolchain w/ C++, NPTL, wchar, dynamic library
-#
-# BR2_PACKAGE_GOOGLEFONTDIRECTORY is not set
-
-#
-# gqrx needs a toolchain w/ C++, threads, wchar
-#
-
-#
-# gqrx needs qt5, gnuradio, fftw's single precision
-#
-# BR2_PACKAGE_GSETTINGS_DESKTOP_SCHEMAS is not set
-# BR2_PACKAGE_HAVEGED is not set
-# BR2_PACKAGE_LINUX_SYSCALL_SUPPORT is not set
-# BR2_PACKAGE_MCRYPT is not set
-# BR2_PACKAGE_MOBILE_BROADBAND_PROVIDER_INFO is not set
-BR2_PACKAGE_QEMU_ARCH_SUPPORTS_TARGET=y
-BR2_PACKAGE_QEMU=y
-
-#
-# Emulators selection
-#
-BR2_PACKAGE_QEMU_CUSTOM_TARGETS="x86_64-softmmu"
-BR2_PACKAGE_QEMU_HAS_EMULS=y
-
-#
-# Frontends
-#
-# BR2_PACKAGE_QEMU_SDL is not set
-
-#
-# Misc. features
-#
-# BR2_PACKAGE_QEMU_FDT is not set
-# BR2_PACKAGE_QEMU_TOOLS is not set
-
-#
-# qpdf needs a toolchain w/ C++
-#
-# BR2_PACKAGE_SHARED_MIME_INFO is not set
-
-#
-# taskd needs a toolchain w/ C++, wchar, dynamic library
-#
-# BR2_PACKAGE_XUTIL_UTIL_MACROS is not set
-
-#
-# Networking applications
-#
-# BR2_PACKAGE_AICCU is not set
-
-#
-# aircrack-ng needs a toolchain w/ threads, C++
-#
-# BR2_PACKAGE_APACHE is not set
-# BR2_PACKAGE_ARGUS is not set
-# BR2_PACKAGE_ARP_SCAN is not set
-# BR2_PACKAGE_ARPTABLES is not set
-# BR2_PACKAGE_ATFTP is not set
-# BR2_PACKAGE_AUTOSSH is not set
-# BR2_PACKAGE_AVAHI is not set
-# BR2_PACKAGE_AXEL is not set
-# BR2_PACKAGE_BABELD is not set
-# BR2_PACKAGE_BANDWIDTHD is not set
-# BR2_PACKAGE_BATCTL is not set
-
-#
-# bcusdk needs a toolchain w/ C++
-#
-# BR2_PACKAGE_BIND is not set
-# BR2_PACKAGE_BLUEZ_UTILS is not set
-# BR2_PACKAGE_BLUEZ5_UTILS is not set
-# BR2_PACKAGE_BMON is not set
-# BR2_PACKAGE_BOA is not set
-BR2_PACKAGE_BRIDGE_UTILS=y
-# BR2_PACKAGE_BWM_NG is not set
-# BR2_PACKAGE_C_ICAP is not set
-# BR2_PACKAGE_CAN_UTILS is not set
-
-#
-# cannelloni needs a toolchain w/ C++, threads, dynamic library, gcc >= 4.8
-#
-# BR2_PACKAGE_CHRONY is not set
-# BR2_PACKAGE_CIVETWEB is not set
-# BR2_PACKAGE_CONNMAN is not set
-
-#
-# connman-gtk needs libgtk3 and a glibc or uClibc toolchain w/ wchar, threads, resolver, dynamic library
-#
-# BR2_PACKAGE_CONNTRACK_TOOLS is not set
-# BR2_PACKAGE_CRDA is not set
-
-#
-# ctorrent needs a toolchain w/ C++
-#
-
-#
-# cups needs a toolchain w/ C++
-#
-# BR2_PACKAGE_DANTE is not set
-# BR2_PACKAGE_DARKHTTPD is not set
-# BR2_PACKAGE_DHCPCD is not set
-# BR2_PACKAGE_DHCPDUMP is not set
-# BR2_PACKAGE_DNSMASQ is not set
-# BR2_PACKAGE_DRBD_UTILS is not set
-# BR2_PACKAGE_DROPBEAR is not set
-# BR2_PACKAGE_EBTABLES is not set
-
-#
-# ebtables needs a glibc or uClibc toolchain
-#
-
-#
-# ejabberd needs erlang, toolchain w/ C++
-#
-# BR2_PACKAGE_ETHTOOL is not set
-# BR2_PACKAGE_FAIFA is not set
-# BR2_PACKAGE_FASTD is not set
-# BR2_PACKAGE_FCGIWRAP is not set
-# BR2_PACKAGE_FLANNEL is not set
-# BR2_PACKAGE_FPING is not set
-
-#
-# freeswitch needs a toolchain w/ C++, dynamic library, threads, wchar
-#
-# BR2_PACKAGE_GESFTPSERVER is not set
-
-#
-# gupnp-tools needs libgtk3
-#
-
-#
-# hans needs a toolchain w/ C++
-#
-# BR2_PACKAGE_HIAWATHA is not set
-# BR2_PACKAGE_HOSTAPD is not set
-# BR2_PACKAGE_HTTPING is not set
-
-#
-# ibrdtn-tools needs a toolchain w/ C++, threads
-#
-
-#
-# ibrdtnd needs a toolchain w/ C++, threads
-#
-# BR2_PACKAGE_IFTOP is not set
-# BR2_PACKAGE_IGD2_FOR_LINUX is not set
-# BR2_PACKAGE_IGH_ETHERCAT is not set
-# BR2_PACKAGE_IGMPPROXY is not set
-# BR2_PACKAGE_INADYN is not set
-# BR2_PACKAGE_IODINE is not set
-
-#
-# iperf needs a toolchain w/ C++
-#
-# BR2_PACKAGE_IPERF3 is not set
-BR2_PACKAGE_IPROUTE2=y
-# BR2_PACKAGE_IPSEC_TOOLS is not set
-# BR2_PACKAGE_IPSET is not set
-# BR2_PACKAGE_IPTABLES is not set
-# BR2_PACKAGE_IPTRAF_NG is not set
-# BR2_PACKAGE_IPUTILS is not set
-# BR2_PACKAGE_IRSSI is not set
-# BR2_PACKAGE_IW is not set
-# BR2_PACKAGE_JANUS_GATEWAY is not set
-# BR2_PACKAGE_KEEPALIVED is not set
-
-#
-# kismet needs a toolchain w/ threads, C++, dynamic library
-#
-# BR2_PACKAGE_KNOCK is not set
-# BR2_PACKAGE_LEAFNODE2 is not set
-# BR2_PACKAGE_LFT is not set
-
-#
-# lftp requires a toolchain w/ C++, wchar
-#
-# BR2_PACKAGE_LIGHTTPD is not set
-
-#
-# linknx needs a toolchain w/ C++
-#
-# BR2_PACKAGE_LINKS is not set
-
-#
-# linphone needs a toolchain w/ threads, C++
-#
-# BR2_PACKAGE_LINUX_ZIGBEE is not set
-# BR2_PACKAGE_LLDPD is not set
-# BR2_PACKAGE_LRZSZ is not set
-# BR2_PACKAGE_MACCHANGER is not set
-# BR2_PACKAGE_MEMCACHED is not set
-# BR2_PACKAGE_MII_DIAG is not set
-# BR2_PACKAGE_MINIDLNA is not set
-# BR2_PACKAGE_MINISSDPD is not set
-# BR2_PACKAGE_MJPG_STREAMER is not set
-
-#
-# modemmanager needs udev /dev management and a toolchain w/ wchar, threads
-#
-BR2_PACKAGE_MONGREL2_LIBC_SUPPORTS=y
-
-#
-# mongrel2 needs a uClibc or glibc toolchain w/ C++, threads, dynamic library
-#
-# BR2_PACKAGE_MONKEY is not set
-
-#
-# mosh needs a toolchain w/ C++, threads, dynamic library, wchar, host and target gcc >= 4.5
-#
-# BR2_PACKAGE_MOSQUITTO is not set
-# BR2_PACKAGE_MROUTED is not set
-# BR2_PACKAGE_MTR is not set
-# BR2_PACKAGE_NBD is not set
-# BR2_PACKAGE_NCFTP is not set
-# BR2_PACKAGE_NDISC6 is not set
-# BR2_PACKAGE_NETATALK is not set
-# BR2_PACKAGE_NETPLUG is not set
-# BR2_PACKAGE_NETSNMP is not set
-# BR2_PACKAGE_NETSTAT_NAT is not set
-
-#
-# NetworkManager needs udev /dev management and a glibc toolchain w/ headers >= 3.7, dynamic library
-#
-# BR2_PACKAGE_NFACCT is not set
-# BR2_PACKAGE_NFTABLES is not set
-# BR2_PACKAGE_NGINX is not set
-# BR2_PACKAGE_NGIRCD is not set
-# BR2_PACKAGE_NGREP is not set
-
-#
-# nload needs a toolchain w/ C++
-#
-
-#
-# nmap needs a toolchain w/ C++, threads
-#
-# BR2_PACKAGE_NOIP is not set
-# BR2_PACKAGE_NTP is not set
-# BR2_PACKAGE_NUTTCP is not set
-# BR2_PACKAGE_ODHCP6C is not set
-# BR2_PACKAGE_ODHCPLOC is not set
-# BR2_PACKAGE_OLSR is not set
-# BR2_PACKAGE_OPEN_PLC_UTILS is not set
-# BR2_PACKAGE_OPENNTPD is not set
-# BR2_PACKAGE_OPENOBEX is not set
-BR2_PACKAGE_OPENSSH=y
-# BR2_PACKAGE_OPENSWAN is not set
-# BR2_PACKAGE_OPENVPN is not set
-# BR2_PACKAGE_P910ND is not set
-# BR2_PACKAGE_PHIDGETWEBSERVICE is not set
-# BR2_PACKAGE_PHYTOOL is not set
-# BR2_PACKAGE_POUND is not set
-# BR2_PACKAGE_PPPD is not set
-# BR2_PACKAGE_PPTP_LINUX is not set
-# BR2_PACKAGE_PRIVOXY is not set
-# BR2_PACKAGE_PROFTPD is not set
-# BR2_PACKAGE_PROXYCHAINS_NG is not set
-# BR2_PACKAGE_PTPD is not set
-# BR2_PACKAGE_PTPD2 is not set
-# BR2_PACKAGE_PURE_FTPD is not set
-# BR2_PACKAGE_PUTTY is not set
-# BR2_PACKAGE_QUAGGA is not set
-
-#
-# rabbitmq-server needs erlang
-#
-# BR2_PACKAGE_RADVD is not set
-# BR2_PACKAGE_RP_PPPOE is not set
-# BR2_PACKAGE_RPCBIND is not set
-# BR2_PACKAGE_RSH_REDONE is not set
-# BR2_PACKAGE_RSYNC is not set
-
-#
-# rtorrent needs a toolchain w/ C++, threads, wchar
-#
-# BR2_PACKAGE_RTPTOOLS is not set
-# BR2_PACKAGE_S6_DNS is not set
-# BR2_PACKAGE_S6_NETWORKING is not set
-# BR2_PACKAGE_SAMBA4 is not set
-
-#
-# sconeserver needs a toolchain with dynamic library, C++, NPTL
-#
-# BR2_PACKAGE_SER2NET is not set
-
-#
-# shairport-sync needs a toolchain w/ C++, NPTL
-#
-# BR2_PACKAGE_SHELLINABOX is not set
-# BR2_PACKAGE_SMCROUTE is not set
-# BR2_PACKAGE_SNGREP is not set
-# BR2_PACKAGE_SOCAT is not set
-# BR2_PACKAGE_SOCKETCAND is not set
-# BR2_PACKAGE_SOFTETHER is not set
-# BR2_PACKAGE_SPAWN_FCGI is not set
-# BR2_PACKAGE_SPICE is not set
-# BR2_PACKAGE_SPICE_PROTOCOL is not set
-
-#
-# squid needs a toolchain w/ C++
-#
-# BR2_PACKAGE_SSHPASS is not set
-
-#
-# sslh needs a toolchain w/ C++
-#
-# BR2_PACKAGE_STRONGSWAN is not set
-# BR2_PACKAGE_STUNNEL is not set
-# BR2_PACKAGE_TCPDUMP is not set
-# BR2_PACKAGE_TCPING is not set
-# BR2_PACKAGE_TCPREPLAY is not set
-# BR2_PACKAGE_THTTPD is not set
-# BR2_PACKAGE_TINC is not set
-# BR2_PACKAGE_TINYHTTPD is not set
-# BR2_PACKAGE_TN5250 is not set
-# BR2_PACKAGE_TOR is not set
-# BR2_PACKAGE_TRANSMISSION is not set
-# BR2_PACKAGE_TUNCTL is not set
-# BR2_PACKAGE_TVHEADEND is not set
-# BR2_PACKAGE_UDPCAST is not set
-# BR2_PACKAGE_UHTTPD is not set
-# BR2_PACKAGE_ULOGD is not set
-# BR2_PACKAGE_USHARE is not set
-# BR2_PACKAGE_USSP_PUSH is not set
-# BR2_PACKAGE_VDE2 is not set
-
-#
-# vdr needs a glibc or uClibc toolchain w/ C++, dynamic library, NPTL, wchar
-#
-# BR2_PACKAGE_VNSTAT is not set
-# BR2_PACKAGE_VPNC is not set
-# BR2_PACKAGE_VSFTPD is not set
-# BR2_PACKAGE_VTUN is not set
-# BR2_PACKAGE_WAVEMON is not set
-# BR2_PACKAGE_WIRELESS_REGDB is not set
-# BR2_PACKAGE_WIRELESS_TOOLS is not set
-# BR2_PACKAGE_WIRESHARK is not set
-# BR2_PACKAGE_WPA_SUPPLICANT is not set
-# BR2_PACKAGE_WPAN_TOOLS is not set
-# BR2_PACKAGE_XINETD is not set
-# BR2_PACKAGE_XL2TP is not set
-# BR2_PACKAGE_XTABLES_ADDONS is not set
-
-#
-# znc needs a toolchain w/ C++, dynamic library, gcc >= 4.7
-#
-
-#
-# Package managers
-#
-
-#
-# -------------------------------------------------------
-#
-
-#
-# Please note:
-#
-
-#
-# - Buildroot does *not* generate binary packages,
-#
-
-#
-# - Buildroot does *not* install any package database.
-#
-
-#
-# *
-#
-
-#
-# It is up to you to provide those by yourself if you
-#
-
-#
-# want to use any of those package managers.
-#
-
-#
-# *
-#
-
-#
-# See the manual:
-#
-
-#
-# http://buildroot.org/manual.html#faq-no-binary-packages
-#
-
-#
-# -------------------------------------------------------
-#
-# BR2_PACKAGE_OPKG is not set
-
-#
-# Real-Time
-#
-BR2_PACKAGE_XENOMAI_ARCH_SUPPORTS=y
-# BR2_PACKAGE_XENOMAI is not set
-
-#
-# Security
-#
-# BR2_PACKAGE_CHECKPOLICY is not set
-# BR2_PACKAGE_POLICYCOREUTILS is not set
-# BR2_PACKAGE_SEPOLGEN is not set
-
-#
-# setools needs a glibc toolchain w/ threads, C++, wchar, dynamic library
-#
-
-#
-# Shell and utilities
-#
-
-#
-# Shells
-#
-# BR2_PACKAGE_MKSH is not set
-
-#
-# Utilities
-#
-# BR2_PACKAGE_AT is not set
-# BR2_PACKAGE_CCRYPT is not set
-# BR2_PACKAGE_DIALOG is not set
-# BR2_PACKAGE_DTACH is not set
-# BR2_PACKAGE_FILE is not set
-# BR2_PACKAGE_GNUPG is not set
-# BR2_PACKAGE_GNUPG2 is not set
-# BR2_PACKAGE_INOTIFY_TOOLS is not set
-# BR2_PACKAGE_LOCKFILE_PROGS is not set
-# BR2_PACKAGE_LOGROTATE is not set
-# BR2_PACKAGE_LOGSURFER is not set
-# BR2_PACKAGE_PINENTRY is not set
-# BR2_PACKAGE_RANGER is not set
-BR2_PACKAGE_SCREEN=y
-BR2_PACKAGE_SUDO=y
-# BR2_PACKAGE_TMUX is not set
-# BR2_PACKAGE_XMLSTARLET is not set
-# BR2_PACKAGE_XXHASH is not set
-
-#
-# System tools
-#
-# BR2_PACKAGE_ACL is not set
-# BR2_PACKAGE_ANDROID_TOOLS is not set
-# BR2_PACKAGE_ATOP is not set
-# BR2_PACKAGE_ATTR is not set
-BR2_PACKAGE_AUDIT_ARCH_SUPPORTS=y
-# BR2_PACKAGE_AUDIT is not set
-# BR2_PACKAGE_CGROUPFS_MOUNT is not set
-
-#
-# circus needs Python and a toolchain w/ C++, threads
-#
-# BR2_PACKAGE_CPULOAD is not set
-# BR2_PACKAGE_DAEMON is not set
-# BR2_PACKAGE_DC3DD is not set
-
-#
-# ddrescue needs a toolchain w/ C++
-#
-# BR2_PACKAGE_DOCKER_CONTAINERD is not set
-# BR2_PACKAGE_DOCKER_ENGINE is not set
-# BR2_PACKAGE_EFIBOOTMGR is not set
-BR2_PACKAGE_EFIVAR_ARCH_SUPPORTS=y
-# BR2_PACKAGE_EFIVAR is not set
-# BR2_PACKAGE_EMLOG is not set
-# BR2_PACKAGE_FTOP is not set
-# BR2_PACKAGE_GETENT is not set
-BR2_PACKAGE_HTOP=y
-BR2_PACKAGE_INITSCRIPTS=y
-
-#
-# iotop depends on python or python3
-#
-# BR2_PACKAGE_IPRUTILS is not set
-# BR2_PACKAGE_IRQBALANCE is not set
-# BR2_PACKAGE_KEYUTILS is not set
-# BR2_PACKAGE_KMOD is not set
-# BR2_PACKAGE_KVMTOOL is not set
-# BR2_PACKAGE_LXC is not set
-# BR2_PACKAGE_MONIT is not set
-# BR2_PACKAGE_NCDU is not set
-BR2_PACKAGE_NUMACTL=y
-
-#
-# nut needs a toolchain w/ C++
-#
-# BR2_PACKAGE_OPENVMTOOLS is not set
-# BR2_PACKAGE_POLKIT is not set
-# BR2_PACKAGE_PROCRANK_LINUX is not set
-# BR2_PACKAGE_PWGEN is not set
-# BR2_PACKAGE_QUOTA is not set
-# BR2_PACKAGE_RUNC is not set
-# BR2_PACKAGE_S6 is not set
-# BR2_PACKAGE_S6_LINUX_INIT is not set
-# BR2_PACKAGE_S6_LINUX_UTILS is not set
-# BR2_PACKAGE_S6_PORTABLE_UTILS is not set
-# BR2_PACKAGE_S6_RC is not set
-# BR2_PACKAGE_SCRUB is not set
-# BR2_PACKAGE_SCRYPT is not set
-# BR2_PACKAGE_SMACK is not set
-
-#
-# supervisor needs the python interpreter
-#
-# BR2_PACKAGE_SWUPDATE is not set
-BR2_PACKAGE_SYSTEMD_ARCH_SUPPORTS=y
-# BR2_PACKAGE_TPM_TOOLS is not set
-# BR2_PACKAGE_UNSCD is not set
-BR2_PACKAGE_UTIL_LINUX=y
-BR2_PACKAGE_UTIL_LINUX_LIBBLKID=y
-# BR2_PACKAGE_UTIL_LINUX_LIBFDISK is not set
-BR2_PACKAGE_UTIL_LINUX_LIBMOUNT=y
-# BR2_PACKAGE_UTIL_LINUX_LIBSMARTCOLS is not set
-BR2_PACKAGE_UTIL_LINUX_LIBUUID=y
-# BR2_PACKAGE_UTIL_LINUX_BINARIES is not set
-# BR2_PACKAGE_UTIL_LINUX_AGETTY is not set
-# BR2_PACKAGE_UTIL_LINUX_BFS is not set
-# BR2_PACKAGE_UTIL_LINUX_CAL is not set
-# BR2_PACKAGE_UTIL_LINUX_CHFN_CHSH is not set
-# BR2_PACKAGE_UTIL_LINUX_CRAMFS is not set
-# BR2_PACKAGE_UTIL_LINUX_EJECT is not set
-# BR2_PACKAGE_UTIL_LINUX_FALLOCATE is not set
-# BR2_PACKAGE_UTIL_LINUX_FDFORMAT is not set
-# BR2_PACKAGE_UTIL_LINUX_FSCK is not set
-# BR2_PACKAGE_UTIL_LINUX_HWCLOCK is not set
-# BR2_PACKAGE_UTIL_LINUX_IPCRM is not set
-# BR2_PACKAGE_UTIL_LINUX_IPCS is not set
-# BR2_PACKAGE_UTIL_LINUX_KILL is not set
-# BR2_PACKAGE_UTIL_LINUX_LAST is not set
-# BR2_PACKAGE_UTIL_LINUX_LINE is not set
-# BR2_PACKAGE_UTIL_LINUX_LOGIN_UTILS is not set
-# BR2_PACKAGE_UTIL_LINUX_LOGGER is not set
-# BR2_PACKAGE_UTIL_LINUX_LOSETUP is not set
-# BR2_PACKAGE_UTIL_LINUX_LSLOGINS is not set
-# BR2_PACKAGE_UTIL_LINUX_MESG is not set
-# BR2_PACKAGE_UTIL_LINUX_MINIX is not set
-# BR2_PACKAGE_UTIL_LINUX_MORE is not set
-# BR2_PACKAGE_UTIL_LINUX_MOUNT is not set
-# BR2_PACKAGE_UTIL_LINUX_MOUNTPOINT is not set
-# BR2_PACKAGE_UTIL_LINUX_NEWGRP is not set
-# BR2_PACKAGE_UTIL_LINUX_NOLOGIN is not set
-# BR2_PACKAGE_UTIL_LINUX_NSENTER is not set
-# BR2_PACKAGE_UTIL_LINUX_PG is not set
-# BR2_PACKAGE_UTIL_LINUX_PARTX is not set
-# BR2_PACKAGE_UTIL_LINUX_PIVOT_ROOT is not set
-# BR2_PACKAGE_UTIL_LINUX_RAW is not set
-# BR2_PACKAGE_UTIL_LINUX_RENAME is not set
-# BR2_PACKAGE_UTIL_LINUX_RESET is not set
-BR2_PACKAGE_UTIL_LINUX_SCHEDUTILS=y
-# BR2_PACKAGE_UTIL_LINUX_SETPRIV is not set
-# BR2_PACKAGE_UTIL_LINUX_SETTERM is not set
-# BR2_PACKAGE_UTIL_LINUX_SWITCH_ROOT is not set
-# BR2_PACKAGE_UTIL_LINUX_TUNELP is not set
-# BR2_PACKAGE_UTIL_LINUX_UL is not set
-# BR2_PACKAGE_UTIL_LINUX_UNSHARE is not set
-# BR2_PACKAGE_UTIL_LINUX_UTMPDUMP is not set
-# BR2_PACKAGE_UTIL_LINUX_UUIDD is not set
-# BR2_PACKAGE_UTIL_LINUX_VIPW is not set
-# BR2_PACKAGE_UTIL_LINUX_WALL is not set
-# BR2_PACKAGE_UTIL_LINUX_WDCTL is not set
-# BR2_PACKAGE_UTIL_LINUX_WRITE is not set
-# BR2_PACKAGE_UTIL_LINUX_ZRAMCTL is not set
-BR2_PACKAGE_XVISOR_ARCH_SUPPORTS=y
-# BR2_PACKAGE_XVISOR is not set
-
-#
-# Text editors and viewers
-#
-# BR2_PACKAGE_ED is not set
-# BR2_PACKAGE_JOE is not set
-# BR2_PACKAGE_MC is not set
-# BR2_PACKAGE_NANO is not set
-# BR2_PACKAGE_UEMACS is not set
-
-#
-# Filesystem images
-#
-# BR2_TARGET_ROOTFS_AXFS is not set
-# BR2_TARGET_ROOTFS_CLOOP is not set
-BR2_TARGET_ROOTFS_CPIO=y
-BR2_TARGET_ROOTFS_CPIO_NONE=y
-# BR2_TARGET_ROOTFS_CPIO_GZIP is not set
-# BR2_TARGET_ROOTFS_CPIO_BZIP2 is not set
-# BR2_TARGET_ROOTFS_CPIO_LZMA is not set
-# BR2_TARGET_ROOTFS_CPIO_LZO is not set
-# BR2_TARGET_ROOTFS_CPIO_XZ is not set
-# BR2_TARGET_ROOTFS_CPIO_UIMAGE is not set
-# BR2_TARGET_ROOTFS_CRAMFS is not set
-# BR2_TARGET_ROOTFS_EXT2 is not set
-# BR2_TARGET_ROOTFS_INITRAMFS is not set
-BR2_TARGET_ROOTFS_ISO9660=y
-BR2_TARGET_ROOTFS_ISO9660_GRUB=y
-BR2_TARGET_ROOTFS_ISO9660_BOOT_MENU="fs/iso9660/menu.lst"
-BR2_TARGET_ROOTFS_ISO9660_INITRD=y
-# BR2_TARGET_ROOTFS_JFFS2 is not set
-# BR2_TARGET_ROOTFS_ROMFS is not set
-# BR2_TARGET_ROOTFS_SQUASHFS is not set
-BR2_TARGET_ROOTFS_TAR=y
-BR2_TARGET_ROOTFS_TAR_NONE=y
-# BR2_TARGET_ROOTFS_TAR_GZIP is not set
-# BR2_TARGET_ROOTFS_TAR_BZIP2 is not set
-# BR2_TARGET_ROOTFS_TAR_LZMA is not set
-# BR2_TARGET_ROOTFS_TAR_LZO is not set
-# BR2_TARGET_ROOTFS_TAR_XZ is not set
-BR2_TARGET_ROOTFS_TAR_OPTIONS=""
-# BR2_TARGET_ROOTFS_UBIFS is not set
-# BR2_TARGET_ROOTFS_YAFFS2 is not set
-
-#
-# Bootloaders
-#
-# BR2_TARGET_BAREBOX is not set
-BR2_TARGET_GRUB=y
-# BR2_TARGET_GRUB_SPLASH is not set
-# BR2_TARGET_GRUB_DISKLESS is not set
-
-#
-# filesystem drivers
-#
-BR2_TARGET_GRUB_FS_EXT2=y
-BR2_TARGET_GRUB_FS_FAT=y
-BR2_TARGET_GRUB_FS_ISO9660=y
-# BR2_TARGET_GRUB_FS_JFS is not set
-# BR2_TARGET_GRUB_FS_REISERFS is not set
-# BR2_TARGET_GRUB_FS_XFS is not set
-
-#
-# network drivers
-#
-# BR2_TARGET_GRUB_3c595 is not set
-# BR2_TARGET_GRUB_3c90x is not set
-# BR2_TARGET_GRUB_davicom is not set
-# BR2_TARGET_GRUB_e1000 is not set
-# BR2_TARGET_GRUB_eepro100 is not set
-# BR2_TARGET_GRUB_epic100 is not set
-# BR2_TARGET_GRUB_forcedeth is not set
-# BR2_TARGET_GRUB_natsemi is not set
-# BR2_TARGET_GRUB_ns83820 is not set
-# BR2_TARGET_GRUB_ns8390 is not set
-# BR2_TARGET_GRUB_pcnet32 is not set
-# BR2_TARGET_GRUB_pnic is not set
-# BR2_TARGET_GRUB_rtl8139 is not set
-# BR2_TARGET_GRUB_r8169 is not set
-# BR2_TARGET_GRUB_sis900 is not set
-# BR2_TARGET_GRUB_tg3 is not set
-# BR2_TARGET_GRUB_tulip is not set
-# BR2_TARGET_GRUB_tlan is not set
-# BR2_TARGET_GRUB_undi is not set
-# BR2_TARGET_GRUB_via_rhine is not set
-# BR2_TARGET_GRUB_w89c840 is not set
-# BR2_TARGET_GRUB2 is not set
-# BR2_TARGET_GUMMIBOOT is not set
-# BR2_TARGET_SYSLINUX is not set
-# BR2_TARGET_UBOOT is not set
-
-#
-# Host utilities
-#
-# BR2_PACKAGE_HOST_AESPIPE is not set
-# BR2_PACKAGE_HOST_ANDROID_TOOLS is not set
-# BR2_PACKAGE_HOST_CHECKPOLICY is not set
-# BR2_PACKAGE_HOST_CRAMFS is not set
-# BR2_PACKAGE_HOST_DFU_UTIL is not set
-# BR2_PACKAGE_HOST_DOS2UNIX is not set
-# BR2_PACKAGE_HOST_DOSFSTOOLS is not set
-# BR2_PACKAGE_HOST_DTC is not set
-# BR2_PACKAGE_HOST_E2FSPROGS is not set
-# BR2_PACKAGE_HOST_E2TOOLS is not set
-# BR2_PACKAGE_HOST_FAKETIME is not set
-# BR2_PACKAGE_HOST_FWUP is not set
-# BR2_PACKAGE_HOST_GENEXT2FS is not set
-# BR2_PACKAGE_HOST_GENIMAGE is not set
-# BR2_PACKAGE_HOST_GENPART is not set
-BR2_PACKAGE_HOST_GO_ARCH_SUPPORTS=y
-BR2_PACKAGE_HOST_GO_CGO_LINKING_SUPPORTS=y
-# BR2_PACKAGE_HOST_GPTFDISK is not set
-# BR2_PACKAGE_HOST_JQ is not set
-# BR2_PACKAGE_HOST_JSMIN is not set
-# BR2_PACKAGE_HOST_LPC3250LOADER is not set
-# BR2_PACKAGE_HOST_LTTNG_BABELTRACE is not set
-# BR2_PACKAGE_HOST_MKE2IMG is not set
-# BR2_PACKAGE_HOST_MKPASSWD is not set
-# BR2_PACKAGE_HOST_MTD is not set
-# BR2_PACKAGE_HOST_MTOOLS is not set
-# BR2_PACKAGE_HOST_OPENOCD is not set
-# BR2_PACKAGE_HOST_OPKG_UTILS is not set
-# BR2_PACKAGE_HOST_PARTED is not set
-# BR2_PACKAGE_HOST_PATCHELF is not set
-# BR2_PACKAGE_HOST_PWGEN is not set
-# BR2_PACKAGE_HOST_PYTHON_LXML is not set
-# BR2_PACKAGE_HOST_QEMU is not set
-# BR2_PACKAGE_HOST_SAM_BA is not set
-# BR2_PACKAGE_HOST_SQUASHFS is not set
-# BR2_PACKAGE_HOST_UBOOT_TOOLS is not set
-# BR2_PACKAGE_HOST_UTIL_LINUX is not set
-# BR2_PACKAGE_HOST_VBOOT_UTILS is not set
-# BR2_PACKAGE_HOST_XORRISO is not set
-# BR2_PACKAGE_HOST_ZIP is not set
-
-#
-# Legacy config options
-#
-
-#
-# Legacy options removed in 2017.05
-#
-# BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WEBRTC is not set
-# BR2_PACKAGE_SPICE_CLIENT is not set
-# BR2_PACKAGE_SPICE_GUI is not set
-# BR2_PACKAGE_SPICE_TUNNEL is not set
-# BR2_PACKAGE_SUNXI_MALI_R2P4 is not set
-# BR2_PACKAGE_NODEJS_MODULES_COFFEESCRIPT is not set
-# BR2_PACKAGE_NODEJS_MODULES_EXPRESS is not set
-# BR2_PACKAGE_BLUEZ5_UTILS_GATTTOOL is not set
-# BR2_PACKAGE_OPENOCD_FT2XXX is not set
-# BR2_PACKAGE_KODI_RTMPDUMP is not set
-# BR2_PACKAGE_KODI_VISUALISATION_FOUNTAIN is not set
-# BR2_PACKAGE_PORTMAP is not set
-# BR2_BINUTILS_VERSION_2_25_X is not set
-# BR2_TOOLCHAIN_BUILDROOT_INET_RPC is not set
-BR2_TARGET_ROOTFS_EXT2_EXTRA_BLOCKS=0
-# BR2_PACKAGE_SYSTEMD_KDBUS is not set
-# BR2_PACKAGE_POLARSSL is not set
-# BR2_NBD_CLIENT is not set
-# BR2_NBD_SERVER is not set
-# BR2_PACKAGE_GMOCK is not set
-# BR2_KERNEL_HEADERS_4_8 is not set
-# BR2_KERNEL_HEADERS_3_18 is not set
-# BR2_GLIBC_VERSION_2_22 is not set
-
-#
-# Legacy options removed in 2017.02
-#
-# BR2_PACKAGE_PERL_DB_FILE is not set
-# BR2_KERNEL_HEADERS_4_7 is not set
-# BR2_KERNEL_HEADERS_4_6 is not set
-# BR2_KERNEL_HEADERS_4_5 is not set
-# BR2_KERNEL_HEADERS_3_14 is not set
-# BR2_TOOLCHAIN_EXTERNAL_MUSL_CROSS is not set
-# BR2_UCLIBC_INSTALL_TEST_SUITE is not set
-# BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX is not set
-# BR2_PACKAGE_MAKEDEVS is not set
-# BR2_TOOLCHAIN_EXTERNAL_ARAGO_ARMV7A is not set
-# BR2_TOOLCHAIN_EXTERNAL_ARAGO_ARMV5TE is not set
-# BR2_PACKAGE_SNOWBALL_HDMISERVICE is not set
-# BR2_PACKAGE_SNOWBALL_INIT is not set
-# BR2_GDB_VERSION_7_9 is not set
-
-#
-# Legacy options removed in 2016.11
-#
-# BR2_PACKAGE_PHP_SAPI_CLI_CGI is not set
-# BR2_PACKAGE_PHP_SAPI_CLI_FPM is not set
-# BR2_PACKAGE_WVSTREAMS is not set
-# BR2_PACKAGE_WVDIAL is not set
-# BR2_PACKAGE_WEBKITGTK24 is not set
-# BR2_PACKAGE_TORSMO is not set
-# BR2_PACKAGE_SSTRIP is not set
-# BR2_KERNEL_HEADERS_4_3 is not set
-# BR2_KERNEL_HEADERS_4_2 is not set
-# BR2_PACKAGE_KODI_ADDON_XVDR is not set
-# BR2_PACKAGE_IPKG is not set
-# BR2_GCC_VERSION_4_7_X is not set
-# BR2_BINUTILS_VERSION_2_24_X is not set
-# BR2_PACKAGE_WESTON_RPI is not set
-# BR2_LINUX_KERNEL_TOOL_CPUPOWER is not set
-# BR2_LINUX_KERNEL_TOOL_PERF is not set
-# BR2_LINUX_KERNEL_TOOL_SELFTESTS is not set
-# BR2_GCC_VERSION_4_8_ARC is not set
-# BR2_KERNEL_HEADERS_4_0 is not set
-# BR2_KERNEL_HEADERS_3_19 is not set
-# BR2_PACKAGE_LIBEVAS_GENERIC_LOADERS is not set
-# BR2_PACKAGE_ELEMENTARY is not set
-# BR2_LINUX_KERNEL_CUSTOM_LOCAL is not set
-
-#
-# Legacy options removed in 2016.08
-#
-# BR2_PACKAGE_EFL_JP2K is not set
-# BR2_PACKAGE_SYSTEMD_COMPAT is not set
-# BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_LIVEADDER is not set
-# BR2_PACKAGE_LIBFSLVPUWRAP is not set
-# BR2_PACKAGE_LIBFSLPARSER is not set
-# BR2_PACKAGE_LIBFSLCODEC is not set
-# BR2_PACKAGE_UBOOT_TOOLS_MKIMAGE_FIT_SIGNATURE_SUPPORT is not set
-# BR2_PTHREADS_OLD is not set
-# BR2_BINUTILS_VERSION_2_23_X is not set
-# BR2_TOOLCHAIN_BUILDROOT_EGLIBC is not set
-# BR2_GDB_VERSION_7_8 is not set
-
-#
-# Legacy options removed in 2016.05
-#
-# BR2_PACKAGE_OPENVPN_CRYPTO_POLARSSL is not set
-# BR2_PACKAGE_NGINX_HTTP_SPDY_MODULE is not set
-# BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_RTP is not set
-# BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_MPG123 is not set
-# BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC is not set
-# BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC_E500V2 is not set
-# BR2_x86_i386 is not set
-# BR2_PACKAGE_QT5WEBKIT_EXAMPLES is not set
-# BR2_PACKAGE_QT5QUICK1 is not set
-BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR=""
-# BR2_PACKAGE_XDRIVER_XF86_INPUT_VOID is not set
-# BR2_KERNEL_HEADERS_3_17 is not set
-# BR2_GDB_VERSION_7_7 is not set
-# BR2_PACKAGE_FOOMATIC_FILTERS is not set
-# BR2_PACKAGE_SAMBA is not set
-# BR2_PACKAGE_KODI_WAVPACK is not set
-# BR2_PACKAGE_KODI_RSXS is not set
-# BR2_PACKAGE_KODI_GOOM is not set
-# BR2_PACKAGE_SYSTEMD_ALL_EXTRAS is not set
-# BR2_GCC_VERSION_4_5_X is not set
-# BR2_PACKAGE_SQLITE_READLINE is not set
-
-#
-# Legacy options removed in 2016.02
-#
-# BR2_PACKAGE_DOVECOT_BZIP2 is not set
-# BR2_PACKAGE_DOVECOT_ZLIB is not set
-# BR2_PACKAGE_E2FSPROGS_FINDFS is not set
-# BR2_PACKAGE_OPENPOWERLINK_DEBUG_LEVEL is not set
-# BR2_PACKAGE_OPENPOWERLINK_KERNEL_MODULE is not set
-# BR2_PACKAGE_OPENPOWERLINK_LIBPCAP is not set
-# BR2_LINUX_KERNEL_SAME_AS_HEADERS is not set
-# BR2_PACKAGE_CUPS_PDFTOPS is not set
-# BR2_KERNEL_HEADERS_3_16 is not set
-# BR2_PACKAGE_PYTHON_PYXML is not set
-# BR2_ENABLE_SSP is not set
-# BR2_PACKAGE_DIRECTFB_CLE266 is not set
-# BR2_PACKAGE_DIRECTFB_UNICHROME is not set
-# BR2_PACKAGE_LIBELEMENTARY is not set
-# BR2_PACKAGE_LIBEINA is not set
-# BR2_PACKAGE_LIBEET is not set
-# BR2_PACKAGE_LIBEVAS is not set
-# BR2_PACKAGE_LIBECORE is not set
-# BR2_PACKAGE_LIBEDBUS is not set
-# BR2_PACKAGE_LIBEFREET is not set
-# BR2_PACKAGE_LIBEIO is not set
-# BR2_PACKAGE_LIBEMBRYO is not set
-# BR2_PACKAGE_LIBEDJE is not set
-# BR2_PACKAGE_LIBETHUMB is not set
-# BR2_PACKAGE_INFOZIP is not set
-# BR2_BR2_PACKAGE_NODEJS_0_10_X is not set
-# BR2_BR2_PACKAGE_NODEJS_0_12_X is not set
-# BR2_BR2_PACKAGE_NODEJS_4_X is not set
-
-#
-# Legacy options removed in 2015.11
-#
-# BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_REAL is not set
-# BR2_PACKAGE_MEDIA_CTL is not set
-# BR2_PACKAGE_SCHIFRA is not set
-# BR2_PACKAGE_ZXING is not set
-# BR2_PACKAGE_BLACKBOX is not set
-# BR2_KERNEL_HEADERS_3_0 is not set
-# BR2_KERNEL_HEADERS_3_11 is not set
-# BR2_KERNEL_HEADERS_3_13 is not set
-# BR2_KERNEL_HEADERS_3_15 is not set
-# BR2_PACKAGE_DIRECTFB_EXAMPLES_ANDI is not set
-# BR2_PACKAGE_DIRECTFB_EXAMPLES_BLTLOAD is not set
-# BR2_PACKAGE_DIRECTFB_EXAMPLES_CPULOAD is not set
-# BR2_PACKAGE_DIRECTFB_EXAMPLES_DATABUFFER is not set
-# BR2_PACKAGE_DIRECTFB_EXAMPLES_DIOLOAD is not set
-# BR2_PACKAGE_DIRECTFB_EXAMPLES_DOK is not set
-# BR2_PACKAGE_DIRECTFB_EXAMPLES_DRIVERTEST is not set
-# BR2_PACKAGE_DIRECTFB_EXAMPLES_FIRE is not set
-# BR2_PACKAGE_DIRECTFB_EXAMPLES_FLIP is not set
-# BR2_PACKAGE_DIRECTFB_EXAMPLES_FONTS is not set
-# BR2_PACKAGE_DIRECTFB_EXAMPLES_INPUT is not set
-# BR2_PACKAGE_DIRECTFB_EXAMPLES_JOYSTICK is not set
-# BR2_PACKAGE_DIRECTFB_EXAMPLES_KNUCKLES is not set
-# BR2_PACKAGE_DIRECTFB_EXAMPLES_LAYER is not set
-# BR2_PACKAGE_DIRECTFB_EXAMPLES_MATRIX is not set
-# BR2_PACKAGE_DIRECTFB_EXAMPLES_MATRIX_WATER is not set
-# BR2_PACKAGE_DIRECTFB_EXAMPLES_NEO is not set
-# BR2_PACKAGE_DIRECTFB_EXAMPLES_NETLOAD is not set
-# BR2_PACKAGE_DIRECTFB_EXAMPLES_PALETTE is not set
-# BR2_PACKAGE_DIRECTFB_EXAMPLES_PARTICLE is not set
-# BR2_PACKAGE_DIRECTFB_EXAMPLES_PORTER is not set
-# BR2_PACKAGE_DIRECTFB_EXAMPLES_STRESS is not set
-# BR2_PACKAGE_DIRECTFB_EXAMPLES_TEXTURE is not set
-# BR2_PACKAGE_DIRECTFB_EXAMPLES_VIDEO is not set
-# BR2_PACKAGE_DIRECTFB_EXAMPLES_VIDEO_PARTICLE is not set
-# BR2_PACKAGE_DIRECTFB_EXAMPLES_WINDOW is not set
-# BR2_PACKAGE_KOBS_NG is not set
-# BR2_PACKAGE_SAWMAN is not set
-# BR2_PACKAGE_DIVINE is not set
-
-#
-# Legacy options removed in 2015.08
-#
-# BR2_PACKAGE_KODI_PVR_ADDONS is not set
-# BR2_BINUTILS_VERSION_2_23_2 is not set
-# BR2_BINUTILS_VERSION_2_24 is not set
-# BR2_BINUTILS_VERSION_2_25 is not set
-# BR2_PACKAGE_PERF is not set
-# BR2_BINUTILS_VERSION_2_22 is not set
-# BR2_PACKAGE_GPU_VIV_BIN_MX6Q is not set
-# BR2_TARGET_UBOOT_NETWORK is not set
-
-#
-# Legacy options removed in 2015.05
-#
-# BR2_TARGET_ROOTFS_JFFS2_NANDFLASH_512_16K is not set
-# BR2_TARGET_ROOTFS_JFFS2_NANDFLASH_2K_128K is not set
-# BR2_PACKAGE_MONO_20 is not set
-# BR2_PACKAGE_MONO_40 is not set
-# BR2_PACKAGE_MONO_45 is not set
-# BR2_CIVETWEB_WITH_LUA is not set
-# BR2_PACKAGE_TIFF_TIFF2PDF is not set
-# BR2_PACKAGE_TIFF_TIFFCP is not set
-# BR2_LINUX_KERNEL_EXT_RTAI_PATCH is not set
-# BR2_TARGET_GENERIC_PASSWD_DES is not set
-# BR2_PACKAGE_GTK2_THEME_HICOLOR is not set
-# BR2_PACKAGE_VALGRIND_PTRCHECK is not set
-
-#
-# Legacy options removed in 2015.02
-#
-# BR2_PACKAGE_LIBGC is not set
-# BR2_PACKAGE_WDCTL is not set
-# BR2_PACKAGE_UTIL_LINUX_ARCH is not set
-# BR2_PACKAGE_UTIL_LINUX_DDATE is not set
-# BR2_PACKAGE_RPM_BZIP2_PAYLOADS is not set
-# BR2_PACKAGE_RPM_XZ_PAYLOADS is not set
-# BR2_PACKAGE_M4 is not set
-# BR2_PACKAGE_FLEX_BINARY is not set
-# BR2_PACKAGE_BISON is not set
-# BR2_PACKAGE_GOB2 is not set
-# BR2_PACKAGE_DISTCC is not set
-# BR2_PACKAGE_HASERL_VERSION_0_8_X is not set
-# BR2_PACKAGE_STRONGSWAN_TOOLS is not set
-# BR2_PACKAGE_XBMC_ADDON_XVDR is not set
-# BR2_PACKAGE_XBMC_PVR_ADDONS is not set
-# BR2_PACKAGE_XBMC is not set
-# BR2_PACKAGE_XBMC_ALSA_LIB is not set
-# BR2_PACKAGE_XBMC_AVAHI is not set
-# BR2_PACKAGE_XBMC_DBUS is not set
-# BR2_PACKAGE_XBMC_LIBBLURAY is not set
-# BR2_PACKAGE_XBMC_GOOM is not set
-# BR2_PACKAGE_XBMC_RSXS is not set
-# BR2_PACKAGE_XBMC_LIBCEC is not set
-# BR2_PACKAGE_XBMC_LIBMICROHTTPD is not set
-# BR2_PACKAGE_XBMC_LIBNFS is not set
-# BR2_PACKAGE_XBMC_RTMPDUMP is not set
-# BR2_PACKAGE_XBMC_LIBSHAIRPLAY is not set
-# BR2_PACKAGE_XBMC_LIBSMBCLIENT is not set
-# BR2_PACKAGE_XBMC_LIBTHEORA is not set
-# BR2_PACKAGE_XBMC_LIBUSB is not set
-# BR2_PACKAGE_XBMC_LIBVA is not set
-# BR2_PACKAGE_XBMC_WAVPACK is not set
-# BR2_PREFER_STATIC_LIB is not set
-
-#
-# Legacy options removed in 2014.11
-#
-# BR2_x86_generic is not set
-# BR2_GCC_VERSION_4_4_X is not set
-# BR2_sparc_sparchfleon is not set
-# BR2_sparc_sparchfleonv8 is not set
-# BR2_sparc_sparcsfleon is not set
-# BR2_sparc_sparcsfleonv8 is not set
-# BR2_PACKAGE_LINUX_FIRMWARE_XC5000 is not set
-# BR2_PACKAGE_LINUX_FIRMWARE_CXGB4 is not set
-# BR2_PACKAGE_LINUX_FIRMWARE_IWLWIFI_3160_7260_7 is not set
-# BR2_PACKAGE_LINUX_FIRMWARE_IWLWIFI_3160_7260_8 is not set
-
-#
-# Legacy options removed in 2014.08
-#
-# BR2_PACKAGE_LIBELF is not set
-# BR2_KERNEL_HEADERS_3_8 is not set
-# BR2_PACKAGE_GETTEXT_TOOLS is not set
-# BR2_PACKAGE_PROCPS is not set
-# BR2_BINUTILS_VERSION_2_20_1 is not set
-# BR2_BINUTILS_VERSION_2_21 is not set
-# BR2_BINUTILS_VERSION_2_23_1 is not set
-# BR2_UCLIBC_VERSION_0_9_32 is not set
-# BR2_GCC_VERSION_4_3_X is not set
-# BR2_GCC_VERSION_4_6_X is not set
-# BR2_GDB_VERSION_7_4 is not set
-# BR2_GDB_VERSION_7_5 is not set
-# BR2_BUSYBOX_VERSION_1_19_X is not set
-# BR2_BUSYBOX_VERSION_1_20_X is not set
-# BR2_BUSYBOX_VERSION_1_21_X is not set
-# BR2_PACKAGE_LIBV4L_DECODE_TM6000 is not set
-# BR2_PACKAGE_LIBV4L_IR_KEYTABLE is not set
-# BR2_PACKAGE_LIBV4L_V4L2_COMPLIANCE is not set
-# BR2_PACKAGE_LIBV4L_V4L2_CTL is not set
-# BR2_PACKAGE_LIBV4L_V4L2_DBG is not set
-
-#
-# Legacy options removed in 2014.05
-#
-# BR2_PACKAGE_EVTEST_CAPTURE is not set
-# BR2_KERNEL_HEADERS_3_6 is not set
-# BR2_KERNEL_HEADERS_3_7 is not set
-# BR2_PACKAGE_VALA is not set
-BR2_PACKAGE_TZDATA_ZONELIST=""
-# BR2_PACKAGE_LUA_INTERPRETER_EDITING_NONE is not set
-# BR2_PACKAGE_LUA_INTERPRETER_READLINE is not set
-# BR2_PACKAGE_LUA_INTERPRETER_LINENOISE is not set
-# BR2_PACKAGE_DVB_APPS_UTILS is not set
-# BR2_KERNEL_HEADERS_SNAP is not set
-# BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_UDEV is not set
-# BR2_PACKAGE_UDEV is not set
-# BR2_PACKAGE_UDEV_RULES_GEN is not set
-# BR2_PACKAGE_UDEV_ALL_EXTRAS is not set
-
-#
-# Legacy options removed in 2014.02
-#
-# BR2_sh2 is not set
-# BR2_sh3 is not set
-# BR2_sh3eb is not set
-# BR2_KERNEL_HEADERS_3_1 is not set
-# BR2_KERNEL_HEADERS_3_3 is not set
-# BR2_KERNEL_HEADERS_3_5 is not set
-# BR2_GDB_VERSION_7_2 is not set
-# BR2_GDB_VERSION_7_3 is not set
-# BR2_PACKAGE_CCACHE is not set
-# BR2_HAVE_DOCUMENTATION is not set
-# BR2_PACKAGE_AUTOMAKE is not set
-# BR2_PACKAGE_AUTOCONF is not set
-# BR2_PACKAGE_XSTROKE is not set
-# BR2_PACKAGE_LZMA is not set
-# BR2_PACKAGE_TTCP is not set
-# BR2_PACKAGE_LIBNFC_LLCP is not set
-# BR2_PACKAGE_MYSQL_CLIENT is not set
-# BR2_PACKAGE_SQUASHFS3 is not set
-# BR2_TARGET_ROOTFS_SQUASHFS3 is not set
-# BR2_PACKAGE_NETKITBASE is not set
-# BR2_PACKAGE_NETKITTELNET is not set
-# BR2_PACKAGE_LUASQL is not set
-# BR2_PACKAGE_LUACJSON is not set
-
-#
-# Legacy options removed in 2013.11
-#
-# BR2_PACKAGE_LVM2_DMSETUP_ONLY is not set
-# BR2_PACKAGE_QT_JAVASCRIPTCORE is not set
-# BR2_PACKAGE_MODULE_INIT_TOOLS is not set
-BR2_TARGET_UBOOT_CUSTOM_GIT_REPO_URL=""
-BR2_TARGET_UBOOT_CUSTOM_GIT_VERSION=""
-BR2_LINUX_KERNEL_CUSTOM_GIT_REPO_URL=""
-BR2_LINUX_KERNEL_CUSTOM_GIT_VERSION=""
-
-#
-# Legacy options removed in 2013.08
-#
-# BR2_ARM_OABI is not set
-# BR2_PACKAGE_DOSFSTOOLS_DOSFSCK is not set
-# BR2_PACKAGE_DOSFSTOOLS_DOSFSLABEL is not set
-# BR2_PACKAGE_DOSFSTOOLS_MKDOSFS is not set
-# BR2_ELF2FLT is not set
-# BR2_VFP_FLOAT is not set
-# BR2_PACKAGE_GCC_TARGET is not set
-# BR2_HAVE_DEVFILES is not set
-
-#
-# Legacy options removed in 2013.05
-#
-# BR2_PACKAGE_LINUX_FIRMWARE_RTL_8192 is not set
-# BR2_PACKAGE_LINUX_FIRMWARE_RTL_8712 is not set
-
-#
-# Legacy options removed in 2013.02
-#
-# BR2_sa110 is not set
-# BR2_sa1100 is not set
-# BR2_PACKAGE_GDISK is not set
-# BR2_PACKAGE_GDISK_GDISK is not set
-# BR2_PACKAGE_GDISK_SGDISK is not set
-# BR2_PACKAGE_GDB_HOST is not set
-# BR2_PACKAGE_DIRECTB_DITHER_RGB16 is not set
-# BR2_PACKAGE_DIRECTB_TESTS is not set
-
-#
-# Legacy options removed in 2012.11
-#
-# BR2_PACKAGE_CUSTOMIZE is not set
-# BR2_PACKAGE_XSERVER_xorg is not set
-# BR2_PACKAGE_XSERVER_tinyx is not set
-# BR2_PACKAGE_PTHREAD_STUBS is not set
-
-#
-# Legacy options removed in 2012.08
-#
-# BR2_PACKAGE_GETTEXT_STATIC is not set
-# BR2_PACKAGE_LIBINTL is not set
-# BR2_PACKAGE_INPUT_TOOLS_EVTEST is not set
-# BR2_BFIN_FDPIC is not set
-# BR2_BFIN_FLAT is not set
diff --git a/resources/tools/disk-image-builder/nested/buildroot-patches/dpdk.patch b/resources/tools/disk-image-builder/nested/buildroot-patches/dpdk.patch
deleted file mode 100644 (file)
index be10b65..0000000
+++ /dev/null
@@ -1,220 +0,0 @@
-diff --git a/package/Config.in b/package/Config.in
-index 6fc0466..ab38a76 100644
---- a/package/Config.in
-+++ b/package/Config.in
-@@ -1095,6 +1095,7 @@ menu "Networking"
-       source "package/cgic/Config.in"
-       source "package/cppzmq/Config.in"
-       source "package/czmq/Config.in"
-+      source "package/dpdk/Config.in"
-       source "package/filemq/Config.in"
-       source "package/flickcurl/Config.in"
-       source "package/fmlib/Config.in"
-diff --git a/package/dpdk/Config.in b/package/dpdk/Config.in
-new file mode 100644
-index 0000000..a42271e
---- /dev/null
-+++ b/package/dpdk/Config.in
-@@ -0,0 +1,55 @@
-+config BR2_PACKAGE_DPDK
-+       bool "dpdk"
-+       depends on (BR2_i386 && !BR2_x86_i386 && !BR2_x86_i486 \
-+                    && !BR2_x86_i586 && !BR2_x86_x1000) \
-+                || BR2_x86_64 || BR2_ARM_CPU_ARMV7A || BR2_aarch64 \
-+                  || BR2_aarch64_be
-+       depends on BR2_TOOLCHAIN_USES_GLIBC || BR2_TOOLCHAIN_USES_UCLIBC
-+       depends on BR2_TOOLCHAIN_HAS_SYNC_1
-+       depends on BR2_TOOLCHAIN_HAS_SYNC_2
-+       depends on BR2_TOOLCHAIN_HAS_SYNC_4
-+       depends on BR2_TOOLCHAIN_HAS_SYNC_8
-+       depends on BR2_PACKAGE_NUMACTL
-+       help
-+       DPDK is a set of libraries and drivers for fast packet processing. It
-+       was designed to run on any processors, however, Intel x86 has been the
-+       first CPU to be supported. Ports for other CPUs like IBM Power 8 and
-+       ARM are under progress. It runs mostly in Linux userland. A FreeBSD
-+       port is now available for a subset of DPDK features.
-+
-+       Notes:
-+       * To build the included Linux Kernel drivers, it is necessary to
-+         enable CONFIG_PCI_MSI, CONFIG_UIO.
-+       * To build the PCAP PMD properly, you need to enable the libpcap
-+         manually.
-+       * You may need to install the python2 interpreter if you want to use
-+         scripts dpdk_nic_bind.py and cpu_layout.py
-+
-+         http://www.dpdk.org/
-+
-+if BR2_PACKAGE_DPDK
-+
-+config BR2_PACKAGE_DPDK_CONFIG
-+      string "Configuration"
-+      default "i686-native-linuxapp-gcc" \
-+              if BR2_x86_i686
-+      default "x86_64-native-linuxapp-gcc" \
-+              if BR2_x86_64
-+      default "arm-armv7a-linuxapp-gcc" \
-+              if BR2_ARM_CPU_ARMV7A
-+      default "arm64-armv8a-linuxapp-gcc" \
-+              if BR2_aarch64 || BR2_aarch64_be
-+
-+config BR2_PACKAGE_DPDK_TEST
-+      bool "Install tests suite"
-+      select BR2_PACKAGE_PYTHON_PEXPECT if BR2_PACKAGE_PYTHON
-+      help
-+        Install all DPDK tests. If you want to run the tests by the included
-+        autotest.py script you need to enable python manually.
-+
-+config BR2_PACKAGE_DPDK_EXAMPLES
-+      bool "Build & install examples"
-+      help
-+        Build and install all examples selected by the current configuration.
-+
-+endif
-diff --git a/package/dpdk/dpdk.hash b/package/dpdk/dpdk.hash
-new file mode 100644
-index 0000000..1c47f19
---- /dev/null
-+++ b/package/dpdk/dpdk.hash
-@@ -0,0 +1,2 @@
-+# Locally calculated
-+sha256 3a08addbff45c636538514e9a5838fb91ea557661a4c071e03a9a6987d46e5b6 dpdk-17.08.tar.gz
-diff --git a/package/dpdk/dpdk.mk b/package/dpdk/dpdk.mk
-new file mode 100644
-index 0000000..02860fd
---- /dev/null
-+++ b/package/dpdk/dpdk.mk
-@@ -0,0 +1,133 @@
-+################################################################################
-+#
-+# dpdk
-+#
-+################################################################################
-+
-+DPDK_VERSION = 17.08
-+DPDK_SITE = http://fast.dpdk.org/rel
-+DPDK_SOURCE = dpdk-$(DPDK_VERSION).tar.gz
-+
-+DPDK_LICENSE = BSD (core), GPLv2+ (Linux drivers)
-+DPDK_LICENSE_FILES = GNUmakefile LICENSE.GPL
-+DPDK_INSTALL_STAGING = YES
-+
-+DPDK_DEPENDENCIES += linux
-+ifeq ($(BR2_PACKAGE_NUMACTL),y)
-+DPDK_DEPENDENCIES += numactl
-+endif
-+
-+ifeq ($(BR2_PACKAGE_LIBPCAP),y)
-+DPDK_DEPENDENCIES += libpcap
-+endif
-+
-+ifeq ($(BR2_SHARED_LIBS),y)
-+define DPDK_ENABLE_SHARED_LIBS
-+      $(call KCONFIG_ENABLE_OPT,CONFIG_RTE_BUILD_SHARED_LIB,\
-+                      $(@D)/build/.config)
-+endef
-+
-+DPDK_POST_CONFIGURE_HOOKS += DPDK_ENABLE_SHARED_LIBS
-+endif
-+
-+# We're building a kernel module without using the kernel-module infra,
-+# so we need to tell we want module support in the kernel
-+ifeq ($(BR2_PACKAGE_DPDK),y)
-+LINUX_NEEDS_MODULES = y
-+endif
-+
-+DPDK_CONFIG = $(call qstrip,$(BR2_PACKAGE_DPDK_CONFIG))
-+
-+ifeq ($(BR2_PACKAGE_DPDK_EXAMPLES),y)
-+# Build of DPDK examples is not very straight-forward. It requires to have
-+# the SDK and runtime installed on same place to reference it by RTE_SDK.
-+# We place it locally in the build directory.
-+# In additition, some examples seem to have a dependency on the ethtool
-+# example that may not be met when building in parallel for the first
-+# time. As a (dirty) workaround, we build twice.
-+define DPDK_BUILD_EXAMPLES
-+       $(INSTALL) -m 0755 -D -d $(TARGET_DIR)/usr/bin
-+       $(INSTALL) -m 0755 -D $(@D)/build/app/testpmd $(TARGET_DIR)/usr/bin
-+#     $(MAKE) -C $(@D) DESTDIR=$(@D)/examples-sdk \
-+#             CROSS=$(TARGET_CROSS) install-sdk install-runtime
-+#     $(MAKE) -C $(@D) RTE_KERNELDIR=$(LINUX_DIR) CROSS=$(TARGET_CROSS) \
-+#             RTE_SDK=$(@D)/examples-sdk/usr/local/share/dpdk \
-+#             T=$(DPDK_CONFIG) examples || echo "Failed, building again"
-+#     $(MAKE) -C $(@D) RTE_KERNELDIR=$(LINUX_DIR) CROSS=$(TARGET_CROSS) \
-+#             RTE_SDK=$(@D)/examples-sdk/usr/local/share/dpdk \
-+#             T=$(DPDK_CONFIG) examples
-+endef
-+
-+DPDK_EXAMPLES_PATH = $(@D)/examples-sdk/usr/local/share/dpdk/examples
-+
-+# Installation of examples is not supported in DPDK so we do it explicitly
-+# here. As the binaries and libraries do not have a single or regular location
-+# where to find them after build, we search for them by find.
-+define DPDK_INSTALL_EXAMPLES
-+#     $(INSTALL) -m 0755 -d $(TARGET_DIR)/usr/local/bin
-+#     $(INSTALL) -m 0755 -d $(TARGET_DIR)/usr/local/lib
-+#     for f in `find $(DPDK_EXAMPLES_PATH) -executable -type f   \
-+#                     -name '[a-z]*.so*' | grep '\/lib\/.*'`; do \
-+#             $(INSTALL) -m 0755 -D $$f                          \
-+#                     $(TARGET_DIR)/usr/local/lib/`basename $$f`;\
-+#     done
-+#     for f in `find $(DPDK_EXAMPLES_PATH) -executable -type f   \
-+#                     ! -name '*.so*' | grep '\/app\/.*'`; do    \
-+#             $(INSTALL) -m 0755 -D $$f                          \
-+#                     $(TARGET_DIR)/usr/local/bin/`basename $$f`;\
-+#     done
-+endef
-+
-+define DPDK_INSTALL_KMOD
-+      $(INSTALL) -m 0755 -d $(TARGET_DIR)/usr/local/kmod
-+      for f in `find $(@D)/build/kmod -name '*.ko'` ; do              \
-+              $(INSTALL) -m 0755 -D $$f                               \
-+                      $(TARGET_DIR)/usr/local/kmod/`basename $$f`;    \
-+      done
-+endef
-+
-+# Build of the power example is broken (at least for 16.04).
-+define DPDK_DISABLE_POWER
-+      $(call KCONFIG_DISABLE_OPT,CONFIG_RTE_LIBRTE_POWER,\
-+                      $(@D)/build/.config)
-+endef
-+
-+DPDK_POST_CONFIGURE_HOOKS += DPDK_DISABLE_POWER
-+endif
-+
-+define DPDK_CONFIGURE_CMDS
-+      $(MAKE) -C $(@D) T=$(DPDK_CONFIG) RTE_KERNELDIR=$(LINUX_DIR) \
-+                         CROSS=$(TARGET_CROSS) config
-+endef
-+
-+define DPDK_BUILD_CMDS
-+        $(TARGET_MAKE_ENV) LDFLAGS="$(TARGET_LDFLAGS)" $(MAKE) \
-+                DBM_INCLUDE="$(STAGING_DIR)/usr/include" \
-+                CCOPTS="$(TARGET_CFLAGS) -D_GNU_SOURCE" \
-+                SHARED_LIBS="$(if $(BR2_STATIC_LIBS),n,y)" -C $(@D) \
-+                RTE_KERNELDIR=$(LINUX_DIR) CROSS=$(TARGET_CROSS)
-+      $(DPDK_BUILD_EXAMPLES)
-+endef
-+
-+define DPDK_INSTALL_STAGING_CMDS
-+      $(MAKE) -C $(@D) DESTDIR=$(STAGING_DIR) prefix=/usr \
-+               CROSS=$(TARGET_CROSS) install-sdk
-+endef
-+
-+ifeq ($(BR2_PACKAGE_DPDK_TEST),y)
-+define DPDK_INSTALL_TARGET_TEST
-+      $(INSTALL) -m 0755 -d $(TARGET_DIR)/usr/dpdk
-+      $(INSTALL) -m 0755 -D $(@D)/build/app/test $(TARGET_DIR)/usr/dpdk
-+      $(INSTALL) -m 0755 -D $(@D)/app/test/*.py $(TARGET_DIR)/usr/dpdk
-+endef
-+endif
-+
-+define DPDK_INSTALL_TARGET_CMDS
-+      $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) prefix=/usr \
-+              CROSS=$(TARGET_CROSS) install-runtime
-+        $(DPDK_INSTALL_KMOD)
-+      $(DPDK_INSTALL_TARGET_TEST)
-+      $(DPDK_INSTALL_EXAMPLES)
-+endef
-+
-+$(eval $(generic-package))
diff --git a/resources/tools/disk-image-builder/nested/clean.sh b/resources/tools/disk-image-builder/nested/clean.sh
deleted file mode 100755 (executable)
index a8912b9..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/bin/sh
-
-# Copyright (c) 2016 Cisco and/or its affiliates.
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at:
-#
-#     http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-BUILD_DIR="$(dirname $0)/build"
-
-make -C ${BUILD_DIR}/buildroot*/ clean
-rm -f ${BUILD_DIR}/*.img
diff --git a/resources/tools/disk-image-builder/nested/deepclean.sh b/resources/tools/disk-image-builder/nested/deepclean.sh
deleted file mode 100755 (executable)
index 66c14aa..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/bin/sh
-
-# Copyright (c) 2016 Cisco and/or its affiliates.
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at:
-#
-#     http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-BUILD_DIR="$(dirname $0)/build"
-rm -fr ${BUILD_DIR}/*
diff --git a/resources/tools/disk-image-builder/nested/image-patches/01-serial-console b/resources/tools/disk-image-builder/nested/image-patches/01-serial-console
deleted file mode 100755 (executable)
index 8dfede4..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/bin/sh
-
-patch boot/grub/menu.lst <<"_EOF"
-2c2,4
-< timeout              10
----
-> timeout              1
-> serial --unit=0 --speed=115200 --word=8 --parity=no --stop=1
-> terminal --timeout=0 serial console
-15c17
-<      kernel /boot/bzImage rw root=/dev/sda1 rootwait
----
->      kernel /boot/bzImage rw root=/dev/sda1 rootwait console=ttyS0,115200n8
-_EOF
-
-patch etc/inittab <<"_EOF"
-27c27,29
-< console::respawn:/sbin/getty -L  console 0 vt100 # GENERIC_SERIAL
----
-> console::respawn:/sbin/getty -L console 0 vt100 # GENERIC_SERIAL
-> # ttyS1 to be used by qemu-ga
-> ttyS2::respawn:/sbin/getty -L ttyS2 0 vt100 # Additional serial
-_EOF
diff --git a/resources/tools/disk-image-builder/nested/image-patches/02-users b/resources/tools/disk-image-builder/nested/image-patches/02-users
deleted file mode 100755 (executable)
index 9b7db09..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/sh -e
-
-patch etc/sudoers <<"_EOF"
-97a98,100
-> 
-> csit ALL=(root) NOPASSWD:ALL
-> cisco ALL=(root) NOPASSWD:ALL
-_EOF
-
-patch etc/passwd <<"_EOF"
-10a11,12
-> csit:x:1001:1001:CSIT user:/tmp:/bin/sh
-> cisco:x:1002:1002:Cisco user:/tmp:/bin/sh
-_EOF
-
-patch etc/shadow <<"_EOF"
-1c1
-< root::10933:0:99999:7:::
----
-> root:5pcUkhKEiBBfw:16892:0:99999:7:::
-10a11,12
-> csit:5pcUkhKEiBBfw:16892:0:99999:7:::
-> cisco:5piAVSAyGsbaI:16892:0:99999:7:::
-_EOF
-
-patch etc/group <<"_EOF"
-27a28,29
-> csit:x:1001:
-> cisco:x:1002:
-_EOF
-
-patch etc/ssh/sshd_config <<"_EOF"
-44c44
-< #PermitRootLogin prohibit-password
----
-> PermitRootLogin yes
-_EOF
diff --git a/resources/tools/disk-image-builder/nested/image-patches/03-network b/resources/tools/disk-image-builder/nested/image-patches/03-network
deleted file mode 100755 (executable)
index e7d215c..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/sh
-
-patch boot/grub/menu.lst <<"_EOF"
-17c17
-<      kernel /boot/bzImage rw root=/dev/sda1 rootwait console=ttyS0,115200n8
----
->      kernel /boot/bzImage rw root=/dev/sda1 rootwait ipv6.disable=1 console=ttyS0,115200n8
-_EOF
-
-patch etc/network/interfaces <<"_EOF"
-4a5,7
-> 
-> auto mgmt0
-> iface mgmt0 inet dhcp
-_EOF
-
-patch etc/init.d/S40network <<"_EOF"
-11a12,29
-> 
->      # Rename interfaces. The e1000 interface is managment.
->      NUM_VIRTIO=0
->      NUM_MGMT=0
->      for dev in /sys/class/net/eth*
->      do
->        devname=`basename $dev`
->        driver=`readlink ${dev}/device/driver`
->        if test "${driver#*virtio}" != "$driver"
->        then
->          ip link set dev $devname name virtio${NUM_VIRTIO}
->          NUM_VIRTIO=$(($NUM_VIRTIO+1))
->        else
->          ip link set dev $devname name mgmt${NUM_MGMT}
->          NUM_MGMT=$((NUM_MGMT+1))
->        fi
->      done
-> 
-_EOF
diff --git a/resources/tools/disk-image-builder/nested/image-patches/04-qemu-ga b/resources/tools/disk-image-builder/nested/image-patches/04-qemu-ga
deleted file mode 100755 (executable)
index 2897260..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-#!/bin/sh
-
-cat - > etc/init.d/S45qemu-ga <<"_EOF"
-#!/bin/sh
-#
-# Start QEMU guest agent
-#
-QEMU_GA_MODE="isa-serial"
-QEMU_GA_DEV="/dev/ttyS1"
-
-case "$1" in
-  start)
-       echo "Starting qemu guest agent..."
-       /usr/bin/qemu-ga -m $QEMU_GA_MODE -p $QEMU_GA_DEV -d
-       ;;
-  stop)
-       echo "Stopping quemu guest agent..."
-       killall qemu-ga
-       ;;
-  restart|reload)
-       "$0" stop
-       "$0" start
-       ;;
-  *)
-       echo "Usage: $0 {start|stop|restart}"
-       exit 1
-esac
-
-exit $?
-_EOF
-
-chown root.root etc/init.d/S45qemu-ga
-chmod 755 etc/init.d/S45qemu-ga
diff --git a/resources/tools/disk-image-builder/nested/image-patches/05-ssh-hostkeys b/resources/tools/disk-image-builder/nested/image-patches/05-ssh-hostkeys
deleted file mode 100755 (executable)
index de8be15..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/bin/sh
-
-# Generate host keys here. This will speed up first boot time ever so slightly.
-# It does however mean that keys are not unique across installations -- which
-# shouldn't be an issue for our use case though.
-
-sudo mkdir -m 0775 -p etc/ssh
-for a in rsa ecdsa ed25519 dsa
-do
-  sudo ssh-keygen -f etc/ssh/ssh_host_${a}_key -N "" -t ${a}
-done
diff --git a/resources/tools/disk-image-builder/nested/image-patches/06-dpdk-support b/resources/tools/disk-image-builder/nested/image-patches/06-dpdk-support
deleted file mode 100755 (executable)
index 2de4ad6..0000000
+++ /dev/null
@@ -1,98 +0,0 @@
-#!/bin/sh
-
-### This may be a temporary file. Once DPDK is working stable in the nested
-### VM, and if and when ### we decide we want to do all testing with DPDK,
-### the steps executed here may become default configuration for the image.
-###
-### For now, to give us the flexibility to work with and without DPDK, keep
-### this as a separate script.
-
-DPDK_START_FILE="start-testpmd.sh"
-DPDK_STOP_FILE="stop-testpmd.sh"
-
-cat - > ${DPDK_START_FILE} <<"_EOF"
-#!/bin/sh
-
-TARGET_DRIVER="igb_uio"
-PATH_TO_IGB_UIO_MODULE="/usr/local/kmod/igb_uio.ko"
-NUM_HUGEPAGES=512
-TESTPMD_LOG=/tmp/testpmd.log
-TESTPMD_PID=/tmp/testpmd.pid
-
-if [ -f ${TESTPMD_PID} ]
-then
-  echo Testpmd is already running. Please stop running instance first.
-  echo Delete PID file ${TESTPMD_PID} if you are sure this is a stale PID file.
-  exit 1
-fi
-
-# Load igb_uio module if this is the driver we want to use
-if [ "${TARGET_DRIVER}" = "igb_uio" ]
-then
-  insmod ${PATH_TO_IGB_UIO_MODULE}
-fi
-
-# Set up hugepages
-echo "vm.nr_hugepages = ${NUM_HUGEPAGES}" > /etc/sysctl.conf
-echo "vm.swappiness = 0" >> /etc/sysctl.conf
-echo "kernel.randomize_va_space = 0" >> /etc/sysctl.conf
-sysctl -p
-mkdir -p /mnt/huge
-grep -q hugetlbfs /etc/fstab || echo "hugetlbfs /mnt/huge hugetlbfs mode=1770,gid=2021 0 0" >> /etc/fstab
-mount -a
-
-#
-echo 1af4 1000 > /sys/bus/pci/drivers/${TARGET_DRIVER}/new_id
-#
-for dev in $(find /sys/bus/pci/drivers/virtio-pci -type l -name '*:*:*.*' | sed -e 's/.*\///')
-do
-  class=$(cat /sys/bus/pci/drivers/virtio-pci/${dev}/class)
-  if [ "$class" = "0x020000" ]; then
-       echo Unbinding $dev from virtio-pci
-       echo $dev > /sys/bus/pci/drivers/virtio-pci/unbind
-       echo Binding $dev to ${TARGET_DRIVER}
-       echo $dev > /sys/bus/pci/drivers/${TARGET_DRIVER}/bind
-  fi
-done
-
-# RCU and IRQ affinity
-for i in $(ls /proc/irq/ | grep [0-9])
-do
-  echo 1 > /proc/irq/$i/smp_affinity
-done
-echo 1 | sudo tee /sys/bus/workqueue/devices/writeback/cpumask
-
-# There is a bug causing packet loss when VM is initialized. This workaround is
-# supposed to re-initialize CPUs.
-for i in $(ls -d /sys/devices/system/cpu/cpu[1-9]/online); do
-    echo 0 | sudo tee $i
-    sleep 2
-    echo 1 | sudo tee $i
-done
-
-# Start testpmd in the background. This looks a bit convoluted; we need to redirect stdin
-# (and keep stdin active) or else testpmd will quit.
-tail -f /dev/null | nohup testpmd $@ > ${TESTPMD_LOG} 2>&1 &
-echo $! > ${TESTPMD_PID}
-_EOF
-
-cat - > ${DPDK_STOP_FILE} <<"_EOF"
-#!/bin/sh
-
-TESTPMD_LOG=/tmp/testpmd.log
-TESTPMD_PID=/tmp/testpmd.pid
-
-if [ ! -f ${TESTPMD_PID} ]
-then
-  echo Testpmd is not running.
-  exit 1
-fi
-
-kill $(cat ${TESTPMD_PID})
-rm -f ${TESTPMD_PID}
-
-cat ${TESTPMD_LOG}
-_EOF
-
-chmod 755 ${DPDK_START_FILE}
-chmod 755 ${DPDK_STOP_FILE}
diff --git a/resources/tools/disk-image-builder/nested/image-patches/07-isolate-cpu b/resources/tools/disk-image-builder/nested/image-patches/07-isolate-cpu
deleted file mode 100755 (executable)
index f057a51..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/sh
-
-patch boot/grub/menu.lst <<"_EOF"
-17c17
-<      kernel /boot/bzImage rw root=/dev/sda1 rootwait ipv6.disable=1 console=ttyS0,115200n8
----
->      kernel /boot/bzImage rw root=/dev/sda1 rootwait ipv6.disable=1 console=ttyS0,115200n8 isolcpus=1,2,3,4 nohz_full=1,2,3,4 rcu_nocbs=1,2,3,4 intel_pstate=disable
-_EOF
diff --git a/resources/tools/disk-image-builder/nested/image-patches/08-virtio-disk b/resources/tools/disk-image-builder/nested/image-patches/08-virtio-disk
deleted file mode 100755 (executable)
index 6e6feae..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/sh
-
-patch boot/grub/menu.lst <<"_EOF"
-17c17
-<      kernel /boot/bzImage rw root=/dev/sda1 rootwait ipv6.disable=1 console=ttyS0,115200n8 isolcpus=1,2,3,4 nohz_full=1,2,3,4 rcu_nocbs=1,2,3,4 intel_pstate=disable
----
->      kernel /boot/bzImage rw root=/dev/vda1 rootwait ipv6.disable=1 console=ttyS0,115200n8 isolcpus=1,2,3,4 nohz_full=1,2,3,4 rcu_nocbs=1,2,3,4 intel_pstate=disable noapic
-_EOF
diff --git a/resources/tools/disk-image-builder/nested/kernel-defconfig b/resources/tools/disk-image-builder/nested/kernel-defconfig
deleted file mode 100644 (file)
index 85beb9f..0000000
+++ /dev/null
@@ -1,325 +0,0 @@
-CONFIG_EXPERIMENTAL=y
-# CONFIG_LOCALVERSION_AUTO is not set
-CONFIG_SYSVIPC=y
-CONFIG_POSIX_MQUEUE=y
-CONFIG_BSD_PROCESS_ACCT=y
-CONFIG_TASKSTATS=y
-CONFIG_TASK_DELAY_ACCT=y
-CONFIG_TASK_XACCT=y
-CONFIG_TASK_IO_ACCOUNTING=y
-CONFIG_FHANDLE=y
-CONFIG_AUDIT=y
-CONFIG_NO_HZ=y
-CONFIG_HIGH_RES_TIMERS=y
-CONFIG_LOG_BUF_SHIFT=18
-CONFIG_CGROUPS=y
-CONFIG_CGROUP_FREEZER=y
-CONFIG_CPUSETS=y
-CONFIG_CGROUP_CPUACCT=y
-CONFIG_RESOURCE_COUNTERS=y
-CONFIG_CGROUP_SCHED=y
-CONFIG_BLK_DEV_INITRD=y
-# CONFIG_COMPAT_BRK is not set
-CONFIG_PROFILING=y
-CONFIG_KPROBES=y
-CONFIG_JUMP_LABEL=y
-CONFIG_MODULES=y
-CONFIG_MODULE_UNLOAD=y
-CONFIG_MODULE_FORCE_UNLOAD=y
-CONFIG_PARTITION_ADVANCED=y
-CONFIG_OSF_PARTITION=y
-CONFIG_AMIGA_PARTITION=y
-CONFIG_MAC_PARTITION=y
-CONFIG_BSD_DISKLABEL=y
-CONFIG_MINIX_SUBPARTITION=y
-CONFIG_SOLARIS_X86_PARTITION=y
-CONFIG_UNIXWARE_DISKLABEL=y
-CONFIG_SGI_PARTITION=y
-CONFIG_SUN_PARTITION=y
-CONFIG_KARMA_PARTITION=y
-CONFIG_EFI_PARTITION=y
-CONFIG_SMP=y
-CONFIG_CALGARY_IOMMU=y
-CONFIG_NR_CPUS=64
-CONFIG_SCHED_SMT=y
-CONFIG_PREEMPT_VOLUNTARY=y
-CONFIG_X86_REROUTE_FOR_BROKEN_BOOT_IRQS=y
-CONFIG_X86_MCE=y
-CONFIG_MICROCODE=y
-CONFIG_MICROCODE_AMD=y
-CONFIG_X86_MSR=y
-CONFIG_X86_CPUID=y
-CONFIG_NUMA=y
-CONFIG_X86_CHECK_BIOS_CORRUPTION=y
-# CONFIG_MTRR_SANITIZER is not set
-CONFIG_EFI=y
-CONFIG_HZ_1000=y
-CONFIG_KEXEC=y
-CONFIG_CRASH_DUMP=y
-# CONFIG_COMPAT_VDSO is not set
-CONFIG_HIBERNATION=y
-CONFIG_PM_DEBUG=y
-CONFIG_PM_TRACE_RTC=y
-CONFIG_ACPI_DOCK=y
-CONFIG_CPU_FREQ=y
-# CONFIG_CPU_FREQ_STAT is not set
-CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE=y
-CONFIG_CPU_FREQ_GOV_PERFORMANCE=y
-CONFIG_CPU_FREQ_GOV_ONDEMAND=y
-CONFIG_X86_ACPI_CPUFREQ=y
-CONFIG_PCI_MMCONFIG=y
-CONFIG_PCIEPORTBUS=y
-CONFIG_PCCARD=y
-CONFIG_YENTA=y
-CONFIG_HOTPLUG_PCI=y
-CONFIG_BINFMT_MISC=y
-CONFIG_IA32_EMULATION=y
-CONFIG_NET=y
-CONFIG_PACKET=y
-CONFIG_UNIX=y
-CONFIG_XFRM_USER=y
-CONFIG_INET=y
-CONFIG_IP_MULTICAST=y
-CONFIG_IP_ADVANCED_ROUTER=y
-CONFIG_IP_MULTIPLE_TABLES=y
-CONFIG_IP_ROUTE_MULTIPATH=y
-CONFIG_IP_ROUTE_VERBOSE=y
-CONFIG_IP_PNP=y
-CONFIG_IP_PNP_DHCP=y
-CONFIG_IP_PNP_BOOTP=y
-CONFIG_IP_PNP_RARP=y
-CONFIG_IP_MROUTE=y
-CONFIG_IP_PIMSM_V1=y
-CONFIG_IP_PIMSM_V2=y
-CONFIG_SYN_COOKIES=y
-# CONFIG_INET_XFRM_MODE_TRANSPORT is not set
-# CONFIG_INET_XFRM_MODE_TUNNEL is not set
-# CONFIG_INET_XFRM_MODE_BEET is not set
-# CONFIG_INET_DIAG is not set
-CONFIG_TCP_CONG_ADVANCED=y
-# CONFIG_TCP_CONG_BIC is not set
-# CONFIG_TCP_CONG_WESTWOOD is not set
-# CONFIG_TCP_CONG_HTCP is not set
-CONFIG_TCP_MD5SIG=y
-CONFIG_IPV6=y
-CONFIG_INET6_AH=y
-CONFIG_INET6_ESP=y
-CONFIG_NETLABEL=y
-CONFIG_NETFILTER=y
-# CONFIG_NETFILTER_ADVANCED is not set
-CONFIG_NF_CONNTRACK=y
-CONFIG_NF_CONNTRACK_FTP=y
-CONFIG_NF_CONNTRACK_IRC=y
-CONFIG_NF_CONNTRACK_SIP=y
-CONFIG_NF_CT_NETLINK=y
-CONFIG_NETFILTER_XT_TARGET_CONNSECMARK=y
-CONFIG_NETFILTER_XT_TARGET_NFLOG=y
-CONFIG_NETFILTER_XT_TARGET_SECMARK=y
-CONFIG_NETFILTER_XT_TARGET_TCPMSS=y
-CONFIG_NETFILTER_XT_MATCH_CONNTRACK=y
-CONFIG_NETFILTER_XT_MATCH_POLICY=y
-CONFIG_NETFILTER_XT_MATCH_STATE=y
-CONFIG_NF_CONNTRACK_IPV4=y
-CONFIG_IP_NF_IPTABLES=y
-CONFIG_IP_NF_FILTER=y
-CONFIG_IP_NF_TARGET_REJECT=y
-CONFIG_IP_NF_TARGET_ULOG=y
-CONFIG_NF_NAT=y
-CONFIG_IP_NF_TARGET_MASQUERADE=y
-CONFIG_IP_NF_MANGLE=y
-CONFIG_NF_CONNTRACK_IPV6=y
-CONFIG_IP6_NF_IPTABLES=y
-CONFIG_IP6_NF_MATCH_IPV6HEADER=y
-CONFIG_IP6_NF_FILTER=y
-CONFIG_IP6_NF_TARGET_REJECT=y
-CONFIG_IP6_NF_MANGLE=y
-CONFIG_NET_SCHED=y
-CONFIG_NET_EMATCH=y
-CONFIG_NET_CLS_ACT=y
-CONFIG_HAMRADIO=y
-CONFIG_CFG80211=y
-CONFIG_MAC80211=y
-CONFIG_MAC80211_LEDS=y
-CONFIG_RFKILL=y
-CONFIG_UEVENT_HELPER_PATH="/sbin/hotplug"
-CONFIG_DEVTMPFS=y
-CONFIG_DEVTMPFS_MOUNT=y
-CONFIG_DEBUG_DEVRES=y
-CONFIG_CONNECTOR=y
-CONFIG_BLK_DEV_LOOP=y
-CONFIG_BLK_DEV_SD=y
-CONFIG_BLK_DEV_SR=y
-CONFIG_BLK_DEV_SR_VENDOR=y
-CONFIG_CHR_DEV_SG=y
-CONFIG_SCSI_CONSTANTS=y
-CONFIG_SCSI_SPI_ATTRS=y
-# CONFIG_SCSI_LOWLEVEL is not set
-CONFIG_ATA=y
-CONFIG_SATA_AHCI=y
-CONFIG_ATA_PIIX=y
-CONFIG_PATA_AMD=y
-CONFIG_PATA_OLDPIIX=y
-CONFIG_PATA_SCH=y
-CONFIG_MD=y
-CONFIG_BLK_DEV_MD=y
-CONFIG_BLK_DEV_DM=y
-CONFIG_DM_MIRROR=y
-CONFIG_DM_ZERO=y
-CONFIG_MACINTOSH_DRIVERS=y
-CONFIG_MAC_EMUMOUSEBTN=y
-CONFIG_NETDEVICES=y
-CONFIG_NETCONSOLE=y
-CONFIG_TIGON3=y
-CONFIG_NET_TULIP=y
-CONFIG_E100=y
-CONFIG_E1000=y
-CONFIG_SKY2=y
-CONFIG_FORCEDETH=y
-CONFIG_8139TOO=y
-CONFIG_FDDI=y
-CONFIG_INPUT_POLLDEV=y
-# CONFIG_INPUT_MOUSEDEV_PSAUX is not set
-CONFIG_INPUT_EVDEV=y
-CONFIG_INPUT_JOYSTICK=y
-CONFIG_INPUT_TABLET=y
-CONFIG_INPUT_TOUCHSCREEN=y
-CONFIG_INPUT_MISC=y
-CONFIG_VT_HW_CONSOLE_BINDING=y
-# CONFIG_LEGACY_PTYS is not set
-CONFIG_SERIAL_NONSTANDARD=y
-CONFIG_SERIAL_8250=y
-CONFIG_SERIAL_8250_CONSOLE=y
-CONFIG_SERIAL_8250_NR_UARTS=32
-CONFIG_SERIAL_8250_EXTENDED=y
-CONFIG_SERIAL_8250_MANY_PORTS=y
-CONFIG_SERIAL_8250_SHARE_IRQ=y
-CONFIG_SERIAL_8250_DETECT_IRQ=y
-CONFIG_SERIAL_8250_RSA=y
-CONFIG_HW_RANDOM=y
-# CONFIG_HW_RANDOM_INTEL is not set
-# CONFIG_HW_RANDOM_AMD is not set
-CONFIG_NVRAM=y
-CONFIG_HPET=y
-# CONFIG_HPET_MMAP is not set
-CONFIG_I2C_I801=y
-CONFIG_WATCHDOG=y
-CONFIG_AGP=y
-CONFIG_AGP_AMD64=y
-CONFIG_AGP_INTEL=y
-CONFIG_DRM=y
-CONFIG_DRM_I915=y
-CONFIG_FB_MODE_HELPERS=y
-CONFIG_FB_TILEBLITTING=y
-CONFIG_FB_EFI=y
-# CONFIG_LCD_CLASS_DEVICE is not set
-CONFIG_VGACON_SOFT_SCROLLBACK=y
-CONFIG_LOGO=y
-# CONFIG_LOGO_LINUX_MONO is not set
-# CONFIG_LOGO_LINUX_VGA16 is not set
-CONFIG_SOUND=y
-CONFIG_SND=y
-CONFIG_SND_SEQUENCER=y
-CONFIG_SND_SEQ_DUMMY=y
-CONFIG_SND_MIXER_OSS=y
-CONFIG_SND_PCM_OSS=y
-CONFIG_SND_SEQUENCER_OSS=y
-CONFIG_SND_HRTIMER=y
-CONFIG_SND_HDA_INTEL=y
-CONFIG_SND_HDA_HWDEP=y
-CONFIG_HIDRAW=y
-CONFIG_HID_GYRATION=y
-CONFIG_LOGITECH_FF=y
-CONFIG_HID_NTRIG=y
-CONFIG_HID_PANTHERLORD=y
-CONFIG_PANTHERLORD_FF=y
-CONFIG_HID_PETALYNX=y
-CONFIG_HID_SAMSUNG=y
-CONFIG_HID_SONY=y
-CONFIG_HID_SUNPLUS=y
-CONFIG_HID_TOPSEED=y
-CONFIG_HID_PID=y
-CONFIG_USB_HIDDEV=y
-CONFIG_USB=y
-CONFIG_USB_ANNOUNCE_NEW_DEVICES=y
-CONFIG_USB_MON=y
-CONFIG_USB_EHCI_HCD=y
-CONFIG_USB_EHCI_TT_NEWSCHED=y
-CONFIG_USB_OHCI_HCD=y
-CONFIG_USB_UHCI_HCD=y
-CONFIG_USB_PRINTER=y
-CONFIG_USB_STORAGE=y
-CONFIG_USB_LIBUSUAL=y
-CONFIG_EDAC=y
-CONFIG_RTC_CLASS=y
-# CONFIG_RTC_HCTOSYS is not set
-CONFIG_DMADEVICES=y
-CONFIG_EEEPC_LAPTOP=y
-CONFIG_AMD_IOMMU=y
-CONFIG_AMD_IOMMU_STATS=y
-CONFIG_INTEL_IOMMU=y
-# CONFIG_INTEL_IOMMU_DEFAULT_ON is not set
-CONFIG_EFI_VARS=y
-CONFIG_EXT4_FS=y
-CONFIG_EXT4_FS_POSIX_ACL=y
-CONFIG_EXT4_FS_SECURITY=y
-CONFIG_QUOTA=y
-CONFIG_QUOTA_NETLINK_INTERFACE=y
-# CONFIG_PRINT_QUOTA_WARNING is not set
-CONFIG_QFMT_V2=y
-CONFIG_AUTOFS4_FS=y
-CONFIG_ISO9660_FS=y
-CONFIG_JOLIET=y
-CONFIG_ZISOFS=y
-CONFIG_MSDOS_FS=y
-CONFIG_VFAT_FS=y
-CONFIG_PROC_KCORE=y
-CONFIG_TMPFS_POSIX_ACL=y
-CONFIG_HUGETLBFS=y
-CONFIG_NFS_FS=y
-CONFIG_NFS_V3_ACL=y
-CONFIG_NFS_V4=y
-CONFIG_ROOT_NFS=y
-CONFIG_NLS_DEFAULT="utf8"
-CONFIG_NLS_CODEPAGE_437=y
-CONFIG_NLS_ASCII=y
-CONFIG_NLS_ISO8859_1=y
-CONFIG_NLS_UTF8=y
-CONFIG_PRINTK_TIME=y
-# CONFIG_ENABLE_WARN_DEPRECATED is not set
-CONFIG_MAGIC_SYSRQ=y
-# CONFIG_UNUSED_SYMBOLS is not set
-CONFIG_DEBUG_KERNEL=y
-# CONFIG_SCHED_DEBUG is not set
-CONFIG_SCHEDSTATS=y
-CONFIG_TIMER_STATS=y
-CONFIG_DEBUG_STACK_USAGE=y
-CONFIG_BLK_DEV_IO_TRACE=y
-CONFIG_PROVIDE_OHCI1394_DMA_INIT=y
-CONFIG_EARLY_PRINTK_DBGP=y
-CONFIG_DEBUG_STACKOVERFLOW=y
-# CONFIG_DEBUG_RODATA_TEST is not set
-CONFIG_DEBUG_BOOT_PARAMS=y
-CONFIG_OPTIMIZE_INLINING=y
-CONFIG_KEYS_DEBUG_PROC_KEYS=y
-CONFIG_SECURITY=y
-CONFIG_SECURITY_NETWORK=y
-CONFIG_SECURITY_SELINUX=y
-CONFIG_SECURITY_SELINUX_BOOTPARAM=y
-CONFIG_SECURITY_SELINUX_DISABLE=y
-# CONFIG_CRYPTO_ANSI_CPRNG is not set
-##
-## Our modifications
-##
-CONFIG_VIRTIO_PCI=y
-CONFIG_VIRTIO_BALLOON=y
-CONFIG_VIRTIO_BLK=y
-CONFIG_VIRTIO_NET=y
-CONFIG_VIRTIO=y
-CONFIG_VIRTIO_RING=y
-CONFIG_BRIDGE=y
-CONFIG_IP_FORWARD=y
-CONFIG_PCI_MSI=y
-CONFIG_UIO=y
-CONFIG_UIO_PCI_GENERIC=y
-# CONFIG_VFIO is not set
-# CONFIG_VFIO_PCI is not set
diff --git a/resources/tools/disk-image-builder/nested/requirements.sh b/resources/tools/disk-image-builder/nested/requirements.sh
deleted file mode 100644 (file)
index c646506..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-
-# Copyright (c) 2016 Cisco and/or its affiliates.
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at:
-#
-#     http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-sudo apt-get install -y gcc-multilib bc unzip

©2016 FD.io a Linux Foundation Collaborative Project. All Rights Reserved.
Linux Foundation is a registered trademark of The Linux Foundation. Linux is a registered trademark of Linus Torvalds.
Please see our privacy policy and terms of use.