Adapt hc2vpp-csit bootstrap scripts to HC2VPP-285/CIMANAGE-22 51/10751/2
authorMarek Gradzki <mgradzki@cisco.com>
Thu, 22 Feb 2018 06:46:09 +0000 (07:46 +0100)
committerPeter Mikus <pmikus@cisco.com>
Fri, 23 Feb 2018 10:06:00 +0000 (10:06 +0000)
Since

https://gerrit.fd.io/r/#/c/10668/
and
https://gerrit.fd.io/r/#/c/10669/

honeycomb packages from stable branches
no longer depend on single VPP version.

This patch updates download_hc_pkgs.hc script,
used by hc2vpp-csit jobs, to use the latest honeycomb package
in such case.

Change-Id: If5b006e72caa8cc905137b1bf02af7d9e927e37a
Signed-off-by: Marek Gradzki <mgradzki@cisco.com>
resources/tools/scripts/download_hc_pkgs.sh

index 1bda025..a7562aa 100755 (executable)
@@ -13,7 +13,7 @@
 # See the License for the specific language governing permissions and
 # limitations under the License.
 
-set -ex
+set -x
 
 STREAM=$1
 OS=$2
@@ -68,12 +68,18 @@ for ART in ${NSH_ARTIFACTS}; do
 done
 
 # determine VPP dependency
+# use latest if honeycomb package does not depend on single VPP version, e.g. stable branches since HC2VPP-285
+VER="RELEASE"
 if [ "${OS}" == "centos7" ]; then
-    VER=`rpm -qpR honeycomb*.rpm | grep 'vpp ' | cut -d ' ' -f 3`
-    VER=${VER}.x86_64
+    HC_VPP_VER=`rpm -qpR honeycomb*.rpm | grep -oP 'vpp = \K.+'`
+    if [ "${HC_VPP_VER}" != "" ]; then
+        VER=${HC_VPP_VER}.x86_64
+    fi
 else
-    VER=`dpkg -I honeycomb*.deb | grep -oP 'vpp \(= \K[^\)]+'`
-    VER=${VER}_amd64
+    HC_VPP_VER=`dpkg -I honeycomb*.deb | grep -oP 'vpp \(= \K[^\)]+'`
+    if [ "${HC_VPP_VER}" != "" ]; then
+        VER=${HC_VPP_VER}_amd64
+    fi
 fi
 
 # download VPP packages

©2016 FD.io a Linux Foundation Collaborative Project. All Rights Reserved.
Linux Foundation is a registered trademark of The Linux Foundation. Linux is a registered trademark of Linus Torvalds.
Please see our privacy policy and terms of use.