FIX: Ansible warnings of deprecation 46/18346/1
authorPeter Mikus <pmikus@cisco.com>
Sat, 16 Mar 2019 07:41:07 +0000 (07:41 +0000)
committerPeter Mikus <pmikus@cisco.com>
Sat, 16 Mar 2019 07:41:07 +0000 (07:41 +0000)
[DEPRECATION WARNING]: Invoking "apt" only once while using a
loop via squash_actions is deprecated.

+ aenum pip fix version
+ crypto dependencies

Change-Id: I7ca4de48d68ec4d8a8f57fedf204fa6710a3e75f
Signed-off-by: Peter Mikus <pmikus@cisco.com>
resources/tools/testbed-setup/ansible/roles/calibration/tasks/main.yaml
resources/tools/testbed-setup/ansible/roles/calibration/tasks/ubuntu_bionic.yaml [moved from resources/tools/testbed-setup/ansible/roles/calibration/tasks/ubuntu.yaml with 77% similarity]
resources/tools/testbed-setup/ansible/roles/common/tasks/ubuntu_bionic.yaml
resources/tools/testbed-setup/ansible/roles/sut/tasks/ubuntu_bionic.yaml
resources/tools/testbed-setup/ansible/roles/tg/tasks/ubuntu_bionic.yaml
resources/tools/testbed-setup/ansible/roles/tg_sut/tasks/main.yaml
resources/tools/testbed-setup/ansible/roles/tg_sut/tasks/ubuntu_bionic.yaml

index 17be800..ba9c466 100644 (file)
@@ -1,9 +1,8 @@
 ---
 # file: roles/calibration/tasks/main.yaml
 
-- name: Ubuntu specific
-  import_tasks: ubuntu.yaml
-  when: ansible_distribution|lower == 'ubuntu'
+- name: Install distribution - release - machine prerequisites
+  include_tasks: '{{ ansible_distribution|lower }}_{{ ansible_distribution_release }}.yaml'
 
 - name: Run Spectre Meltdown checker
   raw: 'spectre-meltdown-checker --no-color'
index d80eb5e..31872e0 100644 (file)
@@ -9,16 +9,16 @@
 
 - name: Install CSIT dependencies
   apt:
-    name: '{{ item }}'
+    name:
+      - 'python-apt'
+      - 'python-setuptools'
+      - 'git'
+      - 'crudini'
+      - 'expect'
+      - 'socat'
+      - 'qemu-system'
+      - 'build-essential'
     state: 'present'
     cache_valid_time: 3600
     install_recommends: False
-  with_items:
-    - 'python-apt'
-    - 'python-setuptools'
-    - 'git'
-    - 'crudini'
-    - 'expect'
-    - 'socat'
-    - 'qemu-system'
   tags: install-csit-dependencies
index 7ed9dae..8f0be43 100644 (file)
@@ -3,24 +3,23 @@
 
 - name: Install CSIT dependencies
   apt:
-    name: '{{ item }}'
+    name:
+      - 'dkms'
+      - 'pkg-config'
+      - 'libglib2.0-dev'
+      - 'autoconf'
+      - 'libtool'
+      - 'screen'
+      - 'libmbedcrypto1'
+      - 'libmbedtls10'
+      - 'libmbedx509-0'
+      - 'lxc'
+      - 'openjdk-8-jdk'
+      - 'libpixman-1-dev'
+      - 'python-cffi'
+      - 'python-cffi-backend'
+      - 'python3-cffi'
+      - 'python3-cffi-backend'
     state: 'present'
     install_recommends: False
-  with_items:
-    - 'dkms'
-    - 'pkg-config'
-    - 'libglib2.0-dev'
-    - 'autoconf'
-    - 'libtool'
-    - 'screen'
-    - 'libmbedcrypto1'
-    - 'libmbedtls10'
-    - 'libmbedx509-0'
-    - 'lxc'
-    - 'openjdk-8-jdk'
-    - 'libpixman-1-dev'
-    - 'python-cffi'
-    - 'python-cffi-backend'
-    - 'python3-cffi'
-    - 'python3-cffi-backend'
   tags: install-csit-dependencies
index f60aaee..27b8b72 100644 (file)
@@ -3,9 +3,8 @@
 
 - name: Install CSIT dependencies
   apt:
-    name: '{{ item }}'
+    name:
+      - 'unzip'
     state: 'present'
     install_recommends: False
-  with_items:
-    - 'unzip'
   tags: install-csit-dependencies
index 1ad96b2..d9026e9 100644 (file)
@@ -55,8 +55,7 @@
 
 - name: Install CSIT PIP requirements
   pip:
-    name: '{{ item }}'
-  with_items:
+    name:
       - 'docopt==0.6.2'
       - 'ecdsa==0.13'
       - 'enum34==1.1.2'
@@ -80,7 +79,8 @@
 
 - name: Install VPP PIP requirements
   pip:
-    name: 'aenum'
+    name:
+      - 'aenum==2.1.2'
   tags: install-pip
 
 - name: Load vfio-pci by default
index 1946097..fd08215 100644 (file)
@@ -3,22 +3,20 @@
 
 - name: Install CSIT dependencies
   apt:
-    name: '{{ item }}'
+    name:
+      - 'python-dev'
+      - 'python-virtualenv'
+      - 'python-pip'
+      - 'libpcap-dev'
+      - 'cpufrequtils'
+      - 'cgroup-bin'
+      - 'zlib1g-dev'
+      - 'apt-transport-https'
+      - 'ca-certificates'
+      - 'software-properties-common'
+      - 'libnuma-dev'
     state: 'present'
     install_recommends: False
-  with_items:
-    - 'python-dev'
-    - 'python-virtualenv'
-    - 'python-pip'
-    - 'libpcap-dev'
-    - 'cpufrequtils'
-    - 'cgroup-bin'
-    - 'zlib1g-dev'
-    - 'apt-transport-https'
-    - 'ca-certificates'
-    - 'software-properties-common'
-    - 'cron'
-    - 'libnuma-dev'
   tags: install-csit-dependencies
 
 - name: Add an Apt signing key, for docker-ce repository
 
 - name: Install Kubernetes
   apt:
-    name: '{{ item }}={{ kubernetes_apt_package_name }}'
+    name:
+      - 'kubeadm={{ kubernetes_apt_package_name }}'
+      - 'kubectl={{ kubernetes_apt_package_name }}'
+      - 'kubelet={{ kubernetes_apt_package_name }}'
     state: 'present'
     force: yes
-  with_items:
-    - 'kubeadm'
-    - 'kubectl'
-    - 'kubelet'
   tags: install-kubernetes
 
 - name: Apply kubelet parameter

©2016 FD.io a Linux Foundation Collaborative Project. All Rights Reserved.
Linux Foundation is a registered trademark of The Linux Foundation. Linux is a registered trademark of Linus Torvalds.
Please see our privacy policy and terms of use.