New upstream version 18.08
[deb_dpdk.git] / app / test-eventdev / meson.build
index 7c373c8..a81dcd1 100644 (file)
@@ -1,6 +1,7 @@
 # SPDX-License-Identifier: BSD-3-Clause
 # Copyright(c) 2017 Cavium, Inc
 
+allow_experimental_apis = true
 sources = files('evt_main.c',
                'evt_options.c',
                'evt_test.c',
@@ -11,19 +12,4 @@ sources = files('evt_main.c',
                'test_perf_common.c',
                'test_perf_atq.c',
                'test_perf_queue.c')
-
-dep_objs = [get_variable(get_option('default_library') + '_rte_eventdev')]
-dep_objs += cc.find_library('execinfo', required: false) # BSD only
-
-link_libs = []
-if get_option('default_library') == 'static'
-       link_libs = dpdk_drivers
-endif
-
-executable('dpdk-test-eventdev',
-       sources,
-       c_args: [machine_args, '-DALLOW_EXPERIMENTAL_API'],
-       link_whole: link_libs,
-       dependencies: dep_objs,
-       install_rpath: join_paths(get_option('prefix'), driver_install_path),
-       install: true)
+deps += 'eventdev'