New upstream version 18.05
[deb_dpdk.git] / app / test-pmd / meson.build
index 7ed74db..a51514b 100644 (file)
@@ -1,6 +1,9 @@
 # SPDX-License-Identifier: BSD-3-Clause
 # Copyright(c) 2017 Intel Corporation
 
+# override default name to drop the hyphen
+name = 'testpmd'
+allow_experimental_apis = true
 sources = files('cmdline.c',
        'cmdline_flow.c',
        'cmdline_mtr.c',
@@ -32,22 +35,10 @@ if dpdk_conf.has('RTE_LIBRTE_SOFTNIC_PMD')
        sources += files('tm.c')
        deps += 'pmd_softnic'
 endif
-
-dep_objs = []
-foreach d:deps
-       dep_objs += get_variable(get_option('default_library') + '_rte_' + d)
-endforeach
-dep_objs += cc.find_library('execinfo', required: false) # for BSD only
-
-link_libs = []
-if get_option('default_library') == 'static'
-       link_libs = dpdk_drivers
+if dpdk_conf.has('RTE_LIBRTE_DPAA_PMD')
+       deps += ['bus_dpaa', 'mempool_dpaa', 'pmd_dpaa']
+endif
+if dpdk_conf.has('RTE_LIBRTE_BPF')
+       sources += files('bpf_cmd.c')
+       deps += 'bpf'
 endif
-
-executable('dpdk-testpmd',
-       sources,
-       c_args: [machine_args, '-DALLOW_EXPERIMENTAL_API'],
-       link_whole: link_libs,
-       dependencies: dep_objs,
-       install_rpath: join_paths(get_option('prefix'), driver_install_path),
-       install: true)