New upstream version 18.08
[deb_dpdk.git] / app / test-pmd / meson.build
index 7ed74db..a0b3be0 100644 (file)
@@ -1,6 +1,10 @@
 # SPDX-License-Identifier: BSD-3-Clause
 # Copyright(c) 2017 Intel Corporation
 
+# override default name to drop the hyphen
+name = 'testpmd'
+allow_experimental_apis = true
+cflags += '-Wno-deprecated-declarations'
 sources = files('cmdline.c',
        'cmdline_flow.c',
        'cmdline_mtr.c',
@@ -22,6 +26,9 @@ deps = ['ethdev', 'gro', 'gso', 'cmdline', 'metrics', 'meter', 'bus_pci']
 if dpdk_conf.has('RTE_LIBRTE_PDUMP')
        deps += 'pdump'
 endif
+if dpdk_conf.has('RTE_LIBRTE_BNXT_PMD')
+       deps += 'pmd_bnxt'
+endif
 if dpdk_conf.has('RTE_LIBRTE_I40E_PMD')
        deps += 'pmd_i40e'
 endif
@@ -29,25 +36,13 @@ if dpdk_conf.has('RTE_LIBRTE_IXGBE_PMD')
        deps += 'pmd_ixgbe'
 endif
 if dpdk_conf.has('RTE_LIBRTE_SOFTNIC_PMD')
-       sources += files('tm.c')
+       sources += files('softnicfwd.c')
        deps += 'pmd_softnic'
 endif
-
-dep_objs = []
-foreach d:deps
-       dep_objs += get_variable(get_option('default_library') + '_rte_' + d)
-endforeach
-dep_objs += cc.find_library('execinfo', required: false) # for BSD only
-
-link_libs = []
-if get_option('default_library') == 'static'
-       link_libs = dpdk_drivers
+if dpdk_conf.has('RTE_LIBRTE_DPAA_PMD')
+       deps += ['bus_dpaa', 'mempool_dpaa', 'pmd_dpaa']
+endif
+if dpdk_conf.has('RTE_LIBRTE_BPF')
+       sources += files('bpf_cmd.c')
+       deps += 'bpf'
 endif
-
-executable('dpdk-testpmd',
-       sources,
-       c_args: [machine_args, '-DALLOW_EXPERIMENTAL_API'],
-       link_whole: link_libs,
-       dependencies: dep_objs,
-       install_rpath: join_paths(get_option('prefix'), driver_install_path),
-       install: true)