Note fuzz refresh in d/changelog
[deb_dpdk.git] / debian / rules
index 03d6e44..961fd50 100755 (executable)
@@ -4,12 +4,10 @@
 export DH_VERBOSE=1
 export DH_OPTIONS=-v
 
-VERSION := $(shell dpkg-parsechangelog | sed -nr '/^Version:/s/Version: (.*:)?(.*)-(.*)/\2/p')
-
 # see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
 include /usr/share/dpkg/default.mk
 
-DEB_HOST_GNU_CPU := $(shell dpkg-architecture -qDEB_HOST_GNU_CPU)
+DPDK_ABI := $(shell echo $(DEB_VERSION_UPSTREAM) | cut -d '-' -f1 | cut -d '.'  -f1-2 | cut -d '~' -f1)
 
 # see FEATURE AREAS in dpkg-buildflags(1)
 export DEB_BUILD_MAINT_OPTIONS = hardening=+all,-pie
@@ -37,6 +35,7 @@ ifeq (yes, $(dpkg_version_lt))
 endif
 
 export RTE_DEVEL_BUILD=n
+export EXTRA_CFLAGS+=-g
 
 # People rebuilding this package can overwrite DPDK_CONFIG, RTE_MACHINE and
 # RTE_TARGET via DEB_BUILD_OPTIONS if they like
@@ -54,15 +53,18 @@ ifneq (,$(filter $(DEB_HOST_ARCH), arm64))
 DPDK_CONFIG ?= "arm64-armv8a-linuxapp-gcc"
 RTE_MACHINE ?= "armv8a"
 RTE_TARGET ?= "arm64-armv8a-linuxapp-gcc"
+INCLUDE_ARCH := arm
 else
 ifneq (,$(filter $(DEB_HOST_ARCH), ppc64el))
 DPDK_CONFIG ?= "ppc_64-power8-linuxapp-gcc"
 RTE_MACHINE ?= "power8"
 RTE_TARGET ?= "ppc_64-power8-linuxapp-gcc"
+INCLUDE_ARCH := ppc_64
 else
 DPDK_CONFIG ?= "$(DEB_HOST_GNU_CPU)-native-linuxapp-gcc"
 RTE_MACHINE ?= "default"
 RTE_TARGET ?= "$(DEB_HOST_GNU_CPU)-default-linuxapp-gcc"
+INCLUDE_ARCH := x86
 endif
 endif
 DPDK_STATIC_DIR = "debian/build/static-root"
@@ -71,8 +73,19 @@ DPDK_SHARED_DIR = "debian/build/shared-root"
 # now stable with parallel comilation, so support -j
 ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
     PAR := $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+    MAKEFLAGS += -j$(PAR)
+endif
+
+ifneq (,$(findstring nodoc,$(DEB_BUILD_OPTIONS)))
+BUILD_DOCS=n
 else
-    PAR := "1"
+BUILD_DOCS=y
+endif
+
+ifneq (,$(findstring nostatic,$(DEB_BUILD_OPTIONS)))
+BUILD_STATIC_LIB=n
+else
+BUILD_STATIC_LIB=y
 endif
 
 # kernel_modules can be passed via DEB_BUILD_OPTIONS to enable building the
@@ -101,12 +114,6 @@ DPDK_CONFIG_BUILD_KMOD=y
 # dpkg-genchanges, and also would require a lot of overrides for debhelpers.
 get_built_using        ?= $(filter-out (=),$(shell dpkg-query -f='$${source:Package} (=$${source:Version})' -W $1))
 
-override_dh_gencontrol:
-       dh_gencontrol
-       dh_gencontrol -p dpdk-modules-$(KVERS) -- \
-               -v`cat debian/VERSION` \
-               -V'built:using:kernel=$(call get_built_using,linux-headers-$(KVERS))'
-
 build:
        @if [ x"$(KVERS)" = x ] ; then \
            echo 'No version in $(KSRC)/include/linux/version.h' >&2; \
@@ -114,23 +121,49 @@ build:
        fi
        sh debian/prep-modules $(KSRC)
        cat debian/control.modules >> debian/control
-       dh $@ --with python2,dkms
+       dh $@ --with python2,dkms,systemd
 endif
 
 %:
-       dh $@ --with python2,dkms
+       dh $@ --with python2,dkms,systemd
+
+override_dh_gencontrol:
+       dh_gencontrol
+       # debian/files will not exist until dh_gencontrol has ran at least once,
+       # so we need to run gencontrol for libdpdk-dev and libdpdk-dbgsym after.
+       # The list of libraries and PMDs is everchanging, so generate the dependency
+       # list for libdpdk-dev to avoid having to maintain it manually.
+       # Same for the recommends list for dpdk, were we want the PMDs and the mempools.
+       dh_gencontrol -p libdpdk-dev -- -V"librte:Depends=`grep -E 'librte-*' ./debian/files | grep -v dbgsym | tr '_' ' ' | awk '{ print $$1,"(=",$$2 ")" }' | paste -sd ',' - | sed -e 's/,/, /g'`"
+       dh_gencontrol -p dpdk -- -V"librte:Recommends=`grep -E 'librte-(pmd|mempool).*' ./debian/files | grep -v dbgsym | tr '_' ' ' | awk '{ print $$1,"(=",$$2 ")" }' | paste -sd ',' - | sed -e 's/,/, /g'`"
+ifneq (,$(findstring kernel_modules,$(DEB_BUILD_OPTIONS)))
+       dh_gencontrol -p dpdk-modules-$(KVERS) -- \
+               -v`cat debian/VERSION` \
+               -V'built:using:kernel=$(call get_built_using,linux-headers-$(KVERS))'
+endif
+ifneq (,$(findstring dbgsym_meta,$(DEB_BUILD_OPTIONS)))
+       ./debian/dh-dbgsym-metapkg libdpdk$(DPDK_ABI)-dbgsym
+endif
+
+# dbgsym_meta can be passed via DEB_BUILD_OPTIONS to enable building the
+# optional dbgsym meta package libdpdk<ABI>-dbgsym.
+# This is not built by default as it would go in main but depend on
+# packages in the debian-debug archive.
+# Debian Developers and FTP masters strongly discourage this.
+# We provide this optional flag as a convenience for rebuilders.
+ifneq (,$(findstring dbgsym_meta,$(DEB_BUILD_OPTIONS)))
+override_dh_builddeb:
+       dh_builddeb
+       dh_builddeb -plibdpdk$(DPDK_ABI)-dbgsym
+endif
 
 override_dh_auto_clean:
        rm -rf debian/build debian/tmp debian/dpdk-modules-* \
                debian/control.modules debian/VERSION
        sed -i '/Package: dpdk-modules-/,/`tail -n1 debian/control.modules.in`/d' debian/control
        test -L config/defconfig_$(DPDK_CONFIG) && rm -f config/defconfig_$(DPDK_CONFIG) || true
-
-override_dh_clean:
-       dh_clean
-       rm -f debian/libethdev4.links
-       rm -f debian/librte-cryptodev1.links
-       rm -f debian/librte-eal2.links
+       rm -f debian/dpdk-igb-uio-dkms.dkms debian/dpdk-rte-kni-dkms.dkms
+       rm -f debian/dpdk-dev.preinst
 
 override_dh_auto_configure:
        # Add support for a custom defconfig file in the debian directory.
@@ -149,7 +182,7 @@ ifeq (,$(filter dpdk_config=%,$(DEB_BUILD_OPTIONS)))
                -e 's,(CONFIG_RTE_KNI_KMOD=).*,\1$(DPDK_CONFIG_BUILD_KMOD),' \
                -e 's,(LIBRTE_PMD_PCAP=).*,\1y,' \
                -e 's,(LIBRTE_PMD_XENVIRT=).*,\1y,' \
-               -e 's,(CONFIG_RTE_EAL_PMD_PATH=).*,\1"/usr/lib/$(shell dpkg-architecture -qDEB_HOST_MULTIARCH)/dpdk-pmds/",' \
+               -e 's,(CONFIG_RTE_EAL_PMD_PATH=).*,\1"/usr/lib/$(DEB_HOST_MULTIARCH)/dpdk-pmds/",' \
                $(DPDK_STATIC_DIR)/.config
        # xen not available on ppc64el
 ifneq (,$(filter $(DEB_HOST_ARCH), ppc64el))
@@ -159,17 +192,22 @@ endif
        dh_auto_configure
 
 override_dh_auto_build-indep:
-       $(MAKE) -j $(PAR) V=$(DH_VERBOSE) O=$(DPDK_STATIC_DIR) doc-api-html doc-guides-html \
-               doc-guides-man
+ifeq (y,$(BUILD_DOCS))
+       $(MAKE) V=$(DH_VERBOSE) O=$(DPDK_STATIC_DIR) doc-api-html doc-guides-html
+endif
 
 override_dh_auto_install-indep:
        # Package: dpdk-doc
        # All files based on the install-doc rule (includes examples)
+ifeq (y,$(BUILD_DOCS))
        $(MAKE) V=$(DH_VERBOSE) O=$(DPDK_STATIC_DIR) prefix=/usr \
                DESTDIR=debian/dpdk-doc install-doc
+endif
 
 override_dh_auto_build-arch:
-       $(MAKE) -j $(PAR) V=$(DH_VERBOSE) O=$(DPDK_STATIC_DIR) RTE_KERNELDIR=$(KSRC) build
+ifeq (y,$(BUILD_STATIC_LIB))
+       $(MAKE) V=$(DH_VERBOSE) O=$(DPDK_STATIC_DIR) RTE_KERNELDIR=$(KSRC) build
+endif
        # Unfortunately the decision about having static or shared libraries is
        # made for the whole build, which then produces only .a or .so files
        # (but not both).
@@ -182,13 +220,19 @@ override_dh_auto_build-arch:
        cp -a $(DPDK_STATIC_DIR) $(DPDK_SHARED_DIR)
        sed -ri 's,(RTE_BUILD_SHARED_LIB=).*,\1y,' \
                $(DPDK_SHARED_DIR)/.config
-       $(MAKE) -j $(PAR) V=$(DH_VERBOSE) O=$(DPDK_SHARED_DIR) RTE_KERNELDIR=$(KSRC) build
+       $(MAKE) V=$(DH_VERBOSE) O=$(DPDK_SHARED_DIR) RTE_KERNELDIR=$(KSRC) build
+ifeq (y,$(BUILD_DOCS))
+       # need to be around for dh_installman to be picked up
+       $(MAKE) V=$(DH_VERBOSE) O=$(DPDK_SHARED_DIR) RTE_KERNELDIR=$(KSRC) doc-guides-man
+endif
 
-override_dh_auto_install-arch: LIBDIR=/usr/lib/$(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+override_dh_auto_install-arch: LIBDIR=/usr/lib/$(DEB_HOST_MULTIARCH)
 override_dh_auto_install-arch:
        # Package: dpdk (runtime)
+ifeq (y,$(BUILD_STATIC_LIB))
        $(MAKE) V=$(DH_VERBOSE) O=$(DPDK_STATIC_DIR) prefix=/usr libdir=$(LIBDIR) \
                DESTDIR=debian/dpdk install-runtime
+endif
        $(MAKE) V=$(DH_VERBOSE) O=$(DPDK_SHARED_DIR) prefix=/usr libdir=$(LIBDIR) \
                DESTDIR=debian/dpdk install-runtime
        mkdir -p debian/dpdk/etc/dpdk
@@ -221,10 +265,38 @@ override_dh_auto_install-arch:
        # linker script
        mv debian/dpdk/$(LIBDIR)/libdpdk.so debian/libdpdk-dev/$(LIBDIR)/
        # includes
-       mkdir -p debian/libdpdk-dev/usr/include
+       # Some headers have architecture-specific content, but the upstream build
+       # system installs them in the same directory, breaking multiarch.
+       # Move them in /usr/include/<arch>/dpdk instead.
+       mkdir -p debian/libdpdk-dev/usr/include/$(DEB_HOST_MULTIARCH)/dpdk
+       # Before moving the files, remove the symlink in usr/share/dpdk and copy them over,
+       # as the SDK subdir is architecture specific and requires the arch-specific headers
+       # in the top level
+       rm -f debian/dpdk-dev/usr/share/dpdk/$(RTE_TARGET)/include
+       mkdir -p debian/dpdk-dev/usr/share/dpdk/$(RTE_TARGET)/include
+       cp -r debian/dpdk-dev/usr/include/dpdk/* debian/dpdk-dev/usr/share/dpdk/$(RTE_TARGET)/include
+       # genereate the preinst to deal with the symlink -> directory transition smoothly
+       sed "s/@@RTE_TARGET@@/$(RTE_TARGET)/g" debian/dpdk-dev.preinst.in > debian/dpdk-dev.preinst
+       mv $(addprefix debian/dpdk-dev/usr/include/dpdk/,$(notdir $(wildcard lib/librte_eal/common/include/arch/$(INCLUDE_ARCH)/*.h))) \
+               debian/libdpdk-dev/usr/include/$(DEB_HOST_MULTIARCH)/dpdk/
+       mv debian/dpdk-dev/usr/include/dpdk/rte_config.h \
+               debian/libdpdk-dev/usr/include/$(DEB_HOST_MULTIARCH)/dpdk/
        mv debian/dpdk-dev/usr/include/dpdk debian/libdpdk-dev/usr/include/
+       rmdir debian/dpdk-dev/usr/include
+       # backward compatibility: to ease things for the majority of users,
+       # which are on x86_64, symlink the x86 headers into the global
+       # directory.
+ifeq (x86_64-linux-gnu,$(DEB_HOST_MULTIARCH))
+       ln -rs debian/libdpdk-dev/usr/include/$(DEB_HOST_MULTIARCH)/dpdk/*.h \
+               debian/libdpdk-dev/usr/include/dpdk
+endif
+       # have the DKMS build include the correct per-arch directory
+       sed "s/@@DEB_HOST_MULTIARCH@@/$(DEB_HOST_MULTIARCH)/g" debian/dpdk-igb-uio-dkms.dkms.in > debian/dpdk-igb-uio-dkms.dkms
+       sed "s/@@DEB_HOST_MULTIARCH@@/$(DEB_HOST_MULTIARCH)/g" debian/dpdk-rte-kni-dkms.dkms.in > debian/dpdk-rte-kni-dkms.dkms
        # all static libs are in the dev package
+ifeq (y,$(BUILD_STATIC_LIB))
        mv debian/dpdk/$(LIBDIR)/lib*.a debian/libdpdk-dev/$(LIBDIR)/
+endif
        # symlinks to last .so's are in the non versioned libdpdk-dev as well
        # this allows multiple libdpdk-<NAME><VER> at different VER concurrently
        # libdpdk-dev depends on all sublibs so symlinks are never broken
@@ -249,6 +321,11 @@ override_dh_auto_install-arch:
            echo "PMD: linking $${LIBF} into RTE_EAL_PMD_PATH at $${LIBD}/dpdk-pmds/"; \
            ln -s --relative --target-directory=$${LIBD}/dpdk-pmds/ $${LIBD}/$${LIBF}; \
          fi; \
+         if [ "$${LIBF#librte_mempool_}x" != "$${LIBF}x" ]; then \
+           mkdir -p $${LIBD}/dpdk-pmds; \
+           echo "MEMPOOL: linking $${LIBF} into RTE_EAL_PMD_PATH at $${LIBD}/dpdk-pmds/"; \
+           ln -s --relative --target-directory=$${LIBD}/dpdk-pmds/ $${LIBD}/$${LIBF}; \
+         fi; \
          if [ "$${LIBF#librte_eal}x" != "$${LIBF}x" ]; then \
            mkdir -p $${LIBD}/dpdk-pmds; \
          fi; \
@@ -257,34 +334,26 @@ override_dh_auto_install-arch:
        mkdir -p debian/libdpdk-dev/$(LIBDIR)/pkgconfig
        LIBS=$$(sed -e 's/GROUP ( \(.*\) )/\1/' -e 's/lib/-l/g' -e 's/\.so//g' \
                $(CURDIR)/debian/libdpdk-dev/$(LIBDIR)/libdpdk.so); \
-       sed -e "s/@DPDK_LIBS@/$${LIBS}/" -e "s/@VERSION@/$(VERSION)/" \
-               -e "s|@LIBDIR@|$(LIBDIR)|" \
+       sed -e "s/@DPDK_LIBS@/$${LIBS}/" -e "s/@VERSION@/$(DEB_VERSION_UPSTREAM)/" \
+               -e "s|@DEB_HOST_MULTIARCH@|$(DEB_HOST_MULTIARCH)|g" \
                debian/libdpdk.pc.in > debian/libdpdk-dev/$(LIBDIR)/pkgconfig/libdpdk.pc
        # Package: dpdk-igb-uio-dkms
-       mkdir -p debian/dpdk-igb-uio-dkms/usr/src/dpdk-igb-uio-$(VERSION)
+       mkdir -p debian/dpdk-igb-uio-dkms/usr/src/dpdk-igb-uio-$(DEB_VERSION_UPSTREAM)
        cp lib/librte_eal/linuxapp/igb_uio/* \
-               debian/dpdk-igb-uio-dkms/usr/src/dpdk-igb-uio-$(VERSION)
+               debian/dpdk-igb-uio-dkms/usr/src/dpdk-igb-uio-$(DEB_VERSION_UPSTREAM)
        # Package: dpdk-rte-kni-dkms
-       mkdir -p debian/dpdk-rte-kni-dkms/usr/src/dpdk-rte-kni-$(VERSION)
+       mkdir -p debian/dpdk-rte-kni-dkms/usr/src/dpdk-rte-kni-$(DEB_VERSION_UPSTREAM)
        cp -a lib/librte_eal/linuxapp/kni/* \
-               debian/dpdk-rte-kni-dkms/usr/src/dpdk-rte-kni-$(VERSION)
+               debian/dpdk-rte-kni-dkms/usr/src/dpdk-rte-kni-$(DEB_VERSION_UPSTREAM)
 ifneq (,$(KVERS))
        # Package: dpdk-modules-<kernel version>
        $(MAKE) V=$(DH_VERBOSE) O=$(DPDK_SHARED_DIR) \
+               kerneldir=/lib/modules/$(KVERS)/extra/dpdk \
                DESTDIR=debian/dpdk-modules-$(KVERS) install-kmod
 endif
 
-debian/libethdev4.links: debian/libethdev4.links.in
-       sed -e 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' < $< > $@
-debian/librte-cryptodev1.links: debian/librte-cryptodev1.links.in
-       sed -e 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' < $< > $@
-debian/librte-eal2.links: debian/librte-eal2.links.in
-       sed -e 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' < $< > $@
-override_dh_link: debian/libethdev4.links debian/librte-cryptodev1.links debian/librte-eal2.links
-       dh_link
-
 override_dh_dkms:
-       dh_dkms -V $(VERSION)
+       dh_dkms -V $(DEB_VERSION_UPSTREAM)
 
 override_dh_installinit:
        dh_installinit --no-start --no-restart-on-upgrade