Note fuzz refresh in d/changelog
[deb_dpdk.git] / debian / rules
index 2953c40..961fd50 100755 (executable)
@@ -7,7 +7,7 @@ export DH_OPTIONS=-v
 # see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
 include /usr/share/dpkg/default.mk
 
-DPDK_ABI := $(shell echo $(DEB_VERSION_UPSTREAM) | cut -d '-' -f1 | cut -d '.'  -f1-2)
+DPDK_ABI := $(shell echo $(DEB_VERSION_UPSTREAM) | cut -d '-' -f1 | cut -d '.'  -f1-2 | cut -d '~' -f1)
 
 # see FEATURE AREAS in dpkg-buildflags(1)
 export DEB_BUILD_MAINT_OPTIONS = hardening=+all,-pie
@@ -356,10 +356,10 @@ override_dh_dkms:
        dh_dkms -V $(DEB_VERSION_UPSTREAM)
 
 override_dh_installinit:
-       dh_installinit --no-start --no-stop-on-upgrade
+       dh_installinit --no-start --no-restart-on-upgrade
 
 override_dh_systemd_start:
-       dh_systemd_start --no-start --no-stop-on-upgrade
+       dh_systemd_start --no-start --no-restart-on-upgrade
 
 override_dh_auto_test: