Note fuzz refresh in d/changelog
[deb_dpdk.git] / debian / rules
index 952cac6..961fd50 100755 (executable)
@@ -7,7 +7,7 @@ export DH_OPTIONS=-v
 # see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
 include /usr/share/dpkg/default.mk
 
-DPDK_ABI := $(shell echo $(DEB_VERSION_UPSTREAM) | cut -d '-' -f1 | cut -d '.'  -f1-2)
+DPDK_ABI := $(shell echo $(DEB_VERSION_UPSTREAM) | cut -d '-' -f1 | cut -d '.'  -f1-2 | cut -d '~' -f1)
 
 # see FEATURE AREAS in dpkg-buildflags(1)
 export DEB_BUILD_MAINT_OPTIONS = hardening=+all,-pie
@@ -121,11 +121,11 @@ build:
        fi
        sh debian/prep-modules $(KSRC)
        cat debian/control.modules >> debian/control
-       dh $@ --with python3,dkms,systemd
+       dh $@ --with python2,dkms,systemd
 endif
 
 %:
-       dh $@ --with python3,dkms,systemd
+       dh $@ --with python2,dkms,systemd
 
 override_dh_gencontrol:
        dh_gencontrol