New upstream version 18.08
[deb_dpdk.git] / drivers / crypto / qat / meson.build
index 7b90463..9cc98d2 100644 (file)
@@ -1,14 +1,18 @@
 # SPDX-License-Identifier: BSD-3-Clause
-# Copyright(c) 2017 Intel Corporation
+# Copyright(c) 2017-2018 Intel Corporation
 
+# this does not build the QAT driver, instead that is done in the compression
+# driver which comes later. Here we just add our sources files to the list
+build = false
 dep = dependency('libcrypto', required: false)
-if not dep.found()
-       build = false
+qat_includes += include_directories('.')
+qat_deps += 'cryptodev'
+if dep.found()
+       # Add our sources files to the list
+       qat_sources += files('qat_sym_pmd.c',
+                            'qat_sym.c',
+                            'qat_sym_session.c')
+       qat_ext_deps += dep
+       pkgconfig_extra_libs += '-lcrypto'
+       qat_cflags += '-DBUILD_QAT_SYM'
 endif
-sources = files('qat_crypto.c', 'qat_qp.c',
-               'qat_adf/qat_algs_build_desc.c',
-               'rte_qat_cryptodev.c')
-includes += include_directories('qat_adf')
-deps += ['bus_pci']
-ext_deps += dep
-pkgconfig_extra_libs += '-lcrypto'