New upstream version 18.08
[deb_dpdk.git] / drivers / net / i40e / meson.build
index 8764b0e..d783f36 100644 (file)
@@ -1,10 +1,13 @@
 # SPDX-License-Identifier: BSD-3-Clause
 # Copyright(c) 2017 Intel Corporation
 
+version = 2
+
 cflags += ['-DPF_DRIVER',
        '-DVF_DRIVER',
        '-DINTEGRATED_VF',
-       '-DX722_A0_SUPPORT']
+       '-DX722_A0_SUPPORT',
+       '-DALLOW_EXPERIMENTAL_API']
 
 subdir('base')
 objs = [base_objs]
@@ -17,10 +20,12 @@ sources = files(
        'i40e_fdir.c',
        'i40e_flow.c',
        'i40e_tm.c',
+       'i40e_vf_representor.c',
        'rte_pmd_i40e.c'
        )
 
 deps += ['hash']
+includes += include_directories('base')
 
 if arch_subdir == 'x86'
        dpdk_conf.set('RTE_LIBRTE_I40E_INC_VECTOR', 1)
@@ -36,11 +41,10 @@ if arch_subdir == 'x86'
                                'i40e_rxtx_vec_avx2.c',
                                dependencies: [static_rte_ethdev,
                                        static_rte_kvargs, static_rte_hash],
-                               c_args: '-mavx2')
+                               include_directories: includes,
+                               c_args: [cflags, '-mavx2'])
                objs += i40e_avx2_lib.extract_objects('i40e_rxtx_vec_avx2.c')
        endif
 endif
 
-includes += include_directories('base')
-
 install_headers('rte_pmd_i40e.h')