New upstream version 18.02
[deb_dpdk.git] / drivers / net / ixgbe / meson.build
diff --git a/drivers/net/ixgbe/meson.build b/drivers/net/ixgbe/meson.build
new file mode 100644 (file)
index 0000000..60af0ba
--- /dev/null
@@ -0,0 +1,32 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
+
+cflags += ['-DRTE_LIBRTE_IXGBE_BYPASS']
+
+subdir('base')
+objs = [base_objs]
+
+allow_experimental_apis = true
+sources = files(
+       'ixgbe_82599_bypass.c',
+       'ixgbe_bypass.c',
+       'ixgbe_ethdev.c',
+       'ixgbe_fdir.c',
+       'ixgbe_flow.c',
+       'ixgbe_ipsec.c',
+       'ixgbe_pf.c',
+       'ixgbe_rxtx.c',
+       'ixgbe_tm.c',
+       'rte_pmd_ixgbe.c'
+)
+
+deps += ['hash', 'security']
+
+if arch_subdir == 'x86'
+       dpdk_conf.set('RTE_IXGBE_INC_VECTOR', 1)
+       sources += files('ixgbe_rxtx_vec_sse.c')
+endif
+
+includes += include_directories('base')
+
+install_headers('rte_pmd_ixgbe.h')