New upstream version 18.08
[deb_dpdk.git] / drivers / net / meson.build
index 704cbe3..9c28ed4 100644 (file)
@@ -1,10 +1,33 @@
 # SPDX-License-Identifier: BSD-3-Clause
 # Copyright(c) 2017 Intel Corporation
 
-drivers = ['af_packet', 'bonding',
-       'e1000', 'fm10k', 'i40e', 'ixgbe',
+drivers = ['af_packet',
+       'ark',
+       'avp',
+       'axgbe', 'bonding',
+       'bnx2x',
+       'bnxt',
+       'cxgbe',
+       'dpaa', 'dpaa2',
+       'e1000',
+       'ena',
+       'enic',
+       'failsafe',
+       'fm10k', 'i40e',
+       'ifc',
+       'ixgbe',
+       'kni',
+       'liquidio',
+       'mvpp2',
+       'netvsc',
+       'nfp',
        'null', 'octeontx', 'pcap', 'ring',
-       'sfc', 'thunderx']
+       'sfc',
+       'softnic',
+       'szedata2',
+       'thunderx',
+       'vhost',
+       'virtio']
 std_deps = ['ethdev', 'kvargs'] # 'ethdev' also pulls in mbuf, net, eal etc
 std_deps += ['bus_pci']         # very many PMDs depend on PCI, so make std
 std_deps += ['bus_vdev']        # same with vdev bus