New upstream version 18.11-rc1
[deb_dpdk.git] / drivers / net / nfp / meson.build
index 3ba37e2..ba6a22e 100644 (file)
@@ -1,6 +1,9 @@
 # SPDX-License-Identifier: BSD-3-Clause
 # Copyright(c) 2018 Intel Corporation
 
+if host_machine.system() != 'linux'
+        build = false
+endif
 sources = files('nfpcore/nfp_cpp_pcie_ops.c',
        'nfpcore/nfp_nsp.c',
        'nfpcore/nfp_cppcore.c',
@@ -14,3 +17,5 @@ sources = files('nfpcore/nfp_cpp_pcie_ops.c',
        'nfpcore/nfp_nsp_eth.c',
        'nfpcore/nfp_hwinfo.c',
        'nfp_net.c')
+
+allow_experimental_apis = true