New upstream version 18.08
[deb_dpdk.git] / drivers / net / sfc / meson.build
index b60a8f5..2d34e86 100644 (file)
@@ -6,7 +6,7 @@
 # This software was jointly developed between OKTET Labs (under contract
 # for Solarflare) and Solarflare Communications, Inc.
 
-if arch_subdir != 'x86'
+if arch_subdir != 'x86' or cc.sizeof('void *') == 4
        build = false
 endif
 
@@ -30,10 +30,6 @@ extra_flags += [
        '-Wbad-function-cast'
 ]
 
-# Suppress ICC false positive warning on 'bulk' may be used before its
-# value is set
-extra_flags += '-wd3656'
-
 foreach flag: extra_flags
        if cc.has_argument(flag)
                cflags += flag
@@ -58,6 +54,7 @@ sources = files(
        'sfc_flow.c',
        'sfc_dp.c',
        'sfc_ef10_rx.c',
+       'sfc_ef10_essb_rx.c',
        'sfc_ef10_tx.c'
 )