New upstream version 18.11-rc1
[deb_dpdk.git] / drivers / net / thunderx / base / meson.build
index c9d5a8f..bf4e860 100644 (file)
@@ -7,8 +7,12 @@ sources = [
        'nicvf_bsvf.c'
 ]
 
+c_args = cflags
+if allow_experimental_apis
+       c_args += '-DALLOW_EXPERIMENTAL_API'
+endif
 base_lib = static_library('nicvf_base', sources,
-       c_args: cflags,
+       c_args: c_args,
        dependencies: static_rte_ethdev
 )