New upstream version 18.08
[deb_dpdk.git] / examples / l3fwd-power / meson.build
index 61e8daa..20c8054 100644 (file)
@@ -1,12 +1,15 @@
 # SPDX-License-Identifier: BSD-3-Clause
-# Copyright(c) 2017 Intel Corporation
+# Copyright(c) 2018 Intel Corporation
 
 # meson file, for building this example as part of a main DPDK build.
 #
 # To build this example as a standalone application with an already-installed
 # DPDK instance, use 'make'
 
+if host_machine.system() != 'linux'
+       build = false
+endif
 deps += ['power', 'timer', 'lpm', 'hash']
 sources = files(
-       'main.c'
+       'main.c', 'perf_core.c'
 )