New upstream version 18.11-rc1
[deb_dpdk.git] / lib / librte_eal / common / meson.build
index 56005be..2a10d57 100644 (file)
@@ -14,6 +14,7 @@ common_sources = files(
        'eal_common_errno.c',
        'eal_common_fbarray.c',
        'eal_common_hexdump.c',
+       'eal_common_hypervisor.c',
        'eal_common_launch.c',
        'eal_common_lcore.c',
        'eal_common_log.c',
@@ -27,11 +28,13 @@ common_sources = files(
        'eal_common_thread.c',
        'eal_common_timer.c',
        'eal_common_uuid.c',
+       'hotplug_mp.c',
        'malloc_elem.c',
        'malloc_heap.c',
        'malloc_mp.c',
        'rte_keepalive.c',
        'rte_malloc.c',
+       'rte_option.c',
        'rte_reciprocal.c',
        'rte_service.c'
 )
@@ -59,6 +62,7 @@ common_headers = files(
        'include/rte_errno.h',
        'include/rte_fbarray.h',
        'include/rte_hexdump.h',
+       'include/rte_hypervisor.h',
        'include/rte_interrupts.h',
        'include/rte_keepalive.h',
        'include/rte_launch.h',
@@ -68,6 +72,7 @@ common_headers = files(
        'include/rte_malloc_heap.h',
        'include/rte_memory.h',
        'include/rte_memzone.h',
+       'include/rte_option.h',
        'include/rte_pci_dev_feature_defs.h',
        'include/rte_pci_dev_features.h',
        'include/rte_per_lcore.h',