New upstream version 18.08
[deb_dpdk.git] / lib / librte_eal / linuxapp / eal / meson.build
index 03974ff..6e31c2a 100644 (file)
@@ -7,9 +7,11 @@ install_subdir('include/exec-env', install_dir: get_option('includedir'))
 env_objs = []
 env_headers = []
 env_sources = files('eal_alarm.c',
+               'eal_cpuflags.c',
                'eal_debug.c',
                'eal_hugepage_info.c',
                'eal_interrupts.c',
+               'eal_memalloc.c',
                'eal_lcore.c',
                'eal_log.c',
                'eal_thread.c',
@@ -18,8 +20,10 @@ env_sources = files('eal_alarm.c',
                'eal_vfio_mp_sync.c',
                'eal.c',
                'eal_memory.c',
+               'eal_dev.c',
 )
 
+deps += ['kvargs']
 if has_libnuma == 1
        dpdk_conf.set10('RTE_EAL_NUMA_AWARE_HUGEPAGES', true)
 endif