New upstream version 18.02
[deb_dpdk.git] / lib / librte_hash / meson.build
diff --git a/lib/librte_hash/meson.build b/lib/librte_hash/meson.build
new file mode 100644 (file)
index 0000000..e139e1d
--- /dev/null
@@ -0,0 +1,17 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
+
+version = 2
+headers = files('rte_cmp_arm64.h',
+       'rte_cmp_x86.h',
+       'rte_crc_arm64.h',
+       'rte_cuckoo_hash.h',
+       'rte_cuckoo_hash_x86.h',
+       'rte_fbk_hash.h',
+       'rte_hash_crc.h',
+       'rte_hash.h',
+       'rte_jhash.h',
+       'rte_thash.h')
+
+sources = files('rte_cuckoo_hash.c', 'rte_fbk_hash.c')
+deps += ['ring']