New upstream version 18.02
[deb_dpdk.git] / lib / librte_kni / meson.build
diff --git a/lib/librte_kni/meson.build b/lib/librte_kni/meson.build
new file mode 100644 (file)
index 0000000..c4b2196
--- /dev/null
@@ -0,0 +1,10 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
+
+if host_machine.system() != 'linux'
+       build = false
+endif
+version = 2
+sources = files('rte_kni.c')
+headers = files('rte_kni.h')
+deps += ['ethdev', 'pci']