New upstream version 18.11-rc1
[deb_dpdk.git] / lib / librte_vhost / meson.build
index bd62e0e..e33e6fc 100644 (file)
@@ -7,8 +7,11 @@ endif
 if has_libnuma == 1
        dpdk_conf.set10('RTE_LIBRTE_VHOST_NUMA', true)
 endif
+dpdk_conf.set('RTE_LIBRTE_VHOST_POSTCOPY',
+             cc.has_header('linux/userfaultfd.h'))
 version = 4
 allow_experimental_apis = true
+cflags += '-fno-strict-aliasing'
 sources = files('fd_man.c', 'iotlb.c', 'socket.c', 'vdpa.c',
                'vhost.c', 'vhost_user.c',
                'virtio_net.c', 'vhost_crypto.c')