New upstream version 18.08
[deb_dpdk.git] / lib / meson.build
index ef61591..eb91f10 100644 (file)
@@ -9,22 +9,27 @@
 # given as a dep, no need to mention ring. This is especially true for the
 # core libs which are widely reused, so their deps are kept to a minimum.
 libraries = [ 'compat', # just a header, used for versioning
-       'eal', 'ring', 'mempool', 'mbuf', 'net', 'ether', 'pci', # core
+       'kvargs',
+       'eal', 'ring', 'mempool', 'mbuf', 'net', 'ethdev', 'pci', # core
        'metrics', # bitrate/latency stats depends on this
        'hash',    # efd depends on this
-       'kvargs',  # cryptodev depends on this
+       'timer',   # eventdev depends on this
        'acl', 'bbdev', 'bitratestats', 'cfgfile',
-       'cmdline', 'cryptodev',
+       'cmdline', 'compressdev', 'cryptodev',
        'distributor', 'efd', 'eventdev',
        'gro', 'gso', 'ip_frag', 'jobstats',
        'kni', 'latencystats', 'lpm', 'member',
-       'meter', 'power', 'pdump',
-       'reorder', 'sched', 'security', 'timer', 'vhost',
+       'meter', 'power', 'pdump', 'rawdev',
+       'reorder', 'sched', 'security', 'vhost',
        # add pkt framework libs which use other libs from above
        'port', 'table', 'pipeline',
        # flow_classify lib depends on pkt framework table lib
-       'flow_classify']
+       'flow_classify', 'bpf']
 
+default_cflags = machine_args
+if cc.has_argument('-Wno-format-truncation')
+       default_cflags += '-Wno-format-truncation'
+endif
 foreach l:libraries
        build = true
        name = l
@@ -33,7 +38,7 @@ foreach l:libraries
        sources = []
        headers = []
        includes = []
-       cflags = machine_args
+       cflags = default_cflags
        objs = [] # other object files to link against, used e.g. for
                  # instruction-set optimized versions of code
 
@@ -41,9 +46,12 @@ foreach l:libraries
        # external package/library requirements
        ext_deps = []
        deps = ['eal']   # eal is standard dependency except for itself
-       if l == 'eal'
+       if l == 'kvargs'
                deps = []
        endif
+       if l == 'eal'
+               deps = ['kvargs']
+       endif
 
        dir_name = 'librte_' + l
        subdir(dir_name)
@@ -63,6 +71,10 @@ foreach l:libraries
                        shared_deps = ext_deps
                        static_deps = ext_deps
                        foreach d:deps
+                               if not is_variable('shared_rte_' + d)
+                                       error('Missing dependency ' + d +
+                                               ' for library ' + lib_name)
+                               endif
                                shared_deps += [get_variable('shared_rte_' + d)]
                                static_deps += [get_variable('static_rte_' + d)]
                        endforeach
@@ -95,7 +107,7 @@ foreach l:libraries
 
                        # then use pre-build objects to build shared lib
                        sources = []
-                       objs += static_lib.extract_all_objects()
+                       objs += static_lib.extract_all_objects(recursive: false)
                        version_map = '@0@/@1@/rte_@2@_version.map'.format(
                                        meson.current_source_dir(), dir_name, name)
                        shared_lib = shared_library(libname,