quic: quicly v0.1.2 update
[vpp.git] / build / external / packages / quicly.mk
index e4926a6..d1fffc9 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (c) 2019 Cisco and/or its affiliates.
+# Copyright (c) 2021 Cisco and/or its affiliates.
 # Licensed under the Apache License, Version 2.0 (the "License");
 # you may not use this file except in compliance with the License.
 # You may obtain a copy of the License at:
@@ -11,9 +11,9 @@
 # See the License for the specific language governing permissions and
 # limitations under the License.
 
-quicly_version := 0.0.3-vpp
+quicly_version := 0.1.2-vpp
 quicly_tarball := quicly_$(quicly_version).tar.gz
-quicly_tarball_md5sum := fa4be6d9039967b380bbf14c96e34cdc
+quicly_tarball_md5sum := 5b184b1733ba027843ab6605d931f752
 quicly_tarball_strip_dirs := 1
 quicly_url := https://github.com/vpp-quic/quicly/releases/download/v$(quicly_version)/quicly_$(quicly_version).tar.gz
 
@@ -21,13 +21,13 @@ picotls_build_dir := $(B)/build-picotls
 
 define  quicly_build_cmds
        @cd $(quicly_build_dir) && \
-               $(CMAKE) -DCMAKE_INSTALL_PREFIX:PATH=$(quicly_install_dir) \
+               $(CMAKE) -DWITH_DTRACE=OFF -DCMAKE_INSTALL_PREFIX:PATH=$(quicly_install_dir) \
                $(quicly_src_dir) > $(quicly_build_log)
        @$(MAKE) $(MAKE_ARGS) -C $(quicly_build_dir) > $(quicly_build_log)
 
        @mkdir -p $(picotls_build_dir)
        @cd $(picotls_build_dir) && \
-               $(CMAKE) -DCMAKE_INSTALL_PREFIX:PATH=$(quicly_install_dir) \
+               $(CMAKE) -DWITH_DTRACE=OFF -DCMAKE_INSTALL_PREFIX:PATH=$(quicly_install_dir) \
                $(quicly_src_dir)/deps/picotls > $(quicly_build_log)
 endef