GBP: l3-out subnets
[vpp.git] / extras / vom / vom / CMakeLists.txt
index 5a5e5a7..f68a740 100644 (file)
@@ -68,16 +68,25 @@ endif()
 
 if(GBP_FILE)
   list(APPEND VOM_SOURCES
-    gbp_recirc_cmds.cpp
-    gbp_recirc.cpp
-    gbp_subnet_cmds.cpp
-    gbp_subnet.cpp
+    gbp_contract_cmds.cpp
+    gbp_contract.cpp
+    gbp_bridge_domain_cmds.cpp
+    gbp_bridge_domain.cpp
     gbp_endpoint_cmds.cpp
     gbp_endpoint.cpp
     gbp_endpoint_group_cmds.cpp
     gbp_endpoint_group.cpp
-    gbp_contract_cmds.cpp
-    gbp_contract.cpp
+    gbp_ext_itf.cpp
+    gbp_ext_itf_cmds.cpp
+    gbp_recirc_cmds.cpp
+    gbp_recirc.cpp
+    gbp_route_domain_cmds.cpp
+    gbp_route_domain.cpp
+    gbp_rule.cpp
+    gbp_subnet_cmds.cpp
+    gbp_subnet.cpp
+    gbp_vxlan.cpp
+    gbp_vxlan_cmds.cpp
   )
 endif()
 
@@ -185,11 +194,16 @@ endif()
 
 if(GBP_FILE)
   list(APPEND VOM_HEADERS
+    gbp_contract.hpp
+    gbp_bridge_domain.hpp
     gbp_endpoint.hpp
     gbp_endpoint_group.hpp
-    gbp_subnet.hpp
+    gbp_ext_itf.hpp
     gbp_recirc.hpp
-    gbp_contract.hpp
+    gbp_route_domain.hpp
+    gbp_rule.hpp
+    gbp_subnet.hpp
+    gbp_vxlan.hpp
   )
 endif()