Move java,lua api and remaining plugins to src/
[vpp.git] / src / Makefile.am
index e691a53..0fc437a 100644 (file)
@@ -79,7 +79,15 @@ include vnet.am
 include vpp.am
 include vpp-api-test.am
 
-SUBDIRS += vpp-api/python plugins
+SUBDIRS += plugins
+
+if ENABLE_PAPI
+SUBDIRS += vpp-api/python
+endif
+
+if ENABLE_JAPI
+SUBDIRS += vpp-api/java
+endif
 
 ###############################################################################
 # API