L2 Emulation
[vpp.git] / src / configure.ac
index 150930f..0e75403 100644 (file)
@@ -99,24 +99,20 @@ AC_DEFUN([DPDK_IS_PMD_ENABLED],
   m4_append_uniq([list_of_with], [$2], [, ])
 ])
 
-AC_DEFUN([DETECT_DPDK_IS_1702_OR_1705],
+# Check if compiler supports specific flag
+AC_DEFUN([CC_CHECK_FLAG],
 [
-  AC_MSG_CHECKING([for RTE_VERSION 17.02/17.05 in rte_version.h])
-  AC_TRY_RUN(
-    [
-    #include <rte_version.h>
-    int main()
-    {
-      return ((RTE_VER_YEAR != 17) ||
-             (RTE_VER_MONTH != 2 && RTE_VER_MONTH != 5));
-    }
-    ],
-    [dpdk_is_1702_or_1705=yes]
-    [AC_MSG_RESULT([yes])],
-    [dpdk_is_1702_or_1705=no]
-    [AC_MSG_RESULT([no])]
-  )
-  AM_CONDITIONAL(DPDK_IS_1702_OR_1705, test "$dpdk_is_1702_or_1705" = "yes")
+  AC_MSG_CHECKING([if $CC supports $1])
+  AC_LANG_PUSH([C])
+  ac_saved_cflags="$CFLAGS"
+  CFLAGS="-Werror $1"
+  AC_COMPILE_IFELSE([AC_LANG_PROGRAM([])],
+  [cc_flag_check=yes],
+  [cc_flag_check=no]
+)
+  AC_MSG_RESULT([$cc_flag_check])
+  CFLAGS="$ac_saved_cflags"
+  AC_LANG_POP([C])
 ])
 
 ###############################################################################
@@ -134,6 +130,7 @@ DISABLE_ARG(vlib,   [Disable vlib and dependant libs and binaries])
 DISABLE_ARG(svm,       [Disable svm and dependant libs and binaries])
 DISABLE_ARG(papi,      [Disable Python API bindings])
 DISABLE_ARG(japi,      [Disable Java API bindings])
+DISABLE_ARG(vom,       [Disable VPP object model bindings])
 
 # --with-X
 
@@ -159,6 +156,37 @@ AC_ARG_WITH(pre-data,
                *) with_pre_data="pre-data-not-set" ;;
             esac], [with_pre_data=128])
 
+###############################################################################
+# Target CPU flags
+###############################################################################
+
+# Check if compiler supports march=core-avx2
+CC_CHECK_FLAG("-march=core-avx2")
+AS_IF([test "$cc_flag_check" = yes],
+      [march_core_avx2=yes],
+      [march_core_avx2=no])
+AM_CONDITIONAL([CC_SUPPORTS_AVX2], [test "$march_core_avx2" = "yes"])
+
+# Check if compiler supports march=skylake-avx512
+CC_CHECK_FLAG("-march=skylake-avx512")
+AS_IF([test "$cc_flag_check" = yes],
+  [march_skylake_avx512=yes],
+  [march_skylake_avx512=no])
+AM_CONDITIONAL([CC_SUPPORTS_AVX512], [test "$march_skylake_avx512" = "yes"])
+
+AS_CASE([$build_cpu],
+       [x86_64], [CPU_FLAGS="-march=corei7 -mtune=corei7-avx"],
+       [aarch64], [CPU_FLAGS="-march=armv8-a+crc"],
+       [CPU_FLAGS=""],
+)
+AC_SUBST([CPU_FLAGS])
+
+AC_SUBST([CPU_AVX2_FLAGS],"-march=core-avx2 -mtune=core-avx2")
+AC_SUBST([CPU_AVX512_FLAGS],"-march=skylake-avx512 -mtune=skylake-avx512")
+
+AM_CONDITIONAL([CPU_X86_64], [test "$build_cpu" = "x86_64"])
+AM_CONDITIONAL([CPU_AARCH64], [test "$build_cpu" = "aarch64"])
+
 ###############################################################################
 # Substitutions and defines
 ###############################################################################
@@ -187,12 +215,14 @@ PLUGIN_ENABLED(gtpu)
 PLUGIN_ENABLED(ila)
 PLUGIN_ENABLED(ioam)
 PLUGIN_ENABLED(ixge)
+PLUGIN_ENABLED(kubeproxy)
 PLUGIN_ENABLED(lb)
 PLUGIN_ENABLED(memif)
 PLUGIN_ENABLED(pppoe)
 PLUGIN_ENABLED(sixrd)
 PLUGIN_ENABLED(nat)
 PLUGIN_ENABLED(stn)
+PLUGIN_ENABLED(l2e)
 
 ###############################################################################
 # Dependency checks
@@ -214,8 +244,6 @@ with_isa_l_crypto_lib=no
 DPDK_IS_PMD_ENABLED(LIBRTE_PMD_AESNI_MB, dpdk_aesni_mb_pmd)
 DPDK_IS_PMD_ENABLED(LIBRTE_PMD_AESNI_GCM, dpdk_aesni_gcm_pmd)
 
-DETECT_DPDK_IS_1702_OR_1705()
-
 AM_COND_IF([WITH_DPDK_AESNI_MB_PMD],
 [
   AC_CHECK_LIB([IPSec_MB], [submit_job_sse],
@@ -225,17 +253,9 @@ AM_COND_IF([WITH_DPDK_AESNI_MB_PMD],
 
 AM_COND_IF([WITH_DPDK_AESNI_GCM_PMD],
 [
-  AM_COND_IF([DPDK_IS_1702_OR_1705],
-  [
-    AC_CHECK_LIB([isal_crypto], [aesni_gcm128_init],
-                [with_isa_l_crypto_lib=yes],
-                [AC_MSG_ERROR([isal_crypto library not found])])
-  ],
-  [
-    AC_CHECK_LIB([IPSec_MB], [submit_job_sse],
-                [with_aesni_mb_lib=yes],
-                [AC_MSG_ERROR([IPSec_MB library not found])])
-  ])
+  AC_CHECK_LIB([IPSec_MB], [submit_job_sse],
+    [with_aesni_mb_lib=yes],
+    [AC_MSG_ERROR([IPSec_MB library not found])])
 ])
 
 m4_append([list_of_with], [aesni_mb_lib], [, ])