MAP: Move MAP-E/T to a plugin.
[vpp.git] / src / configure.ac
index 56080e1..170a908 100644 (file)
@@ -1,17 +1,22 @@
-AC_INIT([vpp], [18.01], [vpp-dev@fd.io])
+AC_INIT([vpp], [18.07], [vpp-dev@fd.io])
 LT_INIT
 AC_CONFIG_AUX_DIR([.])
 AM_INIT_AUTOMAKE([subdir-objects])
 AM_SILENT_RULES([yes])
-AC_CONFIG_FILES([Makefile plugins/Makefile vpp-api/python/Makefile vpp-api/java/Makefile vpp-api/vapi/Makefile vpp-api/vom/Makefile])
+AC_CONFIG_FILES([ \
+  Makefile \
+  plugins/Makefile \
+  vpp-api/python/Makefile \
+  vpp-api/java/Makefile \
+  vpp-api/vapi/Makefile \
+  vlib/config.h \
+])
 AC_CONFIG_MACRO_DIR([m4])
 
 AC_PROG_CC
-AC_PROG_CXX
 AC_PROG_CPP
 AM_PROG_AS
 AM_PROG_LIBTOOL
-AC_PROG_YACC
 AM_PATH_PYTHON
 
 AM_CONDITIONAL([CROSSCOMPILE], [test "$cross_compiling" == "yes"])
@@ -99,26 +104,6 @@ AC_DEFUN([DPDK_IS_PMD_ENABLED],
   m4_append_uniq([list_of_with], [$2], [, ])
 ])
 
-AC_DEFUN([DETECT_DPDK_IS_1702_OR_1705],
-[
-  AC_MSG_CHECKING([for RTE_VERSION 17.02/17.05 in rte_version.h])
-  AC_TRY_RUN(
-    [
-    #include <rte_version.h>
-    int main()
-    {
-      return ((RTE_VER_YEAR != 17) ||
-             (RTE_VER_MONTH != 2 && RTE_VER_MONTH != 5));
-    }
-    ],
-    [dpdk_is_1702_or_1705=yes]
-    [AC_MSG_RESULT([yes])],
-    [dpdk_is_1702_or_1705=no]
-    [AC_MSG_RESULT([no])]
-  )
-  AM_CONDITIONAL(DPDK_IS_1702_OR_1705, test "$dpdk_is_1702_or_1705" = "yes")
-])
-
 # Check if compiler supports specific flag
 AC_DEFUN([CC_CHECK_FLAG],
 [
@@ -135,6 +120,67 @@ AC_DEFUN([CC_CHECK_FLAG],
   AC_LANG_POP([C])
 ])
 
+# This function deduces the BUILD HOST cache-line size by
+# inspecting /sys and/or /proc depending on the kernel / arch in use
+as_fn_log2_cache_line_size_p()
+{
+  sysfs_cache_path="/sys/devices/system/cpu/cpu0/cache/index0/coherency_line_size"
+  m4_define([read_cache_line_size_from_sysfs], [`head -n 1 $1`])
+  m4_define([read_midr_implementer],
+            [`awk '/implementer/ {print $[]4;exit}' /proc/cpuinfo`])
+  m4_define([read_midr_cpuid],
+            [`awk '/part/ {print $[]4;exit}' /proc/cpuinfo`])
+
+  #Check if sysfs path exists,to ignore warning, else do manual mapping
+  AC_CHECK_FILE($sysfs_cache_path,
+    [
+      cache_line_size=read_cache_line_size_from_sysfs($sysfs_cache_path);
+      if test $cache_line_size = "32"  ; then
+          log2_cache_line_size="5";
+      elif test $cache_line_size = "64"  ; then
+          log2_cache_line_size="6";
+      elif test $cache_line_size = "128"  ; then
+          log2_cache_line_size="7";
+      fi
+      AC_MSG_NOTICE([cache_line_size/log2_cache_line_size deduced as $cache_line_size/$log2_cache_line_size])
+    ],
+    [
+        #Define Implementer Ids here
+        implementer_id_cavium=0x43
+
+        #Define CPU Ids here
+        cpu_id_cavium_thunderx_cn88xx=0x0a1
+        cpu_id_cavium_thunderx2_cn99xx=0x0af
+
+        implementer=read_midr_implementer()
+        cpuid=read_midr_cpuid()
+
+        AC_MSG_CHECKING([for implementerid/cpuid to set log2_cache_line_size])
+
+        # Switch case to map log2_cache_line_size for implementer/cpuid combination.
+        # Default case of Switch sets log2_cache_line_size to 6
+        AS_CASE($implementer,
+              #Switch Case for Cavium SoC's
+              [$implementer_id_cavium],
+                  [AS_CASE($cpuid,
+                      #Only ThunderX2 is 64B. Remaining chips are 128B
+                      [$cpu_id_cavium_thunderx2_cn99xx],
+                            [AC_MSG_RESULT([Cavium/ThunderX2]);log2_cache_line_size=6],
+                      [$cpu_id_cavium_thunderx_cn88xx],
+                            [AC_MSG_RESULT([Cavium/ThunderX]);log2_cache_line_size=7],
+                      [log2_cache_line_size=7;AC_MSG_RESULT([Cavium/OCTEONTx($cpuid)])]
+                   )],
+              #Add implementer specific case here:
+
+              #Default case: 64B for all SoC's
+              [log2_cache_line_size=6;AC_MSG_RESULT([$implementer/$cpuid])]
+        )
+      AC_MSG_NOTICE([log2_cache_line_size deduced as $log2_cache_line_size])
+    ]
+  )
+  echo $log2_cache_line_size
+}
+
 ###############################################################################
 # configure arguments
 ###############################################################################
@@ -150,13 +196,23 @@ DISABLE_ARG(vlib, [Disable vlib and dependant libs and binaries])
 DISABLE_ARG(svm,       [Disable svm and dependant libs and binaries])
 DISABLE_ARG(papi,      [Disable Python API bindings])
 DISABLE_ARG(japi,      [Disable Java API bindings])
-DISABLE_ARG(vom,       [Disable VPP object model bindings])
 
 # --with-X
 
 # --without-X
 WITHOUT_ARG(libssl,    [Disable libssl])
 WITHOUT_ARG(apicli,    [Disable binary api CLI])
+WITHOUT_ARG(mbedtls,   [Disable mbedtls])
+WITHOUT_ARG(libnuma,   [for non numa architectures])
+
+AC_ARG_WITH(log2-cache-line-bytes,
+            AC_HELP_STRING([--with-log2-cache-line-bytes],[Set the cache line size, --with-log2-cache-line-bytes=5|6|7|auto]),
+           [case $with_log2_cache_line_bytes in
+             5 | 6 | 7);;
+             auto) with_log2_cache_line_bytes=`as_fn_log2_cache_line_size_p`;;
+              *) with_log2_cache_line_bytes="CONFIG_ERROR";;
+             esac],
+              [with_log2_cache_line_bytes=`as_fn_log2_cache_line_size_p`])
 
 AC_ARG_WITH(unix,
             AC_HELP_STRING([--with-unix],[Compile unix version of clib]),
@@ -194,7 +250,7 @@ AS_IF([test "$cc_flag_check" = yes],
   [march_skylake_avx512=no])
 AM_CONDITIONAL([CC_SUPPORTS_AVX512], [test "$march_skylake_avx512" = "yes"])
 
-AS_CASE([$build_cpu],
+AS_CASE([$host_cpu],
        [x86_64], [CPU_FLAGS="-march=corei7 -mtune=corei7-avx"],
        [aarch64], [CPU_FLAGS="-march=armv8-a+crc"],
        [CPU_FLAGS=""],
@@ -204,18 +260,29 @@ AC_SUBST([CPU_FLAGS])
 AC_SUBST([CPU_AVX2_FLAGS],"-march=core-avx2 -mtune=core-avx2")
 AC_SUBST([CPU_AVX512_FLAGS],"-march=skylake-avx512 -mtune=skylake-avx512")
 
-AM_CONDITIONAL([CPU_X86_64], [test "$build_cpu" = "x86_64"])
-AM_CONDITIONAL([CPU_AARCH64], [test "$build_cpu" = "aarch64"])
+AM_CONDITIONAL([CPU_X86_64], [test "$host_cpu" = "x86_64"])
+AM_CONDITIONAL([CPU_AARCH64], [test "$host_cpu" = "aarch64"])
+
+###############################################################################
+# misc compiler flags
+###############################################################################
+
+CC_CHECK_FLAG("-Wno-address-of-packed-member")
+AS_IF([test "$cc_flag_check" = yes],
+       [CFLAGS="${CFLAGS} -Wno-address-of-packed-member"], [])
 
 ###############################################################################
 # Substitutions and defines
 ###############################################################################
 
 AC_SUBST(PRE_DATA_SIZE,                [$with_pre_data])
+AC_SUBST(LOG2_CACHE_LINE_BYTES, [$with_log2_cache_line_bytes])
 AC_SUBST(APICLI,               [-DVPP_API_TEST_BUILTIN=${n_with_apicli}])
 
 AC_DEFINE_UNQUOTED(DPDK_SHARED_LIB,    [${n_enable_dpdk_shared}])
 AC_DEFINE_UNQUOTED(WITH_LIBSSL,                [${n_with_libssl}])
+AC_DEFINE_UNQUOTED(WITH_MBEDTLS,       [${n_with_mbedtls}])
+AC_DEFINE_UNQUOTED(WITH_LIBNUMA,       [${n_with_libnuma}])
 
 
 # Silence following noise:
@@ -228,23 +295,38 @@ AC_SUBST(AR_FLAGS)
 ###############################################################################
 
 # Please keep alphabetical order
+PLUGIN_ENABLED(abf)
 PLUGIN_ENABLED(acl)
+PLUGIN_ENABLED(avf)
+PLUGIN_ENABLED(cdp)
 PLUGIN_ENABLED(dpdk)
 PLUGIN_ENABLED(flowprobe)
+PLUGIN_ENABLED(gbp)
 PLUGIN_ENABLED(gtpu)
+PLUGIN_ENABLED(igmp)
 PLUGIN_ENABLED(ila)
 PLUGIN_ENABLED(ioam)
 PLUGIN_ENABLED(ixge)
+PLUGIN_ENABLED(l2e)
+PLUGIN_ENABLED(lacp)
 PLUGIN_ENABLED(lb)
+PLUGIN_ENABLED(mactime)
+PLUGIN_ENABLED(marvell)
 PLUGIN_ENABLED(memif)
 PLUGIN_ENABLED(pppoe)
-PLUGIN_ENABLED(sixrd)
 PLUGIN_ENABLED(nat)
+PLUGIN_ENABLED(map)
+PLUGIN_ENABLED(srv6ad)
+PLUGIN_ENABLED(srv6am)
+PLUGIN_ENABLED(srv6as)
 PLUGIN_ENABLED(stn)
+PLUGIN_ENABLED(tlsmbedtls)
+PLUGIN_ENABLED(tlsopenssl)
 
 ###############################################################################
 # Dependency checks
 ###############################################################################
+AC_CHECK_FUNC([memfd_create], [AC_DEFINE([HAVE_MEMFD_CREATE], [1], [Define if memfd exists])])
 
 AM_COND_IF([ENABLE_DPDK_SHARED],
 [
@@ -262,8 +344,6 @@ with_isa_l_crypto_lib=no
 DPDK_IS_PMD_ENABLED(LIBRTE_PMD_AESNI_MB, dpdk_aesni_mb_pmd)
 DPDK_IS_PMD_ENABLED(LIBRTE_PMD_AESNI_GCM, dpdk_aesni_gcm_pmd)
 
-DETECT_DPDK_IS_1702_OR_1705()
-
 AM_COND_IF([WITH_DPDK_AESNI_MB_PMD],
 [
   AC_CHECK_LIB([IPSec_MB], [submit_job_sse],
@@ -273,17 +353,9 @@ AM_COND_IF([WITH_DPDK_AESNI_MB_PMD],
 
 AM_COND_IF([WITH_DPDK_AESNI_GCM_PMD],
 [
-  AM_COND_IF([DPDK_IS_1702_OR_1705],
-  [
-    AC_CHECK_LIB([isal_crypto], [aesni_gcm128_init],
-                [with_isa_l_crypto_lib=yes],
-                [AC_MSG_ERROR([isal_crypto library not found])])
-  ],
-  [
-    AC_CHECK_LIB([IPSec_MB], [submit_job_sse],
-                [with_aesni_mb_lib=yes],
-                [AC_MSG_ERROR([IPSec_MB library not found])])
-  ])
+  AC_CHECK_LIB([IPSec_MB], [submit_job_sse],
+    [with_aesni_mb_lib=yes],
+    [AC_MSG_ERROR([IPSec_MB library not found])])
 ])
 
 m4_append([list_of_with], [aesni_mb_lib], [, ])
@@ -292,46 +364,51 @@ AM_CONDITIONAL(WITH_AESNI_MB_LIB, test "$with_aesni_mb_lib" = "yes")
 m4_append([list_of_with], [isa_l_crypto_lib], [, ])
 AM_CONDITIONAL(WITH_ISA_L_CRYPTO_LIB, test "$with_isa_l_crypto_lib" = "yes")
 
-
-with_ibverbs_lib=no
-DPDK_IS_PMD_ENABLED(LIBRTE_MLX4_PMD, dpdk_mlx4_pmd)
-AM_COND_IF([WITH_DPDK_MLX4_PMD],
+AM_COND_IF([ENABLE_G2],
 [
-  AC_CHECK_LIB([ibverbs], [ibv_fork_init],
-              [with_ibverbs_lib=yes],
-              [AC_MSG_ERROR([ibverbs library not found])])
+  PKG_CHECK_MODULES(g2, gtk+-2.0)
 ])
 
-DPDK_IS_PMD_ENABLED(LIBRTE_MLX5_PMD, dpdk_mlx5_pmd)
-AM_COND_IF([WITH_DPDK_MLX5_PMD],
+AM_COND_IF([ENABLE_MARVELL_PLUGIN],
 [
-  AC_CHECK_LIB([ibverbs], [ibv_fork_init],
-              [with_ibverbs_lib=yes],
-              [AC_MSG_ERROR([ibverbs library not found])])
+  AC_CHECK_LIB( [musdk], [pp2_init],
+    [],
+    [
+      AC_MSG_WARN([Marvell MUSDK library with PP2 support not found. Plugin disabled.])
+      enable_marvell_plugin=no
+      AM_CONDITIONAL(ENABLE_MARVELL_PLUGIN, false)
+    ])
 ])
 
-m4_append([list_of_with], [ibverbs_lib], [, ])
-AM_CONDITIONAL(WITH_IBVERBS_LIB, test "$with_ibverbs_lib" = "yes")
-
-
-AM_COND_IF([ENABLE_G2],
+AM_COND_IF([WITH_MBEDTLS], [],
 [
-  PKG_CHECK_MODULES(g2, gtk+-2.0)
+  AC_MSG_WARN([mbedtls not enabled. Disabling tlsmbedtls plugin])
+  enable_tlsmbedtls_plugin=no
+  AM_CONDITIONAL(ENABLE_TLSMBEDTLS_PLUGIN, false)
 ])
 
-# If cross-compiling, we need external vppapigen and we cannot continue without it
-# For native builds, we just set dependency on vpppaigen binary in top_builddir
-AM_COND_IF([CROSSCOMPILE],
+AM_COND_IF([ENABLE_TLSMBEDTLS_PLUGIN],
 [
-  AC_PATH_PROG([VPPAPIGEN], [vppapigen], [no])
-  if test "$VPPAPIGEN" = "no"; then
-    AC_MSG_ERROR([Externaly built vppapigen is needed when cross-compiling...])
-  fi
-],[
-  VPPAPIGEN=\$\(top_builddir\)/vppapigen
+  AC_CHECK_HEADERS([mbedtls/ssl.h], [],
+    [
+      AC_MSG_WARN([mbedtls headers not found. TLS engine implementation disabled])
+      enable_tlsmbedtls_plugin=no
+      AM_CONDITIONAL(ENABLE_TLSMBEDTLS_PLUGIN, false)
+    ], [])
 ])
-AC_SUBST([VPPAPIGEN])
 
+AM_COND_IF([WITH_LIBSSL],
+[
+  AC_CHECK_LIB([ssl -lcrypto], [SSL_set_async_callback],
+    [
+      AC_DEFINE([HAVE_OPENSSL_ASYNC], [1], [Define if new openssl interface exists])
+    ])
+],
+[
+  AC_MSG_WARN([openssl not enabled. Disabling tlsopenssl plugin])
+  enable_tlsopenssl_plugin=no
+  AM_CONDITIONAL(ENABLE_TLSOPENSSL_PLUGIN, false)
+])
 
 ###############################################################################
 # JAVA
@@ -369,6 +446,7 @@ PRINT_VAL([includedir], ${includedir})
 PRINT_VAL([CFLAGS], ${CFLAGS})
 PRINT_VAL([CPPFLAGS], ${CPPFLAGS})
 PRINT_VAL([LDFLAGS], ${LDFLAGS})
+PRINT_VAL([LOG2_CACHE_LINE_BYTES], ${with_log2_cache_line_bytes})
 AM_COND_IF([ENABLE_JAPI],
 [
   PRINT_VAL([JAVA_VERSION], ${JAVA_VERSION})