VPPAPIGEN: vppapigen replacement in Python PLY.
[vpp.git] / src / examples / sample-plugin / Makefile.am
index a3a9a8d..5c279c4 100644 (file)
@@ -32,14 +32,12 @@ include sample.am
 
 %.api.h: %.api
        mkdir -p `dirname $@` ; \
-       $(CC) $(CPPFLAGS) -E -P -C -x c $^ \
-       | vppapigen --input - --output $@ --show-name $@
+       vppapigen --input $^ --output $@
 
 %.api.json: %.api
        @echo "  JSON APIGEN  " $@ ;                            \
        mkdir -p `dirname $@` ;                                 \
-       $(CC) $(CPPFLAGS) -E -P -C -x c $^                      \
-       | vppapigen --input - --json $@
+       vppapigen --input $^ JSON --output $@
 
 apidir = $(prefix)/api/plugins
 apiincludedir = ${includedir}/vpp_plugins