crypto-native: rename crypto_ia32 to crypto_native
[vpp.git] / src / plugins / crypto_native / CMakeLists.txt
similarity index 89%
rename from src/plugins/crypto_ia32/CMakeLists.txt
rename to src/plugins/crypto_native/CMakeLists.txt
index 0a8b560..cd701ec 100644 (file)
@@ -15,7 +15,7 @@ if(NOT CMAKE_SYSTEM_PROCESSOR MATCHES "amd64.*|x86_64.*|AMD64.*")
   return()
 endif()
 
-add_vpp_plugin(crypto_ia32 SOURCES main.c)
+add_vpp_plugin(crypto_native SOURCES main.c)
 
 list(APPEND VARIANTS "sse42\;-march=silvermont")
 list(APPEND VARIANTS "avx2\;-march=core-avx2")
@@ -29,9 +29,9 @@ endif()
 foreach(VARIANT ${VARIANTS})
   list(GET VARIANT 0 v)
   list(GET VARIANT 1 f)
-  set(l crypto_ia32_${v})
+  set(l crypto_native_${v})
   add_library(${l} OBJECT aes_cbc.c aes_gcm.c)
   set_target_properties(${l} PROPERTIES POSITION_INDEPENDENT_CODE ON)
   target_compile_options(${l} PUBLIC ${f} -Wall -fno-common -maes)
-  target_sources(crypto_ia32_plugin PRIVATE $<TARGET_OBJECTS:${l}>)
+  target_sources(crypto_native_plugin PRIVATE $<TARGET_OBJECTS:${l}>)
 endforeach()