crypto-native: add AArch64 AES-GCM native implementation
[vpp.git] / src / plugins / crypto_native / CMakeLists.txt
index 9ac2946..c6d916d 100644 (file)
@@ -26,7 +26,7 @@ endif()
 
 if(CMAKE_SYSTEM_PROCESSOR MATCHES "^(aarch64.*|AARCH64.*)")
   list(APPEND VARIANTS "armv8\;-march=armv8.1-a+crc+crypto")
-  set (COMPILE_FILES aes_cbc.c)
+  set (COMPILE_FILES aes_cbc.c aes_gcm.c)
   set (COMPILE_OPTS -Wall -fno-common)
 endif()