rdma: fix DPDK MLX driver conflict
[vpp.git] / src / plugins / dpdk / CMakeLists.txt
index 1818ada..b743d59 100644 (file)
@@ -106,11 +106,7 @@ if(DPDK_RTE_LIBRTE_MLX4_PMD OR DPDK_RTE_LIBRTE_MLX5_PMD)
   if (DPDK_RTE_IBVERBS_LINK_DLOPEN)
     message(STATUS "DPDK depends on libmnl (Mellanox PMD requirement)")
   else()
-    vpp_plugin_find_library(dpdk IBVERBS_LIB "ibverbs")
-    list(APPEND DPDK_LINK_LIBRARIES "${IBVERBS_LIB}")
-    vpp_plugin_find_library(dpdk MLX5_LIB "mlx5")
-    list(APPEND DPDK_LINK_LIBRARIES "${MLX5_LIB}")
-    message(STATUS "DPDK depends on libmnl, libibverbs, libmlx5 (Mellanox PMD requirement)")
+    message(WARNING "unsupported DPDK configuration: DPDK Mellanox PMD requires RTE_IBVERBS_LINK_DLOPEN")
   endif()
 endif()