CMake as an alternative to autotools (experimental)
[vpp.git] / src / plugins / igmp / CMakeLists.txt
diff --git a/src/plugins/igmp/CMakeLists.txt b/src/plugins/igmp/CMakeLists.txt
new file mode 100644 (file)
index 0000000..a3f976c
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+#     http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(igmp_plugin
+  igmp.api
+  igmp.c
+  igmp_query.c
+  igmp_report.c
+  igmp_group.c
+  igmp_src.c
+  igmp_config.c
+  igmp_cli.c
+  igmp_api.c
+  igmp_input.c
+  igmp_timer.c
+  igmp_pkt.c
+  igmp_ssm_range.c
+  igmp_format.c
+)