cmake: Add protocol.h to lacp plugin .h includes
[vpp.git] / src / plugins / lacp / CMakeLists.txt
index 0bd79e9..8e0e607 100644 (file)
@@ -11,8 +11,8 @@
 # See the License for the specific language governing permissions and
 # limitations under the License.
 
-add_vpp_plugin(lacp_plugin
-  lacp.api
+add_vpp_plugin(lacp
+  SOURCES
   lacp.c
   lacp_api.c
   selection.c
@@ -23,10 +23,22 @@ add_vpp_plugin(lacp_plugin
   cli.c
   input.c
   node.c
-)
 
-add_vpp_api_test_plugin(lacp_test_plugin
+  API_FILES
   lacp.api
+
+  INSTALL_HEADERS
+  protocol.h
+  machine.h
+  rx_machine.h
+  tx_machine.h
+  mux_machine.h
+  ptx_machine.h
+  node.h
+  lacp_all_api_h.h
+  lacp_msg_enum.h
+
+  API_TEST_SOURCES
   lacp_test.c
 )