mactime: add a "top" command to watch device stats
[vpp.git] / src / plugins / mactime / CMakeLists.txt
index ac5077d..5477674 100644 (file)
@@ -22,3 +22,21 @@ add_vpp_plugin(mactime
   API_TEST_SOURCES
   mactime_test.c
 )
+
+option(VPP_BUILD_MACTIME_TOP "Build mactime plugin 'top' tool" OFF)
+if(VPP_BUILD_MACTIME_TOP)
+  add_vpp_executable(mactime_top ENABLE_EXPORTS
+    SOURCES
+    mactime_top.c
+
+    DEPENDS api_headers
+
+    LINK_LIBRARIES
+    vlibmemoryclient
+    vppapiclient
+    svm
+    vppinfra
+    Threads::Threads
+    rt m dl crypto
+    )
+endif()