MAP: Use explicit address/prefix types in API
[vpp.git] / src / plugins / map / CMakeLists.txt
index 1dc1bed..20d5dfe 100644 (file)
@@ -11,8 +11,8 @@
 # See the License for the specific language governing permissions and
 # limitations under the License.
 
-add_vpp_plugin(map_plugin
-  map.api
+add_vpp_plugin(map
+  SOURCES
   ip4_map.c
   ip4_map_t.c
   ip6_map.c
@@ -20,4 +20,13 @@ add_vpp_plugin(map_plugin
   map_api.c
   map.c
   map_dpo.c
+
+  API_FILES
+  map.api
+
+  INSTALL_HEADERS
+  map_all_api_h.h
+  map_msg_enum.h
+  map_dpo.h
+  map.h
 )