nat: use SVR
[vpp.git] / src / plugins / nat / CMakeLists.txt
index 20cf0e7..372bbd6 100644 (file)
@@ -16,12 +16,18 @@ add_vpp_plugin(nat
   nat.c
   nat_api.c
   in2out.c
+  in2out_ed.c
   out2in.c
+  out2in_ed.c
   nat_ipfix_logging.c
   nat_det.c
-  nat_reass.c
+  nat_det_in2out.c
+  nat_det_out2in.c
   nat_dpo.c
   nat44_cli.c
+  nat44_handoff.c
+  nat44_hairpinning.c
+  nat44_classify.c
   nat64.c
   nat64_cli.c
   nat64_in2out.c
@@ -39,6 +45,28 @@ add_vpp_plugin(nat
   nat66_in2out.c
   nat66_out2in.c
   nat_affinity.c
+  nat_format.c
+  nat_syslog.c
+  nat_ha.c
+
+  MULTIARCH_SOURCES
+  dslite_ce_decap.c
+  dslite_ce_encap.c
+  dslite_in2out.c
+  dslite_out2in.c
+  in2out.c
+  in2out_ed.c
+  nat44_classify.c
+  nat44_hairpinning.c
+  nat44_handoff.c
+  nat64_in2out.c
+  nat64_out2in.c
+  nat66_in2out.c
+  nat66_out2in.c
+  nat_det_in2out.c
+  nat_det_out2in.c
+  out2in.c
+  out2in_ed.c
 
   API_FILES
   nat.api